summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-10-20 22:31:19 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-10-20 22:31:19 +0000
commit4cbd0b10b45a33406a56a06e8383f17b2d17d296 (patch)
treeff73033996417bd57583f15c27a62b7b41d358d7 /www-client
parentVersion bump. Carry over lafiles patch. (diff)
downloadgentoo-2-4cbd0b10b45a33406a56a06e8383f17b2d17d296.tar.gz
gentoo-2-4cbd0b10b45a33406a56a06e8383f17b2d17d296.tar.bz2
gentoo-2-4cbd0b10b45a33406a56a06e8383f17b2d17d296.zip
Version bump synced with release, should improve speed on amd64 and audio stuttering with HTML5
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog9
-rw-r--r--www-client/chromium/chromium-4.0.223.5.ebuild (renamed from www-client/chromium/chromium-4.0.219.4_p27359.ebuild)25
2 files changed, 17 insertions, 17 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index f3a0b4a22dbd..487c24dedbfb 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.14 2009/10/13 22:55:29 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.15 2009/10/20 22:31:19 voyageur Exp $
+
+*chromium-4.0.223.5 (20 Oct 2009)
+
+ 20 Oct 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ -chromium-4.0.219.4_p27359.ebuild, +chromium-4.0.223.5.ebuild:
+ Version bump synced with release, should improve speed on amd64 and audio
+ stuttering with HTML5
*chromium-4.0.222.6_p28888 (13 Oct 2009)
diff --git a/www-client/chromium/chromium-4.0.219.4_p27359.ebuild b/www-client/chromium/chromium-4.0.223.5.ebuild
index fd87392893ec..5b4e3e6fed2d 100644
--- a/www-client/chromium/chromium-4.0.219.4_p27359.ebuild
+++ b/www-client/chromium/chromium-4.0.223.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.219.4_p27359.ebuild,v 1.2 2009/09/30 12:36:10 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.223.5.ebuild,v 1.1 2009/10/20 22:31:19 voyageur Exp $
EAPI="2"
inherit eutils multilib toolchain-funcs
@@ -25,8 +25,8 @@ RDEPEND="app-arch/bzip2
media-libs/jpeg
media-libs/libpng
>=media-video/ffmpeg-0.5_p19787
- sys-libs/zlib
>=x11-libs/gtk+-2.14.7"
+# sys-libs/zlib
# >=dev-libs/libevent-1.4.13
# dev-db/sqlite:3
DEPEND="${RDEPEND}
@@ -36,12 +36,6 @@ DEPEND="${RDEPEND}
export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
src_prepare() {
- # Needed until we add back "rootdir=.", see below
- for i in app webkit third_party/ffmpeg build/util base chrome v8/tools/gyp
- do
- ln -s "${S}"/out ${i}/out
- done
-
# Changing this in ~/include.gypi does not work
sed -i "s/'-Werror'/''/" build/common.gypi || die "Werror sed failed"
# Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
@@ -49,8 +43,10 @@ src_prepare() {
# Add configuration flag to use system libevent
epatch "${FILESDIR}"/${PN}-use_system_libevent.patch
- # Display correct svn revision in about box
- echo "${PV/[0-9.]*\_p}" > build/LASTCHANGE.in || die "setting revision failed"
+ # Display correct svn revision in about box (if not a release)
+ if [[ "${PV}" =~ "_p" ]]; then
+ echo "${PV/[0-9.]*\_p}" > build/LASTCHANGE.in || die "setting revision failed"
+ fi
}
src_configure() {
@@ -67,7 +63,8 @@ EOF
export HOME="${S}"
# Configuration options (system libraries)
- local myconf="-Duse_system_bzip2=1 -Duse_system_zlib=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1 -Duse_system_ffmpeg=1 -Dlinux_use_tcmalloc=1"
+ local myconf="-Duse_system_bzip2=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1 -Duse_system_ffmpeg=1 -Dlinux_use_tcmalloc=1"
+ # -Duse_system_zlib=1: needs mozzconf.h and some MOZ_Z_* functions
# -Duse_system_libevent=1: http://crbug.com/22140
# -Duse_system_sqlite=1 : http://crbug.com/22208
# Others still bundled: icu (not possible?), hunspell (changes required for sandbox support)
@@ -86,12 +83,8 @@ EOF
}
src_compile() {
- # Broken for "Argument list too long":
- # http://code.google.com/p/chromium/issues/detail?id=19854
- # http://code.google.com/p/gyp/issues/detail?id=71
- # When this is fixed, remove the src_prepare
- # and add back "rootdir=${S}"
emake -r V=1 chrome chrome_sandbox BUILDTYPE=Release \
+ rootdir="${S}" \
CC=$(tc-getCC) \
CXX=$(tc-getCXX) \
AR=$(tc-getAR) \