summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-06-05 09:56:32 +0000
committerPacho Ramos <pacho@gentoo.org>2011-06-05 09:56:32 +0000
commit87274d42c0cb5e6a8f470ddaf82ce3347e49ac52 (patch)
tree99ffed67569ae1553b5bd5561330f9497ba7f66b /www-client
parentVersion bump to 2.0.3. Drop older overshadowed versions. Fixes bug #359127. (diff)
downloadgentoo-2-87274d42c0cb5e6a8f470ddaf82ce3347e49ac52.tar.gz
gentoo-2-87274d42c0cb5e6a8f470ddaf82ce3347e49ac52.tar.bz2
gentoo-2-87274d42c0cb5e6a8f470ddaf82ce3347e49ac52.zip
Add support for adblock extension as reported by Jani Kananen in bug #370081, the problem was fixed by upstream in newer glib versions time ago, RDEPENDing then on glib version I have used to confirm the original problem went away. Remove old.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany-extensions/ChangeLog11
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.32.0-r1.ebuild (renamed from www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild)37
2 files changed, 27 insertions, 21 deletions
diff --git a/www-client/epiphany-extensions/ChangeLog b/www-client/epiphany-extensions/ChangeLog
index e164bc91d2d4..184553eb7ecf 100644
--- a/www-client/epiphany-extensions/ChangeLog
+++ b/www-client/epiphany-extensions/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-client/epiphany-extensions
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.147 2011/04/28 18:47:12 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.148 2011/06/05 09:56:32 pacho Exp $
+
+*epiphany-extensions-2.32.0-r1 (05 Jun 2011)
+
+ 05 Jun 2011; Pacho Ramos <pacho@gentoo.org>
+ -epiphany-extensions-2.30.2.ebuild, +epiphany-extensions-2.32.0-r1.ebuild:
+ Add support for adblock extension as reported by Jani Kananen in bug #370081,
+ the problem was fixed by upstream in newer glib versions time ago, RDEPENDing
+ then on glib version I have used to confirm the original problem went away.
+ Remove old.
28 Apr 2011; Mark Loeser <halcy0n@gentoo.org>
-epiphany-extensions-2.26.1-r1.ebuild:
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.32.0-r1.ebuild
index 7c8e3bbd2d91..4df2de1af7fe 100644
--- a/www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.32.0-r1.ebuild
@@ -1,27 +1,28 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.30.2.ebuild,v 1.4 2011/03/21 23:24:54 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.32.0-r1.ebuild,v 1.1 2011/06/05 09:56:32 pacho Exp $
-EAPI="2"
+EAPI="3"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2"
-inherit gnome2 versionator
-
-MY_MAJORV=$(get_version_component_range 1-2)
+inherit gnome2 python
DESCRIPTION="Extensions for the Epiphany web browser"
-HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+HOMEPAGE="http://projects.gnome.org/epiphany/extensions.html"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="dbus examples pcre"
-RDEPEND=">=www-client/epiphany-${MY_MAJORV}
+RDEPEND=">=www-client/epiphany-2.30.0
app-text/opensp
- >=dev-libs/glib-2.15.5:2
+ >=dev-libs/glib-2.28.7:2
>=gnome-base/gconf-2.0:2
>=dev-libs/libxml2-2.6:2
- >=x11-libs/gtk+-2.19.5:2
+ >=x11-libs/gtk+-2.21.6:2
>=net-libs/webkit-gtk-1.1:2
dbus? ( >=dev-libs/dbus-glib-0.34 )
@@ -33,33 +34,29 @@ DEPEND="${RDEPEND}
# eautoreconf dependencies:
# gnome-base/gnome-common
-DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
-# FIXME: Open security issues:
-# FIXME: - adblock ( https://bugzilla.gnome.org/show_bug.cgi?id=595255 )
# FIXME: broken extensions:
# FIXME: - session-saver ( https://bugzilla.gnome.org/show_bug.cgi?id=316245 )
pkg_setup() {
local extensions=""
-
extensions="actions auto-reload auto-scroller certificates \
error-viewer extensions-manager-ui gestures html5tube \
java-console livehttpheaders page-info permissions \
push-scroller select-stylesheet \
smart-bookmarks soup-fly tab-groups tab-states"
use dbus && extensions="${extensions} rss"
-
- use pcre && extensions="${extensions} greasemonkey"
-
+ use pcre && extensions="${extensions} adblock greasemonkey"
use examples && extensions="${extensions} sample"
G2CONF="${G2CONF}
--disable-maintainer-mode
--with-extensions=$(echo "${extensions}" | sed -e 's/[[:space:]]\+/,/g')"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ python_set_active_version 2
}
-src_install() {
- gnome2_src_install
- find "${D}" -name "*.la" -delete || die "remove of la files failed"
+src_prepare() {
+ gnome2_src_prepare
+ python_convert_shebangs -r 2 .
}