summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-08-20 22:50:30 +0000
committerJoe McCann <joem@gentoo.org>2005-08-20 22:50:30 +0000
commit9a67f47dc3b228160e8763fadd9a1ef748f94dcc (patch)
treef223c2e67b33406100346a19c4227f812b55f68b /www-client
parentMarked ~ppc (diff)
downloadgentoo-2-9a67f47dc3b228160e8763fadd9a1ef748f94dcc.tar.gz
gentoo-2-9a67f47dc3b228160e8763fadd9a1ef748f94dcc.tar.bz2
gentoo-2-9a67f47dc3b228160e8763fadd9a1ef748f94dcc.zip
revbump for adblock fix
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany-extensions/Manifest2
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-1.6.4-r1.ebuild75
-rw-r--r--www-client/epiphany-extensions/files/digest-epiphany-extensions-1.6.4-r11
3 files changed, 78 insertions, 0 deletions
diff --git a/www-client/epiphany-extensions/Manifest b/www-client/epiphany-extensions/Manifest
index cb0a084ff85e..37f386c0ba6a 100644
--- a/www-client/epiphany-extensions/Manifest
+++ b/www-client/epiphany-extensions/Manifest
@@ -3,9 +3,11 @@ MD5 82452a5693e265225e96d4222547dafa epiphany-extensions-1.6.0.ebuild 1210
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 e2281d1a43dee1f005d07cb43110aeb1 epiphany-extensions-1.6.4.ebuild 1971
MD5 d1883b0297778d7f0cdcbbc01a6f198f epiphany-extensions-1.7.4.ebuild 1989
+MD5 e2281d1a43dee1f005d07cb43110aeb1 epiphany-extensions-1.6.4-r1.ebuild 1971
MD5 707f7a46f60ea0b7cf60bda490cdbf9e files/digest-epiphany-extensions-1.6.0 78
MD5 372d4cda16db1e3215081c3a6d513141 files/digest-epiphany-extensions-1.6.4 78
MD5 cc94941ad96bbbd969542ee260c77e4c files/epiphany-extensions-1.6.0-disable_bookmarks-tray_label.patch 1034
MD5 6b4caa4057fe795d71689814affe5100 files/epiphany-extensions-1.6.0-fix_includes.patch 1412
MD5 62eba0080b13e7b9650d12374138a2de files/digest-epiphany-extensions-1.7.4 78
MD5 facd371dca75721b247923b903369a05 files/epiphany-extensions-1.7.4-fix_includes.patch 2504
+MD5 372d4cda16db1e3215081c3a6d513141 files/digest-epiphany-extensions-1.6.4-r1 78
diff --git a/www-client/epiphany-extensions/epiphany-extensions-1.6.4-r1.ebuild b/www-client/epiphany-extensions/epiphany-extensions-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..a4168f22e852
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-1.6.4-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-1.6.4-r1.ebuild,v 1.1 2005/08/20 22:50:30 joem Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug firefox static"
+
+RDEPEND=">=www-client/epiphany-1.6
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2
+ app-text/opensp
+ !firefox? ( >=www-client/mozilla-1.7.3 )
+ firefox? ( >=www-client/mozilla-firefox-1.0.2-r1 )
+ dev-libs/libpcre
+ >=sys-apps/dbus-0.22"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-1.6.0-fix_includes.patch
+}
+
+USE_DESTDIR="1"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+src_compile() {
+ local extensions="actions bookmarks-tray certificates dashboard
+ error-viewer extensions-manager-ui gestures page-info sample sample-mozilla
+ select-stylesheet sidebar smart-bookmarks tab-groups tab-states tabsmenu"
+
+ # The find extension doesn't compile against mozilla
+ use firefox && extensions="${extensions} find"
+
+ if built_with_use www-client/epiphany dbus; then
+ extensions="${extensions} net-monitor"
+ else
+ ewarn
+ ewarn "In order to install the net-monitor extension, you need to"
+ ewarn "emerge www-client/epiphany with the 'dbus' USE flag enabled."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ fi
+
+ local list_exts=""
+ for ext in $extensions; do
+ [ "x${list_exts}" != "x" ] && list_exts="${list_exts},"
+ list_exts="${list_exts}${ext}"
+ done
+
+ G2CONF="${G2CONF} $(use_enable static) --with-extensions=${list_exts}"
+
+ if use firefox; then
+ G2CONF="${G2CONF} --with-mozilla=firefox"
+ else
+ G2CONF="${G2CONF} --with-mozilla=mozilla"
+ fi
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany-extensions/files/digest-epiphany-extensions-1.6.4-r1 b/www-client/epiphany-extensions/files/digest-epiphany-extensions-1.6.4-r1
new file mode 100644
index 000000000000..3d8c8cdfe4d6
--- /dev/null
+++ b/www-client/epiphany-extensions/files/digest-epiphany-extensions-1.6.4-r1
@@ -0,0 +1 @@
+MD5 0bc858d08d3f3a4609367505011787d9 epiphany-extensions-1.6.4.tar.bz2 563798