summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-16 21:37:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-16 21:37:08 +0000
commitada5ce11fe67e8fafe944e9aa3e6adeacfbe1385 (patch)
treec02dc3a8744594990780badc82d92b1f8c73a886 /www-client
parentVersion bump. (diff)
downloadgentoo-2-ada5ce11fe67e8fafe944e9aa3e6adeacfbe1385.tar.gz
gentoo-2-ada5ce11fe67e8fafe944e9aa3e6adeacfbe1385.tar.bz2
gentoo-2-ada5ce11fe67e8fafe944e9aa3e6adeacfbe1385.zip
Version bump.
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog8
-rw-r--r--www-client/epiphany/epiphany-2.30.6.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 273dfda8236d..4156021e73a0 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.254 2010/09/11 18:54:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.255 2010/09/16 21:37:08 eva Exp $
+
+*epiphany-2.30.6 (16 Sep 2010)
+
+ 16 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +epiphany-2.30.6.ebuild:
+ Version bump.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> epiphany-2.30.2-r1.ebuild:
Marked ppc for bug #324077.
diff --git a/www-client/epiphany/epiphany-2.30.6.ebuild b/www-client/epiphany/epiphany-2.30.6.ebuild
new file mode 100644
index 000000000000..14ceca6c89bd
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.30.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.30.6.ebuild,v 1.1 2010/09/16 21:37:08 eva Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+# We are not ready for introspection yet
+IUSE="avahi doc networkmanager +nss test"
+
+# TODO: add seed support
+RDEPEND=">=dev-libs/glib-2.19.7
+ >=x11-libs/gtk+-2.19.5
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ >=net-libs/webkit-gtk-1.2.3
+ >=net-libs/libsoup-gnome-2.29.91
+ >=gnome-base/gnome-keyring-2.26
+
+ x11-libs/libICE
+ x11-libs/libSM
+
+ x11-themes/gnome-icon-theme
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ nss? ( dev-libs/nss )"
+# introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-introspection
+ --disable-scrollkeeper
+ --disable-maintainer-mode
+ --with-distributor-name=Gentoo
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable nss)
+ $(use_enable test tests)"
+}
+
+src_compile() {
+ # Fix sandbox error with USE="introspection" and "doc"
+ # https://bugs.webkit.org/show_bug.cgi?id=35471
+ addpredict "$(unset HOME; echo ~)/.local"
+ emake || die "Compile failed"
+}