summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2005-07-27 00:38:06 +0000
committerJory Pratt <anarchy@gentoo.org>2005-07-27 00:38:06 +0000
commitc0bbccf4ad7913d9fb60eb29e4a0e3e523af9254 (patch)
tree1a1b93bd815247f98f8bbc72eef4e4dde29ba180 /www-client
parentBug 98210 (diff)
downloadgentoo-2-c0bbccf4ad7913d9fb60eb29e4a0e3e523af9254.tar.gz
gentoo-2-c0bbccf4ad7913d9fb60eb29e4a0e3e523af9254.tar.bz2
gentoo-2-c0bbccf4ad7913d9fb60eb29e4a0e3e523af9254.zip
updated gcc4 patch
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/mozilla-firefox/ChangeLog6
-rw-r--r--www-client/mozilla-firefox/files/mozilla-firefox-1.0.6-gcc4.patch124
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-1.0.6-r3.ebuild4
3 files changed, 131 insertions, 3 deletions
diff --git a/www-client/mozilla-firefox/ChangeLog b/www-client/mozilla-firefox/ChangeLog
index 687462fc35ab..cee9bab27764 100644
--- a/www-client/mozilla-firefox/ChangeLog
+++ b/www-client/mozilla-firefox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/mozilla-firefox
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/ChangeLog,v 1.58 2005/07/24 06:20:07 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/ChangeLog,v 1.59 2005/07/27 00:38:06 anarchy Exp $
+
+ 27 Jul 2005; Jory A. Pratt <anarchy@gentoo.org>
+ +files/mozilla-firefox-1.0.6-gcc4.patch, mozilla-firefox-1.0.6-r3.ebuild:
+ Updated gcc4 patch
*mozilla-firefox-1.0.6-r3 (24 Jul 2005)
diff --git a/www-client/mozilla-firefox/files/mozilla-firefox-1.0.6-gcc4.patch b/www-client/mozilla-firefox/files/mozilla-firefox-1.0.6-gcc4.patch
new file mode 100644
index 000000000000..8c9eea40b00c
--- /dev/null
+++ b/www-client/mozilla-firefox/files/mozilla-firefox-1.0.6-gcc4.patch
@@ -0,0 +1,124 @@
+diff -ur mozilla-orig/security/nss/lib/pki1/oiddata.h mozilla/security/nss/lib/pki1/oiddata.h
+--- mozilla-orig/security/nss/lib/pki1/oiddata.h 2005-03-13 19:12:25.000000000 -0500
++++ mozilla/security/nss/lib/pki1/oiddata.h 2005-03-13 19:15:19.000000000 -0500
+@@ -43,12 +43,6 @@
+ #include "nsspki1t.h"
+ #endif /* NSSPKI1T_H */
+
+-extern const NSSOID nss_builtin_oids[];
+-extern const PRUint32 nss_builtin_oid_count;
+-
+-/*extern const nssAttributeTypeAliasTable nss_attribute_type_aliases[];*/
+-/*extern const PRUint32 nss_attribute_type_alias_count;*/
+-
+ extern const NSSOID *NSS_OID_RFC1274_UID;
+ extern const NSSOID *NSS_OID_RFC1274_EMAIL;
+ extern const NSSOID *NSS_OID_RFC2247_DC;
+diff -ur mozilla-orig/security/nss/lib/pki1/oidgen.perl mozilla/security/nss/lib/pki1/oidgen.perl
+--- mozilla-orig/security/nss/lib/pki1/oidgen.perl 2005-03-13 19:12:25.000000000 -0500
++++ mozilla/security/nss/lib/pki1/oidgen.perl 2005-03-13 19:15:19.000000000 -0500
+@@ -233,12 +233,6 @@
+ #include "nsspki1t.h"
+ #endif /* NSSPKI1T_H */
+
+-extern const NSSOID nss_builtin_oids[];
+-extern const PRUint32 nss_builtin_oid_count;
+-
+-/*extern const nssAttributeTypeAliasTable nss_attribute_type_aliases[];*/
+-/*extern const PRUint32 nss_attribute_type_alias_count;*/
+-
+ EOD
+ ;
+
+diff -ur mozilla-orig/security/nss/lib/pki1/pki1.h mozilla/security/nss/lib/pki1/pki1.h
+--- mozilla-orig/security/nss/lib/pki1/pki1.h 2005-03-13 19:12:25.000000000 -0500
++++ mozilla/security/nss/lib/pki1/pki1.h 2005-03-13 19:15:19.000000000 -0500
+@@ -55,7 +55,9 @@
+
+ PR_BEGIN_EXTERN_C
+
+-/* fgmr 19990505 moved these here from oiddata.h */
++extern const NSSOID nss_builtin_oids[];
++extern const PRUint32 nss_builtin_oid_count;
++
+ extern const nssAttributeTypeAliasTable nss_attribute_type_aliases[];
+ extern const PRUint32 nss_attribute_type_alias_count;
+
+diff -ur mozilla-orig/xpcom/base/nscore.h mozilla/xpcom/base/nscore.h
+--- mozilla-orig/xpcom/base/nscore.h 2005-07-24 05:07:54.627311840 +0000
++++ mozilla/xpcom/base/nscore.h 2005-07-24 05:13:02.327534296 +0000
+@@ -365,8 +365,9 @@
+ * Use these macros to do 64bit safe pointer conversions.
+ */
+
+-#define NS_PTR_TO_INT32(x) ((char *)(x) - (char *)0)
+-#define NS_INT32_TO_PTR(x) ((void *)((char *)0 + (x)))
++#define NS_PTR_TO_INT32(x) ((PRInt32) (PRWord) (x))
++#define NS_PTR_TO_UINT32(x) ((PRUint32) (PRWord) (x))
++#define NS_INT32_TO_PTR(x) ((void *) (PRWord) (x))
+
+ /*
+ * These macros allow you to give a hint to the compiler about branch
+diff -ur mozilla-orig/netwerk/protocol/http/src/nsHttpConnectionMgr.cpp mozilla/netwerk/protocol/http/src/nsHttpConnectionMgr.cpp
+--- mozilla-orig/netwerk/protocol/http/src/nsHttpConnectionMgr.cpp 2005-07-24 05:07:51.199832896 +0000
++++ mozilla/netwerk/protocol/http/src/nsHttpConnectionMgr.cpp 2005-07-24 05:13:08.302625944 +0000
+@@ -834,8 +834,8 @@
+ void
+ nsHttpConnectionMgr::OnMsgUpdateParam(nsresult status, void *param)
+ {
+- PRUint16 name = (PRUint32(param) & 0xFFFF0000) >> 16;
+- PRUint16 value = PRUint32(param) & 0x0000FFFF;
++ PRUint16 name = (NS_PTR_TO_UINT32(param) & 0xFFFF0000) >> 16;
++ PRUint16 value = NS_PTR_TO_UINT32(param) & 0x0000FFFF;
+
+ switch (name) {
+ case MAX_CONNECTIONS:
+diff -ur mozilla-orig/widget/src/gtk2/nsDragService.cpp mozilla/widget/src/gtk2/nsDragService.cpp
+--- mozilla-orig/widget/src/gtk2/nsDragService.cpp 2005-07-24 05:08:57.666728392 +0000
++++ mozilla/widget/src/gtk2/nsDragService.cpp 2005-07-24 05:13:33.910732920 +0000
+@@ -838,7 +838,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ listTarget->target = g_strdup(gMimeListType);
+ listTarget->flags = 0;
+- listTarget->info = (guint)listAtom;
++ listTarget->info = GPOINTER_TO_UINT(listAtom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("automatically adding target %s with id %ld\n",
+ listTarget->target, listAtom));
+@@ -877,7 +877,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ listTarget->target = g_strdup(gTextUriListType);
+ listTarget->flags = 0;
+- listTarget->info = (guint)listAtom;
++ listTarget->info = GPOINTER_TO_UINT(listAtom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("automatically adding target %s with \
+ id %ld\n", listTarget->target, listAtom));
+@@ -914,7 +914,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ target->target = g_strdup(flavorStr);
+ target->flags = 0;
+- target->info = (guint)atom;
++ target->info = GPOINTER_TO_UINT(atom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("adding target %s with id %ld\n",
+ target->target, atom));
+@@ -931,7 +931,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ plainTarget->target = g_strdup(kTextMime);
+ plainTarget->flags = 0;
+- plainTarget->info = (guint)plainAtom;
++ plainTarget->info = GPOINTER_TO_UINT(plainAtom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("automatically adding target %s with \
+ id %ld\n", plainTarget->target, plainAtom));
+@@ -948,7 +948,7 @@
+ (GtkTargetEntry *)g_malloc(sizeof(GtkTargetEntry));
+ urlTarget->target = g_strdup(gMozUrlType);
+ urlTarget->flags = 0;
+- urlTarget->info = (guint)urlAtom;
++ urlTarget->info = GPOINTER_TO_UINT(urlAtom);
+ PR_LOG(sDragLm, PR_LOG_DEBUG,
+ ("automatically adding target %s with \
+ id %ld\n", urlTarget->target, urlAtom));
+
diff --git a/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r3.ebuild b/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r3.ebuild
index d2cb0d19b7a6..aeb1c8a5fdc0 100644
--- a/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r3.ebuild
+++ b/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r3.ebuild,v 1.2 2005/07/24 06:50:53 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-1.0.6-r3.ebuild,v 1.3 2005/07/27 00:38:06 anarchy Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic toolchain-funcs eutils mozconfig mozilla-launcher makeedit multilib
@@ -79,7 +79,7 @@ src_unpack() {
####################################
# GCC4 compile fix, bug #87800
- epatch ${FILESDIR}/mozilla-firefox-1.0.4-gcc4.patch
+ epatch ${FILESDIR}/${P}-gcc4.patch
# patch out ft caching code since the API changed between releases of
# freetype; this enables freetype-2.1.8+ compat.