summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-11-10 15:33:23 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-11-10 15:33:23 +0000
commite387936bc0e17f8f1a6eb82283f571cc2aadc534 (patch)
tree0eea6e790f1fbca8357f85614bcb385a0561b564 /www-client
parentBump to beta2. Remove beta1. Apply stricter dependencies to 2.* ebuilds (diff)
downloadgentoo-2-e387936bc0e17f8f1a6eb82283f571cc2aadc534.tar.gz
gentoo-2-e387936bc0e17f8f1a6eb82283f571cc2aadc534.tar.bz2
gentoo-2-e387936bc0e17f8f1a6eb82283f571cc2aadc534.zip
Version bump for dev channel release. Fix bug #343805 by Julien Sanchez <julien.sanchez@gmail.com>. Remove old.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog10
-rw-r--r--www-client/chromium/chromium-9.0.576.0.ebuild (renamed from www-client/chromium/chromium-9.0.570.0.ebuild)41
-rw-r--r--www-client/chromium/chromium-9999.ebuild28
-rw-r--r--www-client/chromium/files/chromium-system-vpx-r0.patch68
4 files changed, 121 insertions, 26 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 39d6c299af1b..f14e90306505 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.223 2010/11/09 17:28:06 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.224 2010/11/10 15:33:23 phajdan.jr Exp $
+
+*chromium-9.0.576.0 (10 Nov 2010)
+
+ 10 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +files/chromium-system-vpx-r0.patch, -chromium-9.0.570.0.ebuild,
+ +chromium-9.0.576.0.ebuild, chromium-9999.ebuild:
+ Version bump for dev channel release. Fix bug #343805 by Julien Sanchez
+ <julien.sanchez@gmail.com>. Remove old.
09 Nov 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> chromium-9999.ebuild:
Remove patch applied upstream, bug #344787 by Julien Sanchez
diff --git a/www-client/chromium/chromium-9.0.570.0.ebuild b/www-client/chromium/chromium-9.0.576.0.ebuild
index 931c123f8c74..1a8b336e1d97 100644
--- a/www-client/chromium/chromium-9.0.570.0.ebuild
+++ b/www-client/chromium/chromium-9.0.576.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9.0.570.0.ebuild,v 1.7 2010/11/08 16:45:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9.0.576.0.ebuild,v 1.1 2010/11/10 15:33:23 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -20,17 +20,19 @@ RDEPEND="app-arch/bzip2
system-sqlite? (
>=dev-db/sqlite-3.6.23.1[fts3,icu,secure-delete,threadsafe]
)
- system-v8? ( ~dev-lang/v8-2.5.2 )
+ system-v8? ( ~dev-lang/v8-2.5.4 )
+ dev-libs/dbus-glib
>=dev-libs/icu-4.4.1
>=dev-libs/libevent-1.4.13
dev-libs/libxml2
dev-libs/libxslt
>=dev-libs/nss-3.12.3
- >=gnome-base/gconf-2.24.0
+ gnome? ( >=gnome-base/gconf-2.24.0 )
gnome-keyring? ( >=gnome-base/gnome-keyring-2.28.2 )
>=media-libs/alsa-lib-1.0.19
virtual/jpeg
media-libs/libpng
+ media-libs/libvpx
>=media-video/ffmpeg-0.6_p25423[threads]
cups? ( >=net-print/cups-1.3.11 )
sys-libs/zlib
@@ -52,6 +54,12 @@ RDEPEND+="
virtual/ttf-fonts
gecko-mediaplayer? ( !www-plugins/gecko-mediaplayer[gnome] )"
+egyp() {
+ set -- build/gyp_chromium --depth=. "${@}"
+ echo "${@}" >&2
+ "${@}"
+}
+
remove_bundled_lib() {
einfo "Removing bundled library $1 ..."
local out
@@ -89,6 +97,12 @@ src_prepare() {
# Enable optional support for gecko-mediaplayer.
epatch "${FILESDIR}"/${PN}-gecko-mediaplayer-r0.patch
+ # Make GConf dependency optional, http://crbug.com/13322.
+ epatch "${FILESDIR}"/${PN}-gconf-optional-r0.patch
+
+ # Make sure we don't use bundled libvpx headers.
+ epatch "${FILESDIR}"/${PN}-system-vpx-r0.patch
+
remove_bundled_lib "third_party/bzip2"
remove_bundled_lib "third_party/codesighs"
remove_bundled_lib "third_party/icu"
@@ -97,6 +111,7 @@ src_prepare() {
remove_bundled_lib "third_party/libevent"
remove_bundled_lib "third_party/libjpeg"
remove_bundled_lib "third_party/libpng"
+ remove_bundled_lib "third_party/libvpx"
remove_bundled_lib "third_party/libxml"
remove_bundled_lib "third_party/libxslt"
remove_bundled_lib "third_party/lzma_sdk"
@@ -105,6 +120,7 @@ src_prepare() {
remove_bundled_lib "third_party/pyftpdlib"
remove_bundled_lib "third_party/simplejson"
remove_bundled_lib "third_party/tlslite"
+ remove_bundled_lib "third_party/yasm"
# TODO: also remove third_party/ffmpeg (needs to be compile-tested).
# TODO: also remove third_party/zlib. For now the compilation fails if we
# remove it (minizip-related).
@@ -152,6 +168,7 @@ src_configure() {
-Duse_system_libjpeg=1
-Duse_system_libpng=1
-Duse_system_libxml=1
+ -Duse_system_vpx=1
-Duse_system_zlib=1"
if use system-sqlite; then
@@ -165,6 +182,13 @@ src_configure() {
myconf+=" -Duse_cups=0"
fi
+ # Make GConf dependency optional, http://crbug.com/13322.
+ if use gnome; then
+ myconf+=" -Duse_gconf=1"
+ else
+ myconf+=" -Duse_gconf=0"
+ fi
+
if use "gnome-keyring"; then
myconf+=" -Duse_gnome_keyring=1 -Dlinux_link_gnome_keyring=1"
else
@@ -214,21 +238,12 @@ src_configure() {
die "Failed to determine target arch, got '$myarch'."
fi
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
- myconf+=" -Dno_strict_aliasing=1 -Dgcc_version=44"
- fi
-
- # Work around a likely GCC bug, see bug #331945.
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "45" ]]; then
- append-flags -fno-ipa-cp
- fi
-
# Make sure that -Werror doesn't get added to CFLAGS by the build system.
# Depending on GCC version the warnings are different and we don't want
# the build to fail because of that.
myconf+=" -Dwerror="
- build/gyp_chromium --depth=. ${myconf} || die
+ egyp ${myconf} || die
}
src_compile() {
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index d84cd1ef44dc..53ce8beb68fd 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.108 2010/11/09 17:28:06 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.109 2010/11/10 15:33:23 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -22,7 +22,7 @@ RDEPEND="app-arch/bzip2
system-sqlite? (
>=dev-db/sqlite-3.6.23.1[fts3,icu,secure-delete,threadsafe]
)
- system-v8? ( ~dev-lang/v8-2.5.2 )
+ system-v8? ( ~dev-lang/v8-2.5.4 )
dev-libs/dbus-glib
>=dev-libs/icu-4.4.1
>=dev-libs/libevent-1.4.13
@@ -34,6 +34,7 @@ RDEPEND="app-arch/bzip2
>=media-libs/alsa-lib-1.0.19
virtual/jpeg
media-libs/libpng
+ media-libs/libvpx
>=media-video/ffmpeg-0.6_p25423[threads]
cups? ( >=net-print/cups-1.3.11 )
sys-libs/zlib
@@ -98,6 +99,12 @@ src_unpack() {
elog "Installing/updating to version ${MAJOR}.${MINOR}.${BUILD}.${PATCH}_p${CREV} "
}
+egyp() {
+ set -- build/gyp_chromium --depth=. "${@}"
+ echo "${@}" >&2
+ "${@}"
+}
+
remove_bundled_lib() {
einfo "Removing bundled library $1 ..."
local out
@@ -135,6 +142,9 @@ src_prepare() {
# Enable optional support for gecko-mediaplayer.
epatch "${FILESDIR}"/${PN}-gecko-mediaplayer-r0.patch
+ # Make sure we don't use bundled libvpx headers.
+ epatch "${FILESDIR}"/${PN}-system-vpx-r0.patch
+
remove_bundled_lib "third_party/bzip2"
remove_bundled_lib "third_party/codesighs"
remove_bundled_lib "third_party/icu"
@@ -143,6 +153,7 @@ src_prepare() {
remove_bundled_lib "third_party/libevent"
remove_bundled_lib "third_party/libjpeg"
remove_bundled_lib "third_party/libpng"
+ remove_bundled_lib "third_party/libvpx"
remove_bundled_lib "third_party/libxml"
remove_bundled_lib "third_party/libxslt"
remove_bundled_lib "third_party/lzma_sdk"
@@ -151,6 +162,7 @@ src_prepare() {
remove_bundled_lib "third_party/pyftpdlib"
remove_bundled_lib "third_party/simplejson"
remove_bundled_lib "third_party/tlslite"
+ remove_bundled_lib "third_party/yasm"
# TODO: also remove third_party/ffmpeg (needs to be compile-tested).
# TODO: also remove third_party/zlib. For now the compilation fails if we
# remove it (minizip-related).
@@ -198,6 +210,7 @@ src_configure() {
-Duse_system_libjpeg=1
-Duse_system_libpng=1
-Duse_system_libxml=1
+ -Duse_system_vpx=1
-Duse_system_zlib=1"
if use system-sqlite; then
@@ -267,21 +280,12 @@ src_configure() {
die "Failed to determine target arch, got '$myarch'."
fi
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
- myconf+=" -Dno_strict_aliasing=1 -Dgcc_version=44"
- fi
-
- # Work around a likely GCC bug, see bug #331945.
- if [[ "$(gcc-major-version)$(gcc-minor-version)" == "45" ]]; then
- append-flags -fno-ipa-cp
- fi
-
# Make sure that -Werror doesn't get added to CFLAGS by the build system.
# Depending on GCC version the warnings are different and we don't want
# the build to fail because of that.
myconf+=" -Dwerror="
- build/gyp_chromium --depth=. ${myconf} || die
+ egyp ${myconf} || die
}
src_compile() {
diff --git a/www-client/chromium/files/chromium-system-vpx-r0.patch b/www-client/chromium/files/chromium-system-vpx-r0.patch
new file mode 100644
index 000000000000..102a083ac589
--- /dev/null
+++ b/www-client/chromium/files/chromium-system-vpx-r0.patch
@@ -0,0 +1,68 @@
+--- remoting/base/encoder_vp8.cc.orig 2010-11-10 09:52:56.000000000 +0100
++++ remoting/base/encoder_vp8.cc 2010-11-10 09:53:32.000000000 +0100
+@@ -11,9 +11,9 @@
+
+ extern "C" {
+ #define VPX_CODEC_DISABLE_COMPAT 1
+-#include "third_party/libvpx/include/vpx/vpx_codec.h"
+-#include "third_party/libvpx/include/vpx/vpx_encoder.h"
+-#include "third_party/libvpx/include/vpx/vp8cx.h"
++#include "vpx/vpx_codec.h"
++#include "vpx/vpx_encoder.h"
++#include "vpx/vp8cx.h"
+ }
+
+ namespace remoting {
+--- remoting/base/decoder_vp8.cc.orig 2010-11-10 09:54:14.000000000 +0100
++++ remoting/base/decoder_vp8.cc 2010-11-10 09:54:37.000000000 +0100
+@@ -10,9 +10,9 @@
+
+ extern "C" {
+ #define VPX_CODEC_DISABLE_COMPAT 1
+-#include "third_party/libvpx/include/vpx/vpx_codec.h"
+-#include "third_party/libvpx/include/vpx/vpx_decoder.h"
+-#include "third_party/libvpx/include/vpx/vp8dx.h"
++#include "vpx/vpx_codec.h"
++#include "vpx/vpx_decoder.h"
++#include "vpx/vp8dx.h"
+ }
+
+ namespace remoting {
+--- third_party/ffmpeg/ffmpeg_stub_headers.fragment.orig 2010-11-10 09:55:43.000000000 +0100
++++ third_party/ffmpeg/ffmpeg_stub_headers.fragment 2010-11-10 09:56:09.000000000 +0100
+@@ -7,9 +7,9 @@
+ #include <libavformat/avformat.h>
+
+ #define VPX_CODEC_DISABLE_COMPAT 1
+-#include "third_party/libvpx/include/vpx/vpx_codec.h"
+-#include "third_party/libvpx/include/vpx/vpx_encoder.h"
+-#include "third_party/libvpx/include/vpx/vpx_decoder.h"
++#include "vpx/vpx_codec.h"
++#include "vpx/vpx_encoder.h"
++#include "vpx/vpx_decoder.h"
+
+ typedef int (*AVLockMgrOperation)(void**, enum AVLockOp);
+
+--- third_party/ffmpeg/ffmpeg.gyp.orig 2010-11-10 11:53:27.000000000 +0100
++++ third_party/ffmpeg/ffmpeg.gyp 2010-11-10 11:55:07.000000000 +0100
+@@ -902,10 +902,20 @@
+ 'cflags': [
+ '<!@(pkg-config --cflags libavcodec libavformat libavutil)',
+ ],
++ 'link_settings': {
++ 'libraries': [
++ '-lvpx',
++ ],
++ },
+ 'direct_dependent_settings': {
+ 'cflags': [
+ '<!@(pkg-config --cflags libavcodec libavformat libavutil)',
+ ],
++ 'link_settings': {
++ 'libraries': [
++ '-lvpx',
++ ],
++ },
+ },
+ }, { # else use_system_ffmpeg==0, add local copy to include path
+ 'include_dirs': [