summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-05-28 09:45:48 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-05-28 09:45:48 +0000
commite39eced0768c2f54864680ea2548a3896af67a17 (patch)
treecf565922976a4a6f3c1a269a85de053d56f7057f /www-client
parentVersion bump. Removed old. Added rewritten init script (diff)
downloadgentoo-2-e39eced0768c2f54864680ea2548a3896af67a17.tar.gz
gentoo-2-e39eced0768c2f54864680ea2548a3896af67a17.tar.bz2
gentoo-2-e39eced0768c2f54864680ea2548a3896af67a17.zip
Version bump, wrt bug #511400
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qupzilla/ChangeLog8
-rw-r--r--www-client/qupzilla/files/qupzilla-1.6.6-plugins-version-check-fix.patch33
-rw-r--r--www-client/qupzilla/qupzilla-1.6.6.ebuild77
3 files changed, 117 insertions, 1 deletions
diff --git a/www-client/qupzilla/ChangeLog b/www-client/qupzilla/ChangeLog
index 43cbf801f9f0..c37cfb3c43b8 100644
--- a/www-client/qupzilla/ChangeLog
+++ b/www-client/qupzilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/qupzilla
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.43 2014/05/28 08:54:12 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.44 2014/05/28 09:45:47 pinkbyte Exp $
+
+*qupzilla-1.6.6 (28 May 2014)
+
+ 28 May 2014; Sergey Popov <pinkbyte@gentoo.org> +qupzilla-1.6.6.ebuild,
+ +files/qupzilla-1.6.6-plugins-version-check-fix.patch:
+ Version bump, wrt bug #511400
28 May 2014; Sergey Popov <pinkbyte@gentoo.org> -qupzilla-1.6.0-r1.ebuild,
-qupzilla-1.6.1.ebuild, -qupzilla-1.6.3.ebuild, -qupzilla-1.6.3-r1.ebuild,
diff --git a/www-client/qupzilla/files/qupzilla-1.6.6-plugins-version-check-fix.patch b/www-client/qupzilla/files/qupzilla-1.6.6-plugins-version-check-fix.patch
new file mode 100644
index 000000000000..cabb483dd356
--- /dev/null
+++ b/www-client/qupzilla/files/qupzilla-1.6.6-plugins-version-check-fix.patch
@@ -0,0 +1,33 @@
+--- src/plugins/CopyTitle/copytitle.cpp.orig 2014-01-29 21:43:11.073465642 +0400
++++ src/plugins/CopyTitle/copytitle.cpp 2014-01-29 21:43:33.079464399 +0400
+@@ -61,7 +61,7 @@
+
+ bool CopyTitle::testPlugin()
+ {
+- return (QupZilla::VERSION == QLatin1String("1.6.1"));
++ return (QupZilla::VERSION == QLatin1String("1.6.6"));
+ }
+
+ QTranslator* CopyTitle::getTranslator(const QString &locale)
+--- src/plugins/MailHandle/mailhandle_plugin.cpp.orig 2014-01-29 21:45:27.312457943 +0400
++++ src/plugins/MailHandle/mailhandle_plugin.cpp 2014-01-29 21:45:37.127457388 +0400
+@@ -66,7 +66,7 @@
+ {
+ // Let's be sure, require latest version of QupZilla
+
+- return (QupZilla::VERSION == QLatin1String("1.6.1"));
++ return (QupZilla::VERSION == QLatin1String("1.6.6"));
+ }
+
+ QTranslator* MailHandle_Plugin::getTranslator(const QString &locale)
+--- src/plugins/Videoner/videoner_plugin.cpp.orig 2014-01-29 21:44:59.552459512 +0400
++++ src/plugins/Videoner/videoner_plugin.cpp 2014-01-29 21:45:07.055459088 +0400
+@@ -62,7 +62,7 @@
+ {
+ // Let's be sure, require latest version of QupZilla
+
+- return (QupZilla::VERSION == QLatin1String("1.6.1"));
++ return (QupZilla::VERSION == QLatin1String("1.6.6"));
+ }
+
+ QTranslator* Videoner_Plugin::getTranslator(const QString &locale)
diff --git a/www-client/qupzilla/qupzilla-1.6.6.ebuild b/www-client/qupzilla/qupzilla-1.6.6.ebuild
new file mode 100644
index 000000000000..c231e3b58f8a
--- /dev/null
+++ b/www-client/qupzilla/qupzilla-1.6.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/qupzilla-1.6.6.ebuild,v 1.1 2014/05/28 09:45:47 pinkbyte Exp $
+
+EAPI=5
+PLOCALES="ar_SA bg_BG ca_ES cs_CZ de_DE el_GR es_ES es_MX es_VE eu_ES fa_IR fr_FR gl_ES he_IL hu_HU id_ID it_IT ja_JP ka_GE lg lv_LV nl_NL nqo pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sr_BA sr_BA@latin sr_RS sr_RS@latin sv_SE uk_UA uz@Latn zh_CN zh_TW"
+PLUGINS_HASH='b19f6e0b83baca40e96019ccda329b88459e6a7f'
+PLUGINS_VERSION='1.6.3' # if there are no updates, we can use the older archive
+
+inherit l10n multilib qt4-r2 vcs-snapshot
+
+DESCRIPTION="Qt WebKit web browser"
+HOMEPAGE="http://www.qupzilla.com/"
+SRC_URI="https://github.com/QupZilla/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/QupZilla/${PN}-plugins/archive/${PLUGINS_HASH}.tar.gz -> ${PN}-plugins-${PLUGINS_VERSION}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus debug gnome-keyring kde nonblockdialogs"
+
+RDEPEND="dev-libs/openssl:0
+ >=dev-qt/qtcore-4.8:4
+ >=dev-qt/qtgui-4.8:4
+ >=dev-qt/qtscript-4.8:4
+ >=dev-qt/qtsql-4.8:4[sqlite]
+ >=dev-qt/qtwebkit-4.8:4
+ dbus? ( >=dev-qt/qtdbus-4.8:4 )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ kde? ( kde-base/kwalletd:4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS CHANGELOG FAQ README.md )
+PATCHES=( "${FILESDIR}/${P}-plugins-version-check-fix.patch" )
+
+src_prepare() {
+ # remove outdated prebuilt localizations
+ rm -rf bin/locale || die
+
+ # remove empty locale
+ rm translations/empty.ts || die
+
+ mv "${WORKDIR}"/${PN}-plugins-${PLUGINS_VERSION}/plugins/* "${S}"/src/plugins/ || die
+ mv "${WORKDIR}"/${PN}-plugins-${PLUGINS_VERSION}/themes/* "${S}"/bin/themes/ || die
+
+ l10n_find_plocales_changes "translations" "" ".ts"
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ # see BUILDING document for explanation of options
+ export \
+ QUPZILLA_PREFIX="${EPREFIX}/usr/" \
+ USE_LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
+ USE_QTWEBKIT_2_2=true \
+ DISABLE_DBUS=$(usex dbus '' 'true') \
+ KDE_INTEGRATION=$(usex kde 'true' '') \
+ NONBLOCK_JS_DIALOGS=$(usex nonblockdialogs 'true' '')
+
+ eqmake4 $(use gnome-keyring && echo "DEFINES+=GNOME_INTEGRATION")
+}
+
+src_install() {
+ qt4-r2_src_install
+ l10n_for_each_disabled_locale_do rm_loc
+}
+
+rm_loc() {
+ rm -f "${ED}"/usr/share/${PN}/locale/${1}.qm || die
+}
+
+pkg_postinst(){
+ if has_version www-plugins/adobe-flash; then
+ ewarn "For using adobe flash plugin you most likely need to run \"paxctl-ng -m /usr/bin/qupzilla\""
+ fi
+}