summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-10-15 16:53:19 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-10-15 16:53:19 +0000
commitf9d65bdee2631c27da1c1d4d4529030642c83bbf (patch)
tree4bb01571582170629dc1fac1e99e52d8c7451cf5 /www-client
parentMark 3.5.1 x86 stable, 3.6 version bump. (diff)
downloadgentoo-2-f9d65bdee2631c27da1c1d4d4529030642c83bbf.tar.gz
gentoo-2-f9d65bdee2631c27da1c1d4d4529030642c83bbf.tar.bz2
gentoo-2-f9d65bdee2631c27da1c1d4d4529030642c83bbf.zip
2.1_pre23 version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/links/ChangeLog7
-rw-r--r--www-client/links/files/digest-links-2.1_pre236
-rw-r--r--www-client/links/links-2.1_pre23.ebuild127
3 files changed, 139 insertions, 1 deletions
diff --git a/www-client/links/ChangeLog b/www-client/links/ChangeLog
index a9ee30f395bb..c4c8e09f0313 100644
--- a/www-client/links/ChangeLog
+++ b/www-client/links/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/links
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.71 2006/08/24 00:06:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.72 2006/10/15 16:53:18 vanquirius Exp $
+
+*links-2.1_pre23 (15 Oct 2006)
+
+ 15 Oct 2006; Marcelo Goes <vanquirius@gentoo.org> +links-2.1_pre23.ebuild:
+ 2.1_pre23 version bump.
24 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org>
-files/links-2.1pre18-no-javascript-fix.patch, -links-2.1_pre18.ebuild,
diff --git a/www-client/links/files/digest-links-2.1_pre23 b/www-client/links/files/digest-links-2.1_pre23
new file mode 100644
index 000000000000..4c0099294940
--- /dev/null
+++ b/www-client/links/files/digest-links-2.1_pre23
@@ -0,0 +1,6 @@
+MD5 1f59217d4906622693eb3e1532871a72 links-2.1pre22-utf8.diff.bz2 4189
+RMD160 fa0c4719aa5ac0244bd165d010b9c303bfead5d3 links-2.1pre22-utf8.diff.bz2 4189
+SHA256 42982ee8f605f793226f07da9ed5cb9d5be613d1f8e4bb6270533bbd7cd42b9b links-2.1pre22-utf8.diff.bz2 4189
+MD5 4a1fb575c133eee821b9a1f8e9220b40 links-2.1pre23.tar.bz2 3872086
+RMD160 18ad152bc7367600d4438849c669cdcb8cd513ed links-2.1pre23.tar.bz2 3872086
+SHA256 d258a5406fcdb2cbe42ff797792303419c1fb0ec0e5d9d0482c37d9c3f21f0c1 links-2.1pre23.tar.bz2 3872086
diff --git a/www-client/links/links-2.1_pre23.ebuild b/www-client/links/links-2.1_pre23.ebuild
new file mode 100644
index 000000000000..68240c756581
--- /dev/null
+++ b/www-client/links/links-2.1_pre23.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.1_pre23.ebuild,v 1.1 2006/10/15 16:53:19 vanquirius Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="links is a fast lightweight text and graphic web-browser"
+HOMEPAGE="http://links.twibright.com/"
+# To handle pre-version ...
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://links.twibright.com/download/${MY_P}.tar.bz2
+ mirror://gentoo/${PN}-2.1pre22-utf8.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="directfb fbcon gpm javascript jpeg livecd png sdl ssl svga tiff unicode X"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic
+# mode. libpng is required to compile links in graphic mode
+# (not required in text mode), so let's add libpng for X? and fbcon?
+
+# We've also made USE=livecd compile in graphics mode. This closes bug #75685.
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ fbcon? ( >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ sys-libs/gpm )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3
+ >=media-libs/libpng-1.2.1 )
+ X? ( || ( x11-libs/libXext
+ virtual/x11 )
+ >=media-libs/libpng-1.2.1 )
+ directfb? ( dev-libs/DirectFB )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ sys-libs/zlib
+ virtual/libc
+ sys-libs/ncurses"
+
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ sys-devel/autoconf
+ sys-devel/gcc
+ dev-util/pkgconfig
+ javascript? ( >=sys-devel/flex-2.5.4a )"
+
+src_unpack (){
+ unpack ${A}; cd "${S}"
+
+ if use unicode ; then
+ epatch "${WORKDIR}/${PN}-2.1pre22-utf8.diff"
+ export LANG=C
+ cd "${S}/intl" && ./gen-intl && cd .. || die "gen-intl filed"
+ fi
+}
+
+src_compile (){
+ local myconf
+
+ if use X || use fbcon || use directfb || use svga || use livecd; then
+ myconf="${myconf} --enable-graphics"
+ fi
+
+ # Note: --enable-static breaks.
+
+ # Note: ./configure only support 'gpm' features auto-detection, so
+ # we use the autoconf trick
+ ( use gpm || use fbcon || use livecd ) || export ac_cv_lib_gpm_Gpm_Open="no"
+
+ export LANG=C
+
+ if use fbcon || use livecd; then
+ myconf="${myconf} --with-fb"
+ else
+ myconf="${myconf} --without-fb"
+ fi
+
+ # force --with-libjpeg if livecd flag is set
+ if use livecd; then
+ myconf="${myconf} --with-libjpeg"
+ fi
+
+ # hack to allow cross-compilation
+ export CC="$(tc-getCC)"
+
+ econf \
+ $(use_with X x) \
+ $(use_with png libpng) \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ $(use_with svga svgalib) \
+ $(use_with directfb) \
+ $(use_with ssl) \
+ $(use_with sdl) \
+ $(use_enable javascript) \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install (){
+ einstall
+
+ # Only install links icon if X driver was compiled in ...
+ use X && doicon graphics/links.xpm
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README SITES TODO
+ dohtml doc/links_cal/*
+
+ # Install a compatibility symlink links2:
+ dosym links /usr/bin/links2
+}
+
+
+pkg_postinst() {
+ if use svga
+ then
+ einfo "You had the svga USE flag enabled, but for security reasons"
+ einfo "the links2 binary is NOT setuid by default. In order to"
+ einfo "enable links2 to work in SVGA, please change the permissions"
+ einfo "of /usr/bin/links2 to enable suid."
+ fi
+}