summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-10-01 07:54:00 +0000
committerPeter Volkov <pva@gentoo.org>2011-10-01 07:54:00 +0000
commit4d6048c97d4c4d842400c35f938a6ae9da334516 (patch)
tree391222e9f8586a7127e7444dd9dbd95d809925ba /www-misc
parentInstall README.gost when USE=rfc3779, bug #385027. (diff)
downloadgentoo-2-4d6048c97d4c4d842400c35f938a6ae9da334516.tar.gz
gentoo-2-4d6048c97d4c4d842400c35f938a6ae9da334516.tar.bz2
gentoo-2-4d6048c97d4c4d842400c35f938a6ae9da334516.zip
Bump EAPI, use emake in src_install, bug #385081 thank Nikoli for this job.
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/fcgiwrap/ChangeLog8
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-1.0.3-r1.ebuild (renamed from www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild)19
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-9999.ebuild20
3 files changed, 23 insertions, 24 deletions
diff --git a/www-misc/fcgiwrap/ChangeLog b/www-misc/fcgiwrap/ChangeLog
index d53990c6be59..16cdc42709db 100644
--- a/www-misc/fcgiwrap/ChangeLog
+++ b/www-misc/fcgiwrap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-misc/fcgiwrap
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.6 2011/09/30 20:42:23 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.7 2011/10/01 07:54:00 pva Exp $
+
+*fcgiwrap-1.0.3-r1 (01 Oct 2011)
+
+ 01 Oct 2011; Peter Volkov <pva@gentoo.org> -fcgiwrap-1.0.2-r1.ebuild,
+ +fcgiwrap-1.0.3-r1.ebuild, fcgiwrap-9999.ebuild:
+ Bump EAPI, use emake in src_install, bug #385081 thank Nikoli for this job.
30 Sep 2011; Steve Dibb <beandog@gentoo.org> fcgiwrap-1.0.3.ebuild:
amd64 stable, bug 384475
diff --git a/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild b/www-misc/fcgiwrap/fcgiwrap-1.0.3-r1.ebuild
index 6ec6cf862ae6..5ba4cac1e227 100644
--- a/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild
+++ b/www-misc/fcgiwrap/fcgiwrap-1.0.3-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild,v 1.1 2010/06/29 13:17:59 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-1.0.3-r1.ebuild,v 1.1 2011/10/01 07:54:00 pva Exp $
-EAPI="3"
+EAPI="4"
[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
inherit autotools ${VCS_ECLASS}
@@ -19,8 +19,9 @@ if [[ ${PV} == *9999* ]]; then
KEYWORDS=""
else
- MY_REV="2e301c8"
- SRC_URI="http://download.github.com/gnosek-${PN}-v${PV}-1-g${MY_REV}.tar.gz -> ${P}.tar.gz"
+ MY_REV="58ec209"
+ #SRC_URI="http://download.github.com/gnosek-${P}-4-g${MY_REV}.tar.gz"
+ SRC_URI="mirror://gentoo/gnosek-${P}-4-g${MY_REV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/gnosek-${PN}-${MY_REV}"
KEYWORDS="~amd64 ~x86"
@@ -29,6 +30,8 @@ fi
DEPEND="dev-libs/fcgi"
RDEPEND="${DEPEND}"
+DOCS=( README.rst )
+
src_prepare() {
sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
-i Makefile.in || die "sed failed"
@@ -36,12 +39,6 @@ src_prepare() {
eautoreconf
}
-src_install() {
- einstall DESTDIR="${D}"
-
- dodoc README.rst
-}
-
pkg_postinst() {
einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
}
diff --git a/www-misc/fcgiwrap/fcgiwrap-9999.ebuild b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
index 71cd328f57ce..b81118205017 100644
--- a/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
+++ b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-9999.ebuild,v 1.2 2011/09/21 08:55:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-9999.ebuild,v 1.3 2011/10/01 07:54:00 pva Exp $
-EAPI="3"
+EAPI="4"
[[ ${PV} = *9999* ]] && VCS_ECLASS="git-2" || VCS_ECLASS=""
inherit autotools ${VCS_ECLASS}
@@ -15,13 +15,13 @@ SLOT="0"
IUSE=""
if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://github.com/gnosek/${PN}.git
- https://github.com/gnosek/${PN}.git"
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
KEYWORDS=""
else
- MY_REV="2e301c8"
- SRC_URI="http://download.github.com/gnosek-${PN}-v${PV}-1-g${MY_REV}.tar.gz -> ${P}.tar.gz"
+ MY_REV="58ec209"
+ #SRC_URI="http://download.github.com/gnosek-${P}-4-g${MY_REV}.tar.gz"
+ SRC_URI="mirror://gentoo/gnosek-${P}-4-g${MY_REV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/gnosek-${PN}-${MY_REV}"
KEYWORDS="~amd64 ~x86"
@@ -30,6 +30,8 @@ fi
DEPEND="dev-libs/fcgi"
RDEPEND="${DEPEND}"
+DOCS=( README.rst )
+
src_prepare() {
sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
-i Makefile.in || die "sed failed"
@@ -37,12 +39,6 @@ src_prepare() {
eautoreconf
}
-src_install() {
- einstall DESTDIR="${D}"
-
- dodoc README.rst
-}
-
pkg_postinst() {
einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
}