summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-13 18:21:24 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-13 18:21:24 +0000
commit64484bb50eb9bd7d553909a40e33a55c4732585f (patch)
tree340d9d490eae9bc017ccc353e0e6f3dc08572395 /www-misc
parentRemove old versions (diff)
downloadgentoo-2-64484bb50eb9bd7d553909a40e33a55c4732585f.tar.gz
gentoo-2-64484bb50eb9bd7d553909a40e33a55c4732585f.tar.bz2
gentoo-2-64484bb50eb9bd7d553909a40e33a55c4732585f.zip
New ebuild. Thanks to mren for reporting, thanks to Matthew Connelly for contributing an ebuild and an init script. Fixes bug #281087 and bug #417009.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/monitorix/ChangeLog10
-rw-r--r--www-misc/monitorix/Manifest4
-rw-r--r--www-misc/monitorix/files/monitorix-3.0.0.init24
-rw-r--r--www-misc/monitorix/metadata.xml18
-rw-r--r--www-misc/monitorix/monitorix-3.0.0.ebuild82
5 files changed, 138 insertions, 0 deletions
diff --git a/www-misc/monitorix/ChangeLog b/www-misc/monitorix/ChangeLog
new file mode 100644
index 000000000000..ed44bdb1d93e
--- /dev/null
+++ b/www-misc/monitorix/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-misc/monitorix
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/monitorix/ChangeLog,v 1.1 2013/03/13 18:21:24 tomwij Exp $
+
+*monitorix-3.0.0 (13 Mar 2013)
+
+ 13 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +files/monitorix-3.0.0.init,
+ +metadata.xml, +monitorix-3.0.0.ebuild:
+ New ebuild. Thanks to mren for reporting, thanks to Matthew Connelly for
+ contributing an ebuild and an init script. Fixes bug #281087 and bug #417009.
diff --git a/www-misc/monitorix/Manifest b/www-misc/monitorix/Manifest
new file mode 100644
index 000000000000..886ee4b67260
--- /dev/null
+++ b/www-misc/monitorix/Manifest
@@ -0,0 +1,4 @@
+AUX monitorix-3.0.0.init 649 SHA256 0d8af53b4b0e917a6476e1929be87fef4ceff870097727591087014460dd5778 SHA512 0b14192a2124a70f43625c3b1c70ab0787a19daf53c6b7d6ecdd6832ae69f87c46787f0cb38d6c951023870afa9b9c298a7614b4ebcca9207469d8212fb79422 WHIRLPOOL 00fc216d3aba0767a262d2130e513211a063032e50a9f689f4309c5e8eac082454cfda00a924ffae1e86a7d952faeb181d83c63658b8aaa057792d17f966b95e
+DIST monitorix-3.0.0.tar.gz 158342 SHA256 c503491d6550a99762fc636f07098fc5a66bd170f5d009a05052b4273e5ae224 SHA512 85f943e7f79a847218bd0a0748d5a52a3c458cfe25a5e67cbe42515c1333fca0b00a12dc3104aeee8420a78177ab47ee21f04c5f47b9e7ec18a28cb27cef8bc0 WHIRLPOOL 7976f8d4458c3a5bedf30ac223c14486dc4076f2e5933ac125500c42e30fa283f27611cff8f2591d9dde749dc47bb1f21d8a4bbb5af58230b6ee9904e36725bd
+EBUILD monitorix-3.0.0.ebuild 2227 SHA256 4f2bd201dbe39bdd507c55d0f2068fc38579e63bc36938c284a4f050915c8c6d SHA512 08f90ba97537b97985b2253e80f31041e675724624c8d760d5d726529f9fd9fbcef5e088fb9f955c6514c537a6d2d31199585d1f505e9d669ce2e4b5f7ff0dd6 WHIRLPOOL 669343a917be708661d6f1555898619de341986b9699dc60dc29b8943b176787ed33eadf797b9e15e3baa3668d0bc5fcc4e8e99025c23bd5bd9d5bd41c436816
+MISC metadata.xml 900 SHA256 ee18bf5adc6d404474e7f6950bfc9ea52272be5dc53856d6546900538c0f8adf SHA512 2a003cf517c216b5bab2ef230960fe322f19ce52f421db8bb5f767b137e9a22fdc5a4209c196cb88c9adc819beedd7a5346d3137e5f0441ab07c16471b1ea6f7 WHIRLPOOL 8208104be32381ba1e71b7f1f0b0d6e73bb6c3e23a8617232cba095d4334b9a0acc424814a7b58ac757e2851ca063aa0a05e30abd6a607b8d8b03a93f6152cc3
diff --git a/www-misc/monitorix/files/monitorix-3.0.0.init b/www-misc/monitorix/files/monitorix-3.0.0.init
new file mode 100644
index 000000000000..5cf2408b511e
--- /dev/null
+++ b/www-misc/monitorix/files/monitorix-3.0.0.init
@@ -0,0 +1,24 @@
+#! /sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting monitorix"
+ start-stop-daemon --start --exec /usr/sbin/monitorix --pidfile /var/run/monitorix.pid -- -c /etc/monitorix.conf -p /var/run/monitorix.pid
+ local i=0
+ local timeout=5
+ while [ ! -f /var/run/monitorix.pid ] && [ $i -le $timeout ]; do
+ sleep 1
+ i=$(($i + 1))
+ done
+ [ $timeout -gt $i ]
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping monitorix"
+ start-stop-daemon --stop --signal QUIT --stop --exec /usr/sbin/monitorix --pidfile /var/run/monitorix.pid
+ eend $?
+}
diff --git a/www-misc/monitorix/metadata.xml b/www-misc/monitorix/metadata.xml
new file mode 100644
index 000000000000..4a72c3eecb9c
--- /dev/null
+++ b/www-misc/monitorix/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+ <longdescription>
+ A lightweight system monitoring tool.
+ </longdescription>
+ <use>
+ <flag name='evms'>Make use of utilities for the IBM Enterprise Volume Management System with <pkg>sys-fs/evms</pkg>.</flag>
+ <flag name='hddtemp'>Use SMART to monitor the temperature of hard drives with <pkg>app-admin/hddtemp</pkg>.</flag>
+ <flag name='httpd'>Enables the CGI webserver with any package that satisfies <pkg>virtual/httpd-cgi</pkg>.</flag>
+ <flag name='lm_sensors'>Additional hardware mnitoring sensors with <pkg>sys-apps/lm_sensors</pkg>.</flag>
+ <flag name='postfix'>Analyze postfix logs with <pkg>net-mail/pflogsumm</pkg>.</flag>
+ </use>
+</pkgmetadata>
diff --git a/www-misc/monitorix/monitorix-3.0.0.ebuild b/www-misc/monitorix/monitorix-3.0.0.ebuild
new file mode 100644
index 000000000000..a650a61bcdcf
--- /dev/null
+++ b/www-misc/monitorix/monitorix-3.0.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/monitorix/monitorix-3.0.0.ebuild,v 1.1 2013/03/13 18:21:24 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A lightweight system monitoring tool"
+HOMEPAGE="http://www.${PN}.org/"
+SRC_URI="http://www.${PN}.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="evms hddtemp httpd lm_sensors postfix"
+
+DEPEND="sys-apps/sed"
+RDEPEND="net-analyzer/rrdtool[perl]
+ dev-perl/DBI
+ dev-perl/libwww-perl
+ dev-perl/XML-Simple
+ dev-perl/config-general
+ dev-perl/HTTP-Server-Simple
+ evms? ( sys-fs/evms )
+ hddtemp? ( app-admin/hddtemp )
+ httpd? ( virtual/httpd-cgi )
+ lm_sensors? ( sys-apps/lm_sensors )
+ postfix? ( net-mail/pflogsumm )"
+
+src_prepare() {
+ # Put better Gentoo defaults in the configuration file.
+ sed -i "s|\(base_dir.*\)/usr/share/monitorix|\1/usr/share/monitorix/htdocs|" ${PN}.conf
+ sed -i "s|\(secure_log.*\)/var/log/secure|\1/var/log/auth.log|" ${PN}.conf
+}
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd "${FILESDIR}"/${P}.init ${PN}
+
+ insinto /etc
+ doins ${PN}.conf
+
+ insinto /etc/logrotate.d
+ newins docs/${PN}.logrotate ${PN}
+
+ dodoc Changes README{,.nginx} docs/${PN}.service docs/${PN}-{alert.sh,apache.conf,lighttpd.conf}
+ doman man/man5/${PN}.conf.5
+ doman man/man8/${PN}.8
+
+ dodir "/usr/share/monitorix"
+ dodir "/usr/share/monitorix/htdocs"
+ insinto "/usr/share/monitorix/htdocs"
+ doins logo_bot.png logo_top.png monitorixico.png
+ dodir "/usr/share/monitorix/htdocs/imgs"
+
+ dodir "/usr/share/monitorix/htdocs/cgi"
+ exeinto "/usr/share/monitorix/htdocs/cgi"
+ doexe ${PN}.cgi
+
+ dodir /usr/lib/${PN}
+ exeinto /usr/lib/${PN}
+ doexe lib/*.pm
+
+ dodir /var/lib/${PN}
+ dodir /var/lib/${PN}/usage
+ insinto /var/lib/${PN}/reports
+ doins -r reports/*
+}
+
+pkg_postinst() {
+ elog "WARNING: ${PN} version 3.0.0 includes a brand new config"
+ elog "format, that may be incompatible with your existing config"
+ elog "file. Please take care if upgrading from an old version."
+ elog ""
+ elog "${PN} includes its own web server as of version 3.0.0."
+ elog "For this reason, the dependency on the webapp framework"
+ elog "has been removed. If you wish to use your own web server,"
+ elog "the monitorix web data can be found at:"
+ elog "/usr/share/monitorix/htdocs/"
+}