summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2014-07-31 21:12:29 +0000
committerRichard Yao <ryao@gentoo.org>2014-07-31 21:12:29 +0000
commit129a7e75ee2c4b342603b7e584474d3d2750fea2 (patch)
treef15cc92fcce45f9bc36b5b3fcc9497768e834ef1 /www-plugins
parentfixed prefix install (diff)
downloadgentoo-2-129a7e75ee2c4b342603b7e584474d3d2750fea2.tar.gz
gentoo-2-129a7e75ee2c4b342603b7e584474d3d2750fea2.tar.bz2
gentoo-2-129a7e75ee2c4b342603b7e584474d3d2750fea2.zip
New package www-plugins/pipelight, bug #481596
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/pipelight/ChangeLog9
-rw-r--r--www-plugins/pipelight/metadata.xml8
-rw-r--r--www-plugins/pipelight/pipelight-9999.ebuild76
3 files changed, 93 insertions, 0 deletions
diff --git a/www-plugins/pipelight/ChangeLog b/www-plugins/pipelight/ChangeLog
new file mode 100644
index 000000000000..5a42a266e08d
--- /dev/null
+++ b/www-plugins/pipelight/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for www-plugins/pipelight
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/pipelight/ChangeLog,v 1.1 2014/07/31 21:12:29 ryao Exp $
+
+*pipelight-9999 (31 Jul 2014)
+
+ 31 Jul 2014; Richard Yao <ryao@gentoo.org> +metadata.xml,
+ +pipelight-9999.ebuild:
+ New package www-plugins/pipelight, bug #481596
diff --git a/www-plugins/pipelight/metadata.xml b/www-plugins/pipelight/metadata.xml
new file mode 100644
index 000000000000..e63e3c3865da
--- /dev/null
+++ b/www-plugins/pipelight/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ryao@gentoo.org</email>
+ <name>Richard Yao</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-plugins/pipelight/pipelight-9999.ebuild b/www-plugins/pipelight/pipelight-9999.ebuild
new file mode 100644
index 000000000000..43a32f5749a8
--- /dev/null
+++ b/www-plugins/pipelight/pipelight-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/pipelight/pipelight-9999.ebuild,v 1.1 2014/07/31 21:12:29 ryao Exp $
+
+EAPI=5
+
+inherit git-2 multilib
+
+DESCRIPTION="Wine-based wrapper for Windows Silverlight"
+HOMEPAGE="https://launchpad.net/pipelight"
+SRC_URI=""
+EGIT_REPO_URI="https://bitbucket.org/mmueller2012/${PN}.git"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1+ MPL-1.1 )"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="app-emulation/wine[X,abi_x86_32,pipelight]"
+RDEPEND="${DEPEND}
+ app-arch/cabextract
+ gnome-extra/zenity
+ x11-apps/mesa-progs"
+
+QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader.exe
+ usr/share/pipelight/winecheck.exe"
+
+src_configure() {
+ econf --wine-path="${EPREFIX}/usr/bin/wine"
+}
+
+src_install() {
+ default_src_install
+
+ # Ideally, every wrapped plugin could be a symlink to pipelight's wrapper
+ # plugin, but some browsers do not like this. Upstream provides a script to
+ # duplicate the wrapper plugin as a hack to work around it. That script
+ # does not support DESTDIR, so we use sed to adjust it before running it to
+ # properly duplicate the plugins.
+ # XXX: Patch the script to support DESTDIR and send the patch upstream.
+ sed -e "s:^\(PIPELIGHT_LIBRARY_PATH=\"\)\\(.*\):\1${ED}\2:" \
+ "${DESTDIR}/usr/bin/pipelight-plugin" > "${T}/pipelight-plugin" \
+ || die "Generating temporary pipelight-plugin failed"
+ chmod u+x "${T}/pipelight-plugin" \
+ || die "Setting permissions on temporary pipelight-plugin failed"
+
+ # Create Plugins
+ "${T}/pipelight-plugin" --create-mozilla-plugins \
+ || die "Creating plugins failed"
+
+}
+
+postinst() {
+ # Obligatory warnings about proprietary software
+ ewarn "Neither the Gentoo developers nor the Pipelight developers can"
+ ewarn "patch security vulnerabilities in Windows plugins. Use them at your"
+ ewarn "own risk."
+ # Warn about missing pipelight-sandbox
+ ewarn
+ ewarn "The pipelight sandbox has not been packaged yet. Plugins will have"
+ ewarn "full privileges as Windows programs running inside wine."
+
+ # Helpful information for those willing to live dangerously
+ einfo "Using Windows plugins on certain websites might require a useragent"
+ einfo "switcher. See the upstream FAQ for more details."
+ einfo
+ einfo "https://answers.launchpad.net/pipelight/+faq/2351"
+ einfo
+ einfo "End users should use the pipelight-plugin utility to install and"
+ einfo "manage plugins. Updates are done at plugin initialization whenever"
+ einfo "/usr/share/pipelight/install-dependency has been updated. This can"
+ einfo "be done either by doing updates via portage or by running"
+ einfo "pipelight-plugin --update as root. Browsers like Chrome (all"
+ einfo "versions before 35) will initialize plugins at boot while browsers"
+ einfo "like Firefox will initialize plugins on demand."
+}