summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-03-29 14:00:13 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-03-29 14:00:13 +0000
commit7ad1d0211c98180d786ca66f03903f640b01f05f (patch)
treee3a2f9d1207726367ef1c476b7690ca8f6d06d51 /www-plugins
parentBased on 3.3.0 + genpatches-3.3-1 + grsecurity-2.9-3.3.0-201203251922 (diff)
downloadgentoo-2-7ad1d0211c98180d786ca66f03903f640b01f05f.tar.gz
gentoo-2-7ad1d0211c98180d786ca66f03903f640b01f05f.tar.bz2
gentoo-2-7ad1d0211c98180d786ca66f03903f640b01f05f.zip
version bump (bug #410095)
(Portage version: 2.2.0_alpha96/cvs/Linux i686)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/google-talkplugin/ChangeLog8
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-2.7.5.0.ebuild13
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-2.8.5.0.ebuild117
3 files changed, 132 insertions, 6 deletions
diff --git a/www-plugins/google-talkplugin/ChangeLog b/www-plugins/google-talkplugin/ChangeLog
index 3f78f19b3865..64827e550d09 100644
--- a/www-plugins/google-talkplugin/ChangeLog
+++ b/www-plugins/google-talkplugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/google-talkplugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/ChangeLog,v 1.23 2012/03/19 03:15:03 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/ChangeLog,v 1.24 2012/03/29 14:00:13 ottxor Exp $
+
+*google-talkplugin-2.8.5.0 (29 Mar 2012)
+
+ 29 Mar 2012; Christoph Junghans <ottxor@gentoo.org>
+ google-talkplugin-2.7.5.0.ebuild, +google-talkplugin-2.8.5.0.ebuild:
+ version bump (bug #410095)
*google-talkplugin-2.7.5.0 (19 Mar 2012)
diff --git a/www-plugins/google-talkplugin/google-talkplugin-2.7.5.0.ebuild b/www-plugins/google-talkplugin/google-talkplugin-2.7.5.0.ebuild
index 5617417e9ea5..0ac443fb20d1 100644
--- a/www-plugins/google-talkplugin/google-talkplugin-2.7.5.0.ebuild
+++ b/www-plugins/google-talkplugin/google-talkplugin-2.7.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-2.7.5.0.ebuild,v 1.1 2012/03/19 03:15:03 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-2.7.5.0.ebuild,v 1.2 2012/03/29 14:00:13 ottxor Exp $
EAPI=4
@@ -28,7 +28,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
#GoogleTalkPlugin binary contains openssl
LICENSE="google-talkplugin openssl"
-RESTRICT="strip mirror"
+RESTRICT="fetch strip"
RDEPEND="|| ( media-sound/pulseaudio media-libs/alsa-lib )
dev-libs/glib:2
@@ -73,9 +73,12 @@ done
# nofetch means upstream bumped and thus needs version bump
pkg_nofetch() {
- einfo "This version is no longer available from Google."
- einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
- einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+ elog "This version is no longer available from Google and the license prevents mirroring."
+ elog "This ebuild is intended for users who already downloaded it previously and have problems"
+ elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
+ use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
+ elog "it with google: http://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
+ elog "and copy the file ${MY_PKG} to ${DISTDIR}."
}
src_unpack() {
diff --git a/www-plugins/google-talkplugin/google-talkplugin-2.8.5.0.ebuild b/www-plugins/google-talkplugin/google-talkplugin-2.8.5.0.ebuild
new file mode 100644
index 000000000000..5c9a3a50ac18
--- /dev/null
+++ b/www-plugins/google-talkplugin/google-talkplugin-2.8.5.0.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-2.8.5.0.ebuild,v 1.1 2012/03/29 14:00:13 ottxor Exp $
+
+EAPI=4
+
+inherit eutils nsplugins unpacker
+
+if [ "${PV}" != "9999" ]; then
+ DEB_PATCH="1"
+ #http://dl.google.com/linux/talkplugin/deb/dists/stable/main/binary-i386/Packages
+ MY_URL="http://dl.google.com/linux/talkplugin/deb/pool/main/${P:0:1}/${PN}"
+ MY_PKG="${PN}_${PV}-${DEB_PATCH}_i386.deb"
+ SRC_URI="x86? ( ${MY_URL}/${MY_PKG} )
+ amd64? ( ${MY_URL}/${MY_PKG/i386/amd64} )"
+else
+ MY_URL="http://dl.google.com/linux/direct"
+ MY_PKG="${PN}_current_i386.deb"
+ SRC_URI=""
+fi
+
+DESCRIPTION="Video chat browser plug-in for Google Talk"
+
+HOMEPAGE="http://www.google.com/chat/video"
+IUSE="libnotify +system-libCg"
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+#GoogleTalkPlugin binary contains openssl
+LICENSE="google-talkplugin openssl"
+RESTRICT="strip mirror"
+
+RDEPEND="|| ( media-sound/pulseaudio media-libs/alsa-lib )
+ dev-libs/glib:2
+ system-libCg? ( media-gfx/nvidia-cg-toolkit )
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/libpng:1.2
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXt
+ sys-apps/lsb-release
+ virtual/opengl
+ libnotify? ( x11-libs/libnotify )"
+
+DEPEND=""
+
+INSTALL_BASE="opt/google/talkplugin"
+
+QA_EXECSTACK="${INSTALL_BASE}/GoogleTalkPlugin"
+
+QA_TEXTRELS="${INSTALL_BASE}/libnpg*.so"
+
+QA_DT_HASH="${INSTALL_BASE}/libnpg.*so
+ ${INSTALL_BASE}/GoogleTalkPlugin"
+
+S="${WORKDIR}"
+
+LANGS="ar cs en et fr hu lt ms pl ru sv tl vi bg da fa gu id ja lv nl
+sk ta tr bn de es fi hi is kn ml no sl te uk ca el fil hr it ko mr or
+ro sr th ur"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+# nofetch means upstream bumped and thus needs version bump
+pkg_nofetch() {
+ einfo "This version is no longer available from Google."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+}
+
+src_unpack() {
+ local pkg="${A:=${MY_PKG}}"
+ if [ "${PV}" = "9999" ]; then
+ use amd64 && pkg="${pkg/i386/amd64}"
+ einfo "Fetching ${pkg}"
+ wget "${MY_URL}/${pkg}" || die
+ fi
+ unpacker ${pkg}
+}
+
+src_install() {
+ unpacker usr/share/doc/google-talkplugin/changelog.Debian.gz
+ dodoc usr/share/doc/google-talkplugin/changelog.Debian
+
+ exeinto "/${INSTALL_BASE}"
+ doexe "${INSTALL_BASE}"/GoogleTalkPlugin
+ for i in "${INSTALL_BASE}"/libnpg*.so; do
+ doexe "${i}"
+ inst_plugin "/${i}"
+ done
+
+ #install screen-sharing stuff - bug #397463
+ insinto "/${INSTALL_BASE}"
+ doins "${INSTALL_BASE}"/windowpicker.glade
+
+ strip-linguas ${LANGS}
+ for l in ${LINGUAS}; do
+ insinto "/${INSTALL_BASE}"/locale/$l/LC_MESSAGES/
+ doins "${INSTALL_BASE}"/locale/$l/LC_MESSAGES/windowpicker.mo
+ done
+
+ #install bundled libCg
+ if ! use system-libCg; then
+ exeinto "/${INSTALL_BASE}"/lib
+ doexe "${INSTALL_BASE}"/lib/*.so
+ fi
+}