summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-05-16 14:01:31 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-05-16 14:01:31 +0000
commit8180b821f38a64f42fcbe9b88579fcae094654c2 (patch)
treeef50e208c0dc45aa82b94de101a9c93eebc23ae4 /www-plugins
parentkeyword ~x86-fbsd, bug #269233 (diff)
downloadgentoo-2-8180b821f38a64f42fcbe9b88579fcae094654c2.tar.gz
gentoo-2-8180b821f38a64f42fcbe9b88579fcae094654c2.tar.bz2
gentoo-2-8180b821f38a64f42fcbe9b88579fcae094654c2.zip
version bump to 0.3.2
(Portage version: 2.1.6.11/cvs/Linux ppc)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/mozilla-weave/ChangeLog8
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild10
-rw-r--r--www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild91
3 files changed, 102 insertions, 7 deletions
diff --git a/www-plugins/mozilla-weave/ChangeLog b/www-plugins/mozilla-weave/ChangeLog
index be71f1e984d6..c25a74fc68e7 100644
--- a/www-plugins/mozilla-weave/ChangeLog
+++ b/www-plugins/mozilla-weave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/mozilla-weave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.3 2009/05/16 13:14:17 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/ChangeLog,v 1.4 2009/05/16 14:01:31 volkmar Exp $
+
+*mozilla-weave-0.3.2 (16 May 2009)
+
+ 16 May 2009; Mounir Lamouri <volkmar@gentoo.org>
+ mozilla-weave-0.3.0.ebuild, +mozilla-weave-0.3.2.ebuild:
+ Version bump to 0.3.2
16 May 2009; Mounir Lamouri <volkmar@gentoo.org>
mozilla-weave-0.2.104.ebuild, mozilla-weave-0.3.0.ebuild:
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild
index 783f7ca17bf4..70dc30243b7e 100644
--- a/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild
+++ b/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild,v 1.2 2009/05/16 13:14:17 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.3.0.ebuild,v 1.3 2009/05/16 14:01:31 volkmar Exp $
EAPI="2"
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-RDEPEND=">=www-client/mozilla-firefox-bin-3.1_beta
+RDEPEND=">=www-client/mozilla-firefox-bin-3.1_beta3
net-libs/xulrunner:1.9
>=dev-libs/nss-3.12
>=dev-libs/nspr-4.7.1"
@@ -27,12 +27,10 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
-# TODO: KEYWORDS is empty because it needs to be tested for amd64 and x86 (bin)
-
# NOTES:
# there are tests but they don't break the build if not working
-# thunderbird and fennec are in install.rdf
-# mozilla-firefox-3.1_beta is not in the tree atm
+# thunderbird and fennec are listed in install.rdf
+# mozilla-firefox-3.{1,5} (not -bin) is not in the tree atm
src_prepare() {
# we want to use system nss and nspr
diff --git a/www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild b/www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild
new file mode 100644
index 000000000000..0c1e64aaa845
--- /dev/null
+++ b/www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mozilla-weave/mozilla-weave-0.3.2.ebuild,v 1.1 2009/05/16 14:01:31 volkmar Exp $
+
+EAPI="2"
+
+inherit mozextension multilib
+
+MY_PN="weave"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Mozilla Labs prototype for online services into Firefox"
+HOMEPAGE="http://labs.mozilla.com/projects/weave/"
+SRC_URI="http://hg.mozilla.org/labs/${MY_PN}/index.cgi/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-bin-3.1_beta3
+ >=www-client/seamonkey-bin-2.0_alpha3
+ )
+ net-libs/xulrunner:1.9
+ >=dev-libs/nss-3.12
+ >=dev-libs/nspr-4.7.1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+# NOTES:
+# there are tests but they don't break the build if not working
+# thunderbird and fennec are listed in install.rdf
+# mozilla-firefox-3.{1,5} (not -bin) is not in the tree atm
+# seamonkey-2 (not -bin) is not in the tree atm
+
+src_prepare() {
+ # we want to use system nss and nspr
+ sed -i -e 's@-I\$(sdkdir)\(/include/ns\(s\|pr\)\)@-I/usr\1@' \
+ src/Makefile || die "patching Makefile failed"
+ sed -i -e 's@^\(libdirs\s*:=\s*.*\)$@\1 /usr/lib/nspr /usr/lib/nss@' \
+ src/Makefile || die "patching Makefile failed"
+
+ # remove useless platforms
+ rm -fr platform/* || die "rm -rf never dies"
+
+ # ppc arch is not recognized on Linux
+ # upstream has been contacted w/patch, see bug 486797 in upstream bugtracker
+ sed -i -e "s/Power Macintosh/ppc/" src/Makefile \
+ || die "patching src/Makefile failed"
+
+ # stupid mistake in a var in Makefile
+ sed -i -e "s/0.3.1/0.3.2/" Makefile || die "sed failed"
+}
+
+src_compile() {
+ export XULRUNNER_BIN=/usr/bin/xulrunner-1.9
+ export WEAVE_BUILDID=${PV}
+ export MOZSDKDIR=/usr/$(get_libdir)/xulrunner-1.9
+
+ emake release_build=1 xpi || "emake failed"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+
+ # recommanded usage is to launch firefox with xpi as a parameter
+ # so, we unzip the file and intsall it with mozextension tools
+ unzip -qo "${MY_P}-rel.xpi" -d "${MY_P}"
+
+ if has_version '>=www-client/mozilla-firefox-3.1_beta3'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}/${MY_P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-3.1_beta3'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}/${MY_P}"
+ fi
+ if has_version '>=www-client/seamonkey-bin-2.0_alpha3'; then
+ MOZILLA_FIVE_HOME="/opt/seamonkey"
+ xpi_install "${S}/${MY_P}"
+ fi
+}
+
+pkg_postinst() {
+ einfo "To use Weave, you have to get an account at https://services.mozilla.com/"
+ einfo "Otherwise, you can setup your own server, see:"
+ einfo "https://wiki.mozilla.org/Labs/Weave/0.3/Setup/Server"
+}