summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2008-09-28 17:16:23 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2008-09-28 17:16:23 +0000
commit73a26427f1170205881e78844e2025ccc780f2ae (patch)
tree4fcfc9772f4ee9035b8cfbedac2ca6c1dc88fdc7 /www-servers/cherokee
parentamd64 stable, bug #238535 (diff)
downloadgentoo-2-73a26427f1170205881e78844e2025ccc780f2ae.tar.gz
gentoo-2-73a26427f1170205881e78844e2025ccc780f2ae.tar.bz2
gentoo-2-73a26427f1170205881e78844e2025ccc780f2ae.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-servers/cherokee')
-rw-r--r--www-servers/cherokee/ChangeLog9
-rw-r--r--www-servers/cherokee/cherokee-0.5.6.ebuild103
-rw-r--r--www-servers/cherokee/cherokee-0.6.0.ebuild113
-rw-r--r--www-servers/cherokee/cherokee-0.7.0.ebuild113
-rw-r--r--www-servers/cherokee/cherokee-0.7.2.ebuild119
-rw-r--r--www-servers/cherokee/cherokee-0.9.0.ebuild (renamed from www-servers/cherokee/cherokee-0.6.1.ebuild)11
6 files changed, 10 insertions, 458 deletions
diff --git a/www-servers/cherokee/ChangeLog b/www-servers/cherokee/ChangeLog
index 697e5cfa705e..6f3de13251e3 100644
--- a/www-servers/cherokee/ChangeLog
+++ b/www-servers/cherokee/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/cherokee
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/ChangeLog,v 1.43 2008/09/02 19:58:52 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/ChangeLog,v 1.44 2008/09/28 17:16:23 bass Exp $
+
+*cherokee-0.9.0 (28 Sep 2008)
+
+ 28 Sep 2008; J. Alberto Suárez López <bass@gentoo.org>
+ -cherokee-0.5.6.ebuild, -cherokee-0.6.0.ebuild, -cherokee-0.6.1.ebuild,
+ -cherokee-0.7.0.ebuild, -cherokee-0.7.2.ebuild, +cherokee-0.9.0.ebuild:
+ Version bump
*cherokee-0.8.1 (02 Sep 2008)
diff --git a/www-servers/cherokee/cherokee-0.5.6.ebuild b/www-servers/cherokee/cherokee-0.5.6.ebuild
deleted file mode 100644
index 00c9eb8e3754..000000000000
--- a/www-servers/cherokee/cherokee-0.5.6.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.5.6.ebuild,v 1.4 2006/12/27 06:06:49 flameeyes Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-inherit eutils pam versionator libtool autotools
-
-DESCRIPTION="An extremely fast and tiny web server."
-SRC_URI="http://www.cherokee-project.com/download/$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.cherokee-project.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="ipv6 ssl gnutls static pam coverpage threads kernel_linux"
-
-RDEPEND=">=sys-libs/zlib-1.1.4-r1
- ssl? (
- gnutls? ( net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- )
- pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${P}-epoll-crosscompile.patch"
- epatch "${FILESDIR}/${P}-sendfile-crosscompile.patch"
- epatch "${FILESDIR}/${P}-gnutls-pkgconfig.patch"
- epatch "${FILESDIR}/${P}-replace-with-sed.patch"
-
- AT_M4DIR="m4" eautoreconf
-
- # use cherokee user/group
- sed -i -e 's|^#\(User \).*$|\1cherokee|' \
- -e 's|^#\(Group \).*$|\1cherokee|' "${S}/cherokee.conf.sample.pre" || \
- die "sed cherokee.conf failed"
-}
-
-src_compile() {
- local myconf
-
- if use ssl && use gnutls ; then
- myconf="${myconf} --enable-tls=gnutls"
- elif use ssl && ! use gnutls ; then
- myconf="${myconf} --enable-tls=openssl"
- else
- myconf="${myconf} --disable-tls"
- fi
-
- if use static ; then
- myconf="${myconf} --enable-static --enable-static-module=all"
- else
- myconf="${myconf} --disable-static"
- fi
-
- local os="Unknown"
- case "${CHOST}" in
- *-freebsd*)
- os="FreeBSD" ;;
- *-netbsd*)
- os="NetBSD" ;;
- *-openbsd*)
- os="OpenBSD" ;;
- *)
- os="Linux" ;;
- esac
-
- econf \
- ${myconf} \
- $(use_enable pam) \
- $(use_enable ipv6) \
- $(use_enable threads pthread) \
- $(use_enable kernel_linux epoll) \
- --disable-dependency-tracking \
- --enable-os-string="Gentoo ${os}" \
- --with-wwwroot=/var/www/localhost/htdocs \
- || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake -j1 DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
- dodoc AUTHORS ChangeLog TODO
-
- newpamd pam.d_cherokee ${PN} || die "newpamd failed"
- newinitd "${FILESDIR}/${PN}-initd-0.5.6" ${PN} || die "newinitd failed"
-
- keepdir /etc/cherokee/mods-enabled /etc/cherokee/sites-enabled /var/www/localhost/htdocs
-
- use coverpage || rm -rf "${D}"/var/www/localhost/htdocs/{index.html,images}
-}
-
-pkg_postinst() {
- enewgroup cherokee
- enewuser cherokee -1 -1 /var/www/localhost cherokee
-}
diff --git a/www-servers/cherokee/cherokee-0.6.0.ebuild b/www-servers/cherokee/cherokee-0.6.0.ebuild
deleted file mode 100644
index 11b942e3d016..000000000000
--- a/www-servers/cherokee/cherokee-0.6.0.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.6.0.ebuild,v 1.3 2008/03/17 17:19:31 mr_bones_ Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-inherit eutils pam versionator libtool autotools
-
-DESCRIPTION="An extremely fast and tiny web server."
-SRC_URI="http://www.cherokee-project.com/download/$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.cherokee-project.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="ipv6 ssl gnutls static pam coverpage threads kernel_linux admin"
-
-RDEPEND=">=sys-libs/zlib-1.1.4-r1
- ssl? (
- gnutls? ( net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- )
- pam? ( virtual/pam )
- admin? ( dev-lang/python )"
-DEPEND="${RDEPEND}"
-
-#S="${WORKDIR}/${P}b1240"
-
-src_compile() {
- local myconf
-
- if use ssl && use gnutls ; then
- myconf="${myconf} --enable-tls=gnutls"
- elif use ssl && ! use gnutls ; then
- myconf="${myconf} --enable-tls=openssl"
- else
- myconf="${myconf} --disable-tls"
- fi
-
- if use static ; then
- myconf="${myconf} --enable-static --enable-static-module=all"
- else
- myconf="${myconf} --disable-static"
- fi
-
- local os="Unknown"
- case "${CHOST}" in
- *-freebsd*)
- os="FreeBSD" ;;
- *-netbsd*)
- os="NetBSD" ;;
- *-openbsd*)
- os="OpenBSD" ;;
- *)
- os="Linux" ;;
- esac
-
- econf \
- ${myconf} \
- $(use_enable pam) \
- $(use_enable ipv6) \
- $(use_enable threads pthread) \
- $(use_enable kernel_linux epoll) \
- --disable-dependency-tracking \
- --enable-os-string="Gentoo ${os}" \
- --with-wwwroot=/var/www/localhost/htdocs \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake -j1 DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
- dodoc AUTHORS ChangeLog TODO
-
- newpamd pam.d_cherokee ${PN} || die "newpamd failed"
- newinitd "${FILESDIR}/${PN}-initd-0.6" ${PN} || die "newinitd failed"
-
- dodir /usr/share/doc/${PF}/contrib
- insinto /usr/share/${PF}/contrib
- doins contrib/05to06.py
-
- keepdir /etc/cherokee/mods-enabled /etc/cherokee/sites-enabled /var/www/localhost/htdocs
-
- use coverpage || rm -rf "${D}"/var/www/localhost/htdocs/{index.html,images}
- use admin || rm -rf "${D}"/usr/sbin/admin "${D}"/usr/share/cherokee/admin
-
-}
-
-pkg_postinst() {
- enewgroup cherokee
- enewuser cherokee -1 -1 /var/www/localhost cherokee
-
- if use admin ; then
- echo ""
- elog "Just run 'cherokee-admin' and go to: http://localhost:9090"
- echo ""
- else
- echo ""
- elog "Try USE=admin if you want a easy way to configure cherokee."
- echo ""
- fi
-
- echo ""
- elog "Cherokee conf is quite different in 0.6.x series. You must use"
- elog " cherokee-admin to create a new config or use /usr/share/doc/${PF}/contrib/05to06.py"
- elog " to export your old config (not ever works)."
- echo ""
-}
diff --git a/www-servers/cherokee/cherokee-0.7.0.ebuild b/www-servers/cherokee/cherokee-0.7.0.ebuild
deleted file mode 100644
index d5cd57485ec0..000000000000
--- a/www-servers/cherokee/cherokee-0.7.0.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.7.0.ebuild,v 1.2 2008/06/03 15:40:36 mr_bones_ Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-inherit eutils pam versionator libtool autotools
-
-DESCRIPTION="An extremely fast and tiny web server."
-SRC_URI="http://www.cherokee-project.com/download/$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.cherokee-project.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="ipv6 ssl gnutls static pam coverpage threads kernel_linux admin"
-
-RDEPEND=">=sys-libs/zlib-1.1.4-r1
- ssl? (
- gnutls? ( net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- )
- pam? ( virtual/pam )
- admin? ( dev-lang/python )"
-DEPEND="${RDEPEND}"
-
-#S="${WORKDIR}/${P}b1240"
-
-src_compile() {
- local myconf
-
- if use ssl && use gnutls ; then
- myconf="${myconf} --enable-tls=gnutls"
- elif use ssl && ! use gnutls ; then
- myconf="${myconf} --enable-tls=openssl"
- else
- myconf="${myconf} --disable-tls"
- fi
-
- if use static ; then
- myconf="${myconf} --enable-static --enable-static-module=all"
- else
- myconf="${myconf} --disable-static"
- fi
-
- local os="Unknown"
- case "${CHOST}" in
- *-freebsd*)
- os="FreeBSD" ;;
- *-netbsd*)
- os="NetBSD" ;;
- *-openbsd*)
- os="OpenBSD" ;;
- *)
- os="Linux" ;;
- esac
-
- econf \
- ${myconf} \
- $(use_enable pam) \
- $(use_enable ipv6) \
- $(use_enable threads pthread) \
- $(use_enable kernel_linux epoll) \
- --disable-dependency-tracking \
- --enable-os-string="Gentoo ${os}" \
- --with-wwwroot=/var/www/localhost/htdocs \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake -j1 DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
- dodoc AUTHORS ChangeLog TODO
-
- newpamd pam.d_cherokee ${PN} || die "newpamd failed"
- newinitd "${FILESDIR}/${PN}-initd-0.6" ${PN} || die "newinitd failed"
-
- dodir /usr/share/doc/${PF}/contrib
- insinto /usr/share/${PF}/contrib
- doins contrib/05to06.py
-
- keepdir /etc/cherokee/mods-enabled /etc/cherokee/sites-enabled /var/www/localhost/htdocs
-
- use coverpage || rm -rf "${D}"/var/www/localhost/htdocs/{index.html,images}
- use admin || rm -rf "${D}"/usr/sbin/admin "${D}"/usr/share/cherokee/admin
-
-}
-
-pkg_postinst() {
- enewgroup cherokee
- enewuser cherokee -1 -1 /var/www/localhost cherokee
-
- if use admin ; then
- echo ""
- elog "Just run 'cherokee-admin' and go to: http://localhost:9090"
- echo ""
- else
- echo ""
- elog "Try USE=admin if you want a easy way to configure cherokee."
- echo ""
- fi
-
- echo ""
- elog "Cherokee conf is quite different in 0.6.x series. You must use"
- elog " cherokee-admin to create a new config or use /usr/share/doc/${PF}/contrib/05to06.py"
- elog " to export your old config (not ever works)."
- echo ""
-}
diff --git a/www-servers/cherokee/cherokee-0.7.2.ebuild b/www-servers/cherokee/cherokee-0.7.2.ebuild
deleted file mode 100644
index beced80b763a..000000000000
--- a/www-servers/cherokee/cherokee-0.7.2.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.7.2.ebuild,v 1.2 2008/06/20 08:35:51 dev-zero Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-inherit eutils pam versionator libtool autotools
-
-DESCRIPTION="An extremely fast and tiny web server."
-SRC_URI="http://www.cherokee-project.com/download/$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.cherokee-project.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="ipv6 ssl gnutls static pam coverpage threads kernel_linux admin"
-
-RDEPEND=">=sys-libs/zlib-1.1.4-r1
- ssl? (
- gnutls? ( net-libs/gnutls )
- !gnutls? ( dev-libs/openssl )
- )
- pam? ( virtual/pam )
- admin? ( dev-lang/python )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-signed_unsigned_char.patch"
-}
-
-src_compile() {
- local myconf
-
- if use ssl && use gnutls ; then
- myconf="${myconf} --enable-tls=gnutls"
- elif use ssl && ! use gnutls ; then
- myconf="${myconf} --enable-tls=openssl"
- else
- myconf="${myconf} --disable-tls"
- fi
-
- if use static ; then
- myconf="${myconf} --enable-static --enable-static-module=all"
- else
- myconf="${myconf} --disable-static"
- fi
-
- local os="Unknown"
- case "${CHOST}" in
- *-freebsd*)
- os="FreeBSD" ;;
- *-netbsd*)
- os="NetBSD" ;;
- *-openbsd*)
- os="OpenBSD" ;;
- *)
- os="Linux" ;;
- esac
-
- econf \
- ${myconf} \
- $(use_enable pam) \
- $(use_enable ipv6) \
- $(use_enable threads pthread) \
- $(use_enable kernel_linux epoll) \
- --disable-dependency-tracking \
- --enable-os-string="Gentoo ${os}" \
- --with-wwwroot=/var/www/localhost/htdocs \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake -j1 DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
- dodoc AUTHORS ChangeLog TODO
-
- newpamd pam.d_cherokee ${PN} || die "newpamd failed"
- newinitd "${FILESDIR}/${PN}-initd-0.6" ${PN} || die "newinitd failed"
-
- dodir /usr/share/doc/${PF}/contrib
- insinto /usr/share/${PF}/contrib
- doins contrib/05to06.py
- doins contrib/06to07.py
-
- keepdir /etc/cherokee/mods-enabled /etc/cherokee/sites-enabled /var/www/localhost/htdocs
-
- use coverpage || rm -rf "${D}"/var/www/localhost/htdocs/{index.html,images}
- use admin || rm -rf "${D}"/usr/sbin/admin "${D}"/usr/share/cherokee/admin
-
-}
-
-pkg_postinst() {
- enewgroup cherokee
- enewuser cherokee -1 -1 /var/www/localhost cherokee
-
- if use admin ; then
- echo ""
- elog "Just run 'cherokee-admin' and go to: http://localhost:9090"
- echo ""
- else
- echo ""
- elog "Try USE=admin if you want a easy way to configure cherokee."
- echo ""
- fi
-
- echo ""
- elog "Cherokee conf is quite different in 0.6.x and 0.7.x series. You must use"
- elog " cherokee-admin to create a new config or use /usr/share/doc/${PF}/contrib/05to06.py"
- elog " or 06to07.py to export your old config (not ever works)."
- echo ""
-}
diff --git a/www-servers/cherokee/cherokee-0.6.1.ebuild b/www-servers/cherokee/cherokee-0.9.0.ebuild
index 1ac5006c5260..94aaa4d563e3 100644
--- a/www-servers/cherokee/cherokee-0.6.1.ebuild
+++ b/www-servers/cherokee/cherokee-0.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.6.1.ebuild,v 1.1 2008/03/25 10:39:34 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.9.0.ebuild,v 1.1 2008/09/28 17:16:23 bass Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -25,8 +25,6 @@ RDEPEND=">=sys-libs/zlib-1.1.4-r1
admin? ( dev-lang/python )"
DEPEND="${RDEPEND}"
-#S="${WORKDIR}/${P}b1240"
-
src_compile() {
local myconf
@@ -83,6 +81,7 @@ src_install () {
dodir /usr/share/doc/${PF}/contrib
insinto /usr/share/${PF}/contrib
doins contrib/05to06.py
+ doins contrib/06to07.py
keepdir /etc/cherokee/mods-enabled /etc/cherokee/sites-enabled /var/www/localhost/htdocs
@@ -104,10 +103,4 @@ pkg_postinst() {
elog "Try USE=admin if you want a easy way to configure cherokee."
echo ""
fi
-
- echo ""
- elog "Cherokee conf is quite different in 0.6.x series. You must use"
- elog " cherokee-admin to create a new config or use /usr/share/doc/${PF}/contrib/05to06.py"
- elog " to export your old config (not ever works)."
- echo ""
}