summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-12-22 22:22:10 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-12-22 22:22:10 +0000
commit6568470097203e5857b5dfeb0edf6524aa93ce9a (patch)
treec2110b011edd2d414440aad47752d1f49514939e /www-servers/gunicorn
parentVersion bump. (diff)
downloadgentoo-2-6568470097203e5857b5dfeb0edf6524aa93ce9a.tar.gz
gentoo-2-6568470097203e5857b5dfeb0edf6524aa93ce9a.tar.bz2
gentoo-2-6568470097203e5857b5dfeb0edf6524aa93ce9a.zip
Version bump.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/ChangeLog8
-rw-r--r--www-servers/gunicorn/gunicorn-0.12.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index 4daf2540077b..f8aa3cc36986 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.1 2010/12/12 20:37:18 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.2 2010/12/22 22:22:10 rafaelmartins Exp $
+
+*gunicorn-0.12.0 (22 Dec 2010)
+
+ 22 Dec 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gunicorn-0.12.0.ebuild:
+ Version bump.
*gunicorn-0.11.2 (12 Dec 2010)
diff --git a/www-servers/gunicorn/gunicorn-0.12.0.ebuild b/www-servers/gunicorn/gunicorn-0.12.0.ebuild
new file mode 100644
index 000000000000..5debd62e3175
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-0.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.12.0.ebuild,v 1.1 2010/12/22 22:22:10 rafaelmartins Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="A WSGI HTTP Server for UNIX, fast clients and nothing else"
+HOMEPAGE="http://gunicorn.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools
+ test? ( dev-python/nose )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+DOCS="README.rst"
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r doc/htdocs/*
+ insinto "/usr/share/doc/${PF}"
+ use examples && doins -r examples
+}
+
+src_test() {
+ # distutils_src_test doesn't works if gunicorn isn't installed yet
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" \
+ setup.py test || die 'test failed.'
+ }
+ python_execute_function testing
+}