summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-16 08:17:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-16 08:17:08 +0000
commit9b22953250a41adcf1160f3427baa416971bb110 (patch)
tree5decbf50cf7837f1c1441a0872ab77b089e5d450 /www-servers/monkeyd
parentppc stable (bug 408487) (diff)
downloadgentoo-2-9b22953250a41adcf1160f3427baa416971bb110.tar.gz
gentoo-2-9b22953250a41adcf1160f3427baa416971bb110.tar.bz2
gentoo-2-9b22953250a41adcf1160f3427baa416971bb110.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/monkeyd')
-rw-r--r--www-servers/monkeyd/ChangeLog7
-rw-r--r--www-servers/monkeyd/monkeyd-1.0.1.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index 4838c37fe5cf..4aaa0c8a4299 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/monkeyd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.35 2012/06/07 08:25:21 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.36 2012/06/16 08:17:08 blueness Exp $
+
+*monkeyd-1.0.1 (16 Jun 2012)
+
+ 16 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +monkeyd-1.0.1.ebuild:
+ Version bump
07 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
-monkeyd-0.33.0-r1.ebuild, -files/monkeyd-dont-strip-configure.patch,
diff --git a/www-servers/monkeyd/monkeyd-1.0.1.ebuild b/www-servers/monkeyd/monkeyd-1.0.1.ebuild
new file mode 100644
index 000000000000..7b1e1e2cd18d
--- /dev/null
+++ b/www-servers/monkeyd/monkeyd-1.0.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-1.0.1.ebuild,v 1.1 2012/06/16 08:17:08 blueness Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs depend.php multilib
+
+WEBROOT="/var/www/localhost"
+
+MY_P="${PN/d}-${PV}"
+DESCRIPTION="A small, fast, and scalable web server"
+HOMEPAGE="http://www.monkey-project.com/"
+SRC_URI="http://monkey-project.com/releases/${PV:0:3}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="php"
+
+RDEPEND="php? ( virtual/httpd-php )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use php && require_php_cgi
+}
+
+src_prepare() {
+ # Don't install the banana script, we use ${FILESDIR}/monkeyd.initd
+ sed -i '/install -m 755 bin\/banana/d' configure || die "sed banana"
+
+ # Don't explicitly strip files
+ sed -i -e '/$STRIP /d' -e 's/install -s -m 644/install -m 755/' configure || die
+}
+
+src_configure() {
+ # Non-autotools configure
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=${WEBROOT}/htdocs \
+ --logdir=/var/log/${PN} \
+ --mandir=/usr/share/man \
+ --plugdir=/usr/$(get_libdir)/monkeyd/plugins \
+ --sysconfdir=/etc/${PN} \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+
+ # Don't install the banana script man page
+ rm "${S}"/man/banana.1
+}
+
+src_install() {
+ default
+
+ if use php ; then
+ sed -i -e '/^#AddScript application\/x-httpd-php/s:^#::' "${D}"/etc/monkeyd/monkey.conf || die
+ sed -i -e 's:/home/my_home/php/bin/php:/usr/bin/php-cgi:' "${D}"/etc/monkeyd/monkey.conf || die
+ fi
+
+ mv "${D}"${WEBROOT}/htdocs/{index,index-monkey}.html
+
+ sed -i -e "s:/var/log/monkeyd/monkey.pid:/var/run/monkey.pid:" "${D}"/etc/monkeyd/monkey.conf || die
+ newinitd "${FILESDIR}"/monkeyd.initd monkeyd
+ newconfd "${FILESDIR}"/monkeyd.confd monkeyd
+}