summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-07-14 13:11:19 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-07-14 13:11:19 +0000
commit5ccf409c47a9439f6dbefd9d2702902ee0cf9776 (patch)
treeff8bcfea35ea7c553cfcc5f99d2e7f28746e31bd /www-servers/nginx
parent2.4.30-r3 stabilization (diff)
downloadgentoo-2-5ccf409c47a9439f6dbefd9d2702902ee0cf9776.tar.gz
gentoo-2-5ccf409c47a9439f6dbefd9d2702902ee0cf9776.tar.bz2
gentoo-2-5ccf409c47a9439f6dbefd9d2702902ee0cf9776.zip
* bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest4
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.391
-rw-r--r--www-servers/nginx/nginx-0.1.39.ebuild68
4 files changed, 78 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index f326fb3af97d..541fd78586e4 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.33 2005/07/11 03:54:57 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.34 2005/07/14 13:11:19 voxus Exp $
+
+*nginx-0.1.39 (14 Jul 2005)
+
+ 14 Jul 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.1.39.ebuild:
+ Version bump.
*nginx-0.1.38 (11 Jul 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index dfd475d72706..83cd07d9a521 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,8 +1,10 @@
MD5 4d709334244203f40e373b840fc93315 nginx-0.1.38.ebuild 1824
MD5 98db90f9a2bfa831d161546966272c78 nginx-0.1.37.ebuild 1822
-MD5 bf1fafc858bf9c2ed38256295d005669 ChangeLog 6049
+MD5 ce7bf983e9515a22dc661b91f40cf42e nginx-0.1.39.ebuild 1900
+MD5 fac9e89fc2083ee9f813cf92780e41ab ChangeLog 6171
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
MD5 23dc869263233b746e0a92df932c1d77 files/digest-nginx-0.1.37 64
MD5 08b4fee07b21ac422ba46360d47971f5 files/digest-nginx-0.1.38 64
+MD5 777f6009404998ee19def5cf7f35834b files/digest-nginx-0.1.39 64
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
diff --git a/www-servers/nginx/files/digest-nginx-0.1.39 b/www-servers/nginx/files/digest-nginx-0.1.39
new file mode 100644
index 000000000000..321aa07b4fbe
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.1.39
@@ -0,0 +1 @@
+MD5 1d89eda584082bbcf2e5f62bf38671f6 nginx-0.1.39.tar.gz 314685
diff --git a/www-servers/nginx/nginx-0.1.39.ebuild b/www-servers/nginx/nginx-0.1.39.ebuild
new file mode 100644
index 000000000000..7e74fb0dcb19
--- /dev/null
+++ b/www-servers/nginx/nginx-0.1.39.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.39.ebuild,v 1.1 2005/07/14 13:11:19 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || myconf="${myconf} --without-pcre"
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}