summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2006-05-16 16:58:11 +0000
committerThilo Bangert <bangert@gentoo.org>2006-05-16 16:58:11 +0000
commitbc1656f0998f34e0417226fabfe1ccc0d42cb2db (patch)
treea3870e1e1e81a8b55b765c2f4dbe52d96e025663 /www-servers/pound/pound-1.10.ebuild
parentFix bug 133409 and other sandbox violations i hope. Also put this in ~arch. (diff)
downloadgentoo-2-bc1656f0998f34e0417226fabfe1ccc0d42cb2db.tar.gz
gentoo-2-bc1656f0998f34e0417226fabfe1ccc0d42cb2db.tar.bz2
gentoo-2-bc1656f0998f34e0417226fabfe1ccc0d42cb2db.zip
added old version - has the security fix, but not the incompatible configuration file change (bug #118541)
(Portage version: 2.0.54-r2)
Diffstat (limited to 'www-servers/pound/pound-1.10.ebuild')
-rw-r--r--www-servers/pound/pound-1.10.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/www-servers/pound/pound-1.10.ebuild b/www-servers/pound/pound-1.10.ebuild
new file mode 100644
index 000000000000..25ca05002d7d
--- /dev/null
+++ b/www-servers/pound/pound-1.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.10.ebuild,v 1.1 2006/05/16 16:58:11 bangert Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
+IUSE="ssl msdav unsafe static"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable msdav) \
+ $(use_enable unsafe) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ dosbin pound
+ doman pound.8
+
+ dodoc README FAQ
+
+ newinitd ${FILESDIR}/${PN}.init-${PV} ${PN}
+
+ insinto /etc
+ doins ${FILESDIR}/pound.cfg
+}
+
+pkg_postinst() {
+ einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ einfo "for more info."
+ einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+}