summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-11 10:14:01 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-11 10:14:01 +0000
commit023c7c29498d40c927d3625538888c337fea9cb8 (patch)
tree57069bfb559efb940597108558b0a9e1e6be208b /www-servers
parentfixing USE=-cups properly (diff)
downloadgentoo-2-023c7c29498d40c927d3625538888c337fea9cb8.tar.gz
gentoo-2-023c7c29498d40c927d3625538888c337fea9cb8.tar.bz2
gentoo-2-023c7c29498d40c927d3625538888c337fea9cb8.zip
* bump
(Portage version: 2.1.2_rc3-r2)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.5.13
-rw-r--r--www-servers/nginx/nginx-0.5.1.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 7d8893dfc89a..d2e14267e1e8 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.121 2006/12/04 17:13:21 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.122 2006/12/11 10:14:00 voxus Exp $
+
+*nginx-0.5.1 (11 Dec 2006)
+
+ 11 Dec 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.5.0.ebuild, +nginx-0.5.1.ebuild:
+ Version bump.
*nginx-0.5.0 (04 Dec 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.5.1 b/www-servers/nginx/files/digest-nginx-0.5.1
new file mode 100644
index 000000000000..7a23c6c07a12
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.5.1
@@ -0,0 +1,3 @@
+MD5 a87b060c0bd6a6c8e24e6e8a0a7b0844 nginx-0.5.1.tar.gz 441022
+RMD160 1f93d78e68f8e0711b9e4c135510011171353bd9 nginx-0.5.1.tar.gz 441022
+SHA256 047d6689320dc6b3d9e45fafd37203fd30c7197a1615603aa0bd7807f997e82d nginx-0.5.1.tar.gz 441022
diff --git a/www-servers/nginx/nginx-0.5.1.ebuild b/www-servers/nginx/nginx-0.5.1.ebuild
new file mode 100644
index 000000000000..ed2bd06a9788
--- /dev/null
+++ b/www-servers/nginx/nginx-0.5.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.1.ebuild,v 1.1 2006/12/11 10:14:01 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}