summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-04-19 16:35:22 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-04-19 16:35:22 +0000
commit6df31ee30023d1b32bc3eee373db7de08e12e19a (patch)
treeb243f4b33ee551dddaeb09a0fad8eddb9289d5fc /www-servers
parentinit script tweak to require /dev/root (diff)
downloadgentoo-2-6df31ee30023d1b32bc3eee373db7de08e12e19a.tar.gz
gentoo-2-6df31ee30023d1b32bc3eee373db7de08e12e19a.tar.bz2
gentoo-2-6df31ee30023d1b32bc3eee373db7de08e12e19a.zip
Multiple bug fixes, bugs #171487, #174498, #175016, & #175189.
(Portage version: 2.1.2.3)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/ChangeLog9
-rw-r--r--www-servers/tomcat/files/6/tomcat.conf6
-rwxr-xr-xwww-servers/tomcat/files/6/tomcat.init19
-rw-r--r--www-servers/tomcat/files/digest-tomcat-6.0.10-r3 (renamed from www-servers/tomcat/files/digest-tomcat-6.0.10-r2)0
-rw-r--r--www-servers/tomcat/tomcat-6.0.10-r3.ebuild (renamed from www-servers/tomcat/tomcat-6.0.10-r2.ebuild)14
5 files changed, 31 insertions, 17 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 2846dcc2c570..eae6f5bd3111 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.134 2007/04/07 00:35:32 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.135 2007/04/19 16:35:22 wltjr Exp $
+
+*tomcat-6.0.10-r3 (19 Apr 2007)
+
+ 19 Apr 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+ files/6/tomcat.conf, files/6/tomcat.init, -tomcat-6.0.10-r2.ebuild,
+ +tomcat-6.0.10-r3.ebuild:
+ Multiple bug fixes, bugs #171487, #174498, #175016, & #175189.
07 Apr 2007; William L. Thomson Jr. <wltjr@gentoo.org>
-files/5.5.20/catalinabuild-xml.patch,
diff --git a/www-servers/tomcat/files/6/tomcat.conf b/www-servers/tomcat/files/6/tomcat.conf
index becfac654717..7a56fce515bf 100644
--- a/www-servers/tomcat/files/6/tomcat.conf
+++ b/www-servers/tomcat/files/6/tomcat.conf
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.conf,v 1.1 2006/12/08 07:00:55 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.conf,v 1.2 2007/04/19 16:35:22 wltjr Exp $
# JVM Runtime
# Using the default setting, it will determine your JVM from the system-vm
@@ -6,9 +6,9 @@
# See java-config(1) manual page for assistance in determining this value.
#
# You can override this value with whatever path you wish.
-# Example: JAVA_HOME=/opt/sun-jdk-1.5.0.09
+# Example: GENTOO_VM="sun-jdk-1.6"
-JAVA_HOME=`java-config --jre-home`
+#GENTOO_VM="sun-jdk-1.6"
# (Optional) Java runtime options used when the "start", "stop", or "run"
# commands are executed.
diff --git a/www-servers/tomcat/files/6/tomcat.init b/www-servers/tomcat/files/6/tomcat.init
index c4e863f61d0f..be49a38999e5 100755
--- a/www-servers/tomcat/files/6/tomcat.init
+++ b/www-servers/tomcat/files/6/tomcat.init
@@ -1,9 +1,12 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init,v 1.4 2007/01/28 07:26:59 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init,v 1.5 2007/04/19 16:35:22 wltjr Exp $
init_env_vars() {
+ # Populate JAVA_HOME
+ JAVA_HOME=`java-config --jre-home`
+
# Set some sane defaults
if [ -z "${CATALINA_TMPDIR}" ] ; then
CATALINA_TMPDIR="${CATALINA_BASE}"/temp
@@ -38,7 +41,7 @@ init_env_vars() {
fi
}
-start-helper() {
+start_helper() {
local executor=${1}
shift
local arguments="--start --quiet --background --chuid ${CATALINA_USER}:${CATALINA_GROUP} \
@@ -54,21 +57,21 @@ depend() {
start() {
ebegin "Starting Tomcat"
init_env_vars
- # Figure out what arguments to pass start-helper based on TOMCAT_START
+ # Figure out what arguments to pass start_helper based on TOMCAT_START
if [[ "${TOMCAT_START}" == "debug" ]] ; then
- start-helper ${JAVA_HOME}/bin/jdb \
+ start_helper ${JAVA_HOME}/bin/jdb \
-sourcepath ${CATALINA_HOME}/../../jakarta-tomcat-catalina/catalina/src/share
elif [[ "${TOMCAT_START}" == "debug -security" ]] ; then
- start-helper ${JAVA_HOME}/bin/jdb \
+ start_helper ${JAVA_HOME}/bin/jdb \
-sourcepath ${CATALINA_HOME}/../../jakarta-tomcat-catalina/catalina/src/share \
-Djava.security.manager \
-Djava.security.policy=${CATALINA_BASE}/conf/catalina.policy
elif [[ "${TOMCAT_START}" == "jpda start" ]] ; then
- start-helper ${JAVA_HOME}/bin/java ${JPDA_OPTS}
+ start_helper ${JAVA_HOME}/bin/java ${JPDA_OPTS}
elif [[ "${TOMCAT_START}" == "start" ]] ; then
- start-helper ${JAVA_HOME}/bin/java
+ start_helper ${JAVA_HOME}/bin/java
elif [[ "${TOMCAT_START}" == "start -security" ]] ; then
- start-helper ${JAVA_HOME}/bin/java \
+ start_helper ${JAVA_HOME}/bin/java \
-Djava.security.manager \
-Djava.security.policy=${CATALINA_BASE}/conf/catalina.policy
else
diff --git a/www-servers/tomcat/files/digest-tomcat-6.0.10-r2 b/www-servers/tomcat/files/digest-tomcat-6.0.10-r3
index 3dd91cc642dc..3dd91cc642dc 100644
--- a/www-servers/tomcat/files/digest-tomcat-6.0.10-r2
+++ b/www-servers/tomcat/files/digest-tomcat-6.0.10-r3
diff --git a/www-servers/tomcat/tomcat-6.0.10-r2.ebuild b/www-servers/tomcat/tomcat-6.0.10-r3.ebuild
index a964c9e7c790..0189fece44b4 100644
--- a/www-servers/tomcat/tomcat-6.0.10-r2.ebuild
+++ b/www-servers/tomcat/tomcat-6.0.10-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.10-r2.ebuild,v 1.1 2007/04/04 22:22:55 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.10-r3.ebuild,v 1.1 2007/04/19 16:35:22 wltjr Exp $
WANT_ANT_TASKS="ant-trax"
@@ -17,17 +17,20 @@ LICENSE="Apache-2.0"
IUSE="doc examples source test"
-RDEPEND=">=virtual/jre-1.5
- =dev-java/eclipse-ecj-3.2*
+COMMON_DEPEND="=dev-java/eclipse-ecj-3.2*
>=dev-java/commons-daemon-1.0.1
>=dev-java/commons-dbcp-1.2.1
>=dev-java/commons-logging-1.1
>=dev-java/commons-pool-1.2
- ~dev-java/tomcat-servlet-api-${PV}
+ ~dev-java/tomcat-servlet-api-${PV}"
+
+RDEPEND=">=virtual/jre-1.5
+ dev-java/ant-core
+ ${COMMON_DEPEND}
examples? ( dev-java/jakarta-jstl )"
DEPEND=">=virtual/jdk-1.5
- ${RDEPEND}
+ ${COMMON_DEPEND}
test? ( dev-java/junit )"
S=${WORKDIR}/${MY_P}
@@ -83,6 +86,7 @@ src_install() {
# create dir structure
diropts -m755 -o tomcat -g tomcat
dodir /etc/${TOMCAT_NAME}/Catalina/localhost
+ chown -R tomcat:tomcat ${D}/etc/${TOMCAT_NAME}
fperms 750 /etc/${TOMCAT_NAME}
dodir /usr/share/${TOMCAT_NAME}
keepdir ${WEBAPPS_DIR}