summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-07-22 12:21:07 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-07-22 12:21:07 +0000
commit88336e5980ff67ec7e338a85aef7a35c8e9831f9 (patch)
tree5c2210ac6904a1b672d3fc9ed3802c30b59b8b72 /www-servers
parentRemove old. (diff)
downloadgentoo-2-88336e5980ff67ec7e338a85aef7a35c8e9831f9.tar.gz
gentoo-2-88336e5980ff67ec7e338a85aef7a35c8e9831f9.tar.bz2
gentoo-2-88336e5980ff67ec7e338a85aef7a35c8e9831f9.zip
Feed dodir and fperms functions with the ${dest} variable. This variable is
already formatted with the $CATALINA_BASE full path. Fix security bug 458890. Signed-off-by: Patrice Clement <monsieurp@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/ChangeLog7
-rw-r--r--www-servers/tomcat/tomcat-6.0.44-r0.ebuild6
-rw-r--r--www-servers/tomcat/tomcat-7.0.59-r2.ebuild6
-rw-r--r--www-servers/tomcat/tomcat-8.0.23-r2.ebuild6
4 files changed, 15 insertions, 10 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index f95b1f7de138..a414203d8e85 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.361 2015/07/21 15:33:26 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.362 2015/07/22 12:21:07 monsieurp Exp $
+
+ 22 Jul 2015; Patrice Clement <monsieurp@gentoo.org> tomcat-6.0.44-r0.ebuild,
+ tomcat-7.0.59-r2.ebuild, tomcat-8.0.23-r2.ebuild:
+ Feed dodir and fperms functions with the ${dest} variable. This variable is
+ already formatted with the $CATALINA_BASE full path. Fix security bug 458890.
*tomcat-6.0.44-r0 (21 Jul 2015)
*tomcat-7.0.59-r2 (21 Jul 2015)
diff --git a/www-servers/tomcat/tomcat-6.0.44-r0.ebuild b/www-servers/tomcat/tomcat-6.0.44-r0.ebuild
index 590b4701edf7..e2a5316c5839 100644
--- a/www-servers/tomcat/tomcat-6.0.44-r0.ebuild
+++ b/www-servers/tomcat/tomcat-6.0.44-r0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.44-r0.ebuild,v 1.1 2015/07/21 15:33:26 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.44-r0.ebuild,v 1.2 2015/07/22 12:21:07 monsieurp Exp $
EAPI=5
@@ -106,8 +106,8 @@ src_install() {
# create "logs" directory in $CATALINA_BASE
# and set correct perms, see #458890
- dodir /usr/share/tomcat-${SLOT}/logs
- fperms 0750 /usr/share/tomcat-${SLOT}/logs
+ dodir "${dest}"/logs
+ fperms 0750 "${dest}"/logs
# replace the default pw with a random one, see #92281
local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
diff --git a/www-servers/tomcat/tomcat-7.0.59-r2.ebuild b/www-servers/tomcat/tomcat-7.0.59-r2.ebuild
index 0c083f945c73..ea658fdbfd6d 100644
--- a/www-servers/tomcat/tomcat-7.0.59-r2.ebuild
+++ b/www-servers/tomcat/tomcat-7.0.59-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.59-r2.ebuild,v 1.1 2015/07/21 15:33:26 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.59-r2.ebuild,v 1.2 2015/07/22 12:21:07 monsieurp Exp $
EAPI=5
@@ -109,8 +109,8 @@ src_install() {
# create "logs" directory in $CATALINA_BASE
# and set correct perms, see #458890
- dodir logs
- fperms 0750 logs
+ dodir "${dest}"/logs
+ fperms 0750 "${dest}"/logs
# replace the default pw with a random one, see #92281
local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
diff --git a/www-servers/tomcat/tomcat-8.0.23-r2.ebuild b/www-servers/tomcat/tomcat-8.0.23-r2.ebuild
index 52ecbf241a85..a6f703acb387 100644
--- a/www-servers/tomcat/tomcat-8.0.23-r2.ebuild
+++ b/www-servers/tomcat/tomcat-8.0.23-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-8.0.23-r2.ebuild,v 1.1 2015/07/21 15:33:26 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-8.0.23-r2.ebuild,v 1.2 2015/07/22 12:21:07 monsieurp Exp $
EAPI="5"
@@ -107,8 +107,8 @@ src_install() {
# create "logs" directory in $CATALINA_BASE
# and set correct perms, see #458890
- dodir /usr/share/tomcat-${SLOT}/logs
- fperms 0750 /usr/share/tomcat-${SLOT}/logs
+ dodir "${dest}"/logs
+ fperms 0750 "${dest}"/logs
# replace the default pw with a random one, see #92281
local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)