summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-16 19:10:37 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-16 19:10:37 +0000
commit8a6d74e18add620b0d4a54a0cc00e3ffbf52def6 (patch)
tree8620207f192f335c7e5d2e70426be1102796dbf4 /www-servers
parentAdds media-libs/libsdl2 as dependency, bug #535978 (diff)
downloadgentoo-2-8a6d74e18add620b0d4a54a0cc00e3ffbf52def6.tar.gz
gentoo-2-8a6d74e18add620b0d4a54a0cc00e3ffbf52def6.tar.bz2
gentoo-2-8a6d74e18add620b0d4a54a0cc00e3ffbf52def6.zip
Version bump. Adds path prefixing support to improve security a bit.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pshs/ChangeLog9
-rw-r--r--www-servers/pshs/pshs-0.2.6.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/www-servers/pshs/ChangeLog b/www-servers/pshs/ChangeLog
index 073381aafae3..09717fc93370 100644
--- a/www-servers/pshs/ChangeLog
+++ b/www-servers/pshs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pshs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.13 2014/12/25 19:03:24 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.14 2015/01/16 19:10:37 mgorny Exp $
+
+*pshs-0.2.6 (16 Jan 2015)
+
+ 16 Jan 2015; Michał Górny <mgorny@gentoo.org> +pshs-0.2.6.ebuild:
+ Version bump. Adds path prefixing support to improve security a bit.
*pshs-0.2.5 (25 Dec 2014)
diff --git a/www-servers/pshs/pshs-0.2.6.ebuild b/www-servers/pshs/pshs-0.2.6.ebuild
new file mode 100644
index 000000000000..8ea1b290c5ed
--- /dev/null
+++ b/www-servers/pshs/pshs-0.2.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-0.2.6.ebuild,v 1.1 2015/01/16 19:10:37 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
+HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic +netlink qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ dev-libs/openssl:0= )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ autotools-utils_src_configure
+}