summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-11-27 16:50:10 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-11-27 16:50:10 +0000
commit920df0c00438dfb05c1fc89a0eae51cd5e02b0cb (patch)
tree1cc02acd6330af40e0663c62ad2bac65bdece68f /www-servers
parentvanilla-3.17.4 + genpatches-3.17-7 + grsecurity-3.0-3.17.4-201411260107 (diff)
downloadgentoo-2-920df0c00438dfb05c1fc89a0eae51cd5e02b0cb.tar.gz
gentoo-2-920df0c00438dfb05c1fc89a0eae51cd5e02b0cb.tar.bz2
gentoo-2-920df0c00438dfb05c1fc89a0eae51cd5e02b0cb.zip
Version bump wrt bug #518078, solving CVE-2014-5015.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/bozohttpd/ChangeLog10
-rw-r--r--www-servers/bozohttpd/bozohttpd-20140708.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/www-servers/bozohttpd/ChangeLog b/www-servers/bozohttpd/ChangeLog
index 56a27e2f93f3..e354f63e59a4 100644
--- a/www-servers/bozohttpd/ChangeLog
+++ b/www-servers/bozohttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/bozohttpd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/ChangeLog,v 1.17 2013/03/26 19:54:50 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/ChangeLog,v 1.18 2014/11/27 16:50:10 kensington Exp $
+
+*bozohttpd-20140708 (27 Nov 2014)
+
+ 27 Nov 2014; Michael Palimaka <kensington@gentoo.org>
+ +bozohttpd-20140708.ebuild:
+ Version bump wrt bug #518078, solving CVE-2014-5015.
*bozohttpd-20111118 (26 Mar 2013)
diff --git a/www-servers/bozohttpd/bozohttpd-20140708.ebuild b/www-servers/bozohttpd/bozohttpd-20140708.ebuild
new file mode 100644
index 000000000000..af7fcede6cba
--- /dev/null
+++ b/www-servers/bozohttpd/bozohttpd-20140708.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/bozohttpd-20140708.ebuild,v 1.1 2014/11/27 16:50:10 kensington Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_prepare() {
+ mv Makefile{.boot,}
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin bozohttpd
+ doman bozohttpd.8
+
+ newconfd "${FILESDIR}"/${PN}.conffile bozohttpd
+ newinitd "${FILESDIR}"/${PN}.initscript bozohttpd
+}