summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-12-19 21:40:21 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-12-19 21:40:21 +0000
commitc30052510d10823b47f46d469f51fae67904184f (patch)
tree4ce98e35e969f7b6a836a458ab0fc06cfb93e24d /x11-apps/radeontop/radeontop-9999.ebuild
parentupdate of facter to 1.7.4 (diff)
downloadgentoo-2-c30052510d10823b47f46d469f51fae67904184f.tar.gz
gentoo-2-c30052510d10823b47f46d469f51fae67904184f.tar.bz2
gentoo-2-c30052510d10823b47f46d469f51fae67904184f.zip
New ebuild for x11-apps/radeontop, utility to view Radeon GPU utilization; fixes bug #493552, proxied commit for Nikoli whom will maintain this package.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'x11-apps/radeontop/radeontop-9999.ebuild')
-rw-r--r--x11-apps/radeontop/radeontop-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-apps/radeontop/radeontop-9999.ebuild b/x11-apps/radeontop/radeontop-9999.ebuild
new file mode 100644
index 000000000000..b4f70201f70d
--- /dev/null
+++ b/x11-apps/radeontop/radeontop-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/radeontop/radeontop-9999.ebuild,v 1.1 2013/12/19 21:40:21 tomwij Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs git-r3
+
+DESCRIPTION="Utility to view Radeon GPU utilization"
+HOMEPAGE="https://github.com/clbr/radeontop"
+LICENSE="GPL-3"
+EGIT_REPO_URI="https://github.com/clbr/radeontop.git"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses
+ x11-libs/libpciaccess
+ nls? ( sys-libs/ncurses[unicode] virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ tc-export CC
+ export nls=$(usex nls 1 0)
+ # Do not add -g or -s to CFLAGS
+ export plain=1
+}