summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2005-11-11 19:20:47 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2005-11-11 19:20:47 +0000
commit40c18c11266283a6a95cf48858f19e12fa9b9d4a (patch)
treebb41fa4ec33d79da1a93beb3586a0a043e48ce1a /x11-apps/xdm/xdm-0.99.3.ebuild
parentVersion bump. In this release the cairo use flag was added back. The new alsa... (diff)
downloadgentoo-2-40c18c11266283a6a95cf48858f19e12fa9b9d4a.tar.gz
gentoo-2-40c18c11266283a6a95cf48858f19e12fa9b9d4a.tar.bz2
gentoo-2-40c18c11266283a6a95cf48858f19e12fa9b9d4a.zip
Bump for 7.0RC2.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'x11-apps/xdm/xdm-0.99.3.ebuild')
-rw-r--r--x11-apps/xdm/xdm-0.99.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-apps/xdm/xdm-0.99.3.ebuild b/x11-apps/xdm/xdm-0.99.3.ebuild
new file mode 100644
index 000000000000..24004c5914f6
--- /dev/null
+++ b/x11-apps/xdm/xdm-0.99.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-0.99.3.ebuild,v 1.1 2005/11/11 19:20:47 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DESCRIPTION="X.Org xdm application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="xprint ipv6 pam"
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-0.99.1_pre20050905-r1
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-xdmconfigdir=/etc/X11/xdm"
+
+PATCHES="${FILESDIR}/gentoo_locations-0.99.3.patch"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ newpamd ${FILESDIR}/xdm.pamd xdm
+}