summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-10-20 00:45:25 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-10-20 00:45:25 +0000
commitcb65bb7016c0361820004c26bd52575a6cf5c0a7 (patch)
tree76d4bacb7f60f793b28ddb765173cf0287a6868b /x11-apps/xdm
parentUpdate SRC_URI to look in 7.0 RC1 location first, then RC0. Also only active ... (diff)
downloadgentoo-2-cb65bb7016c0361820004c26bd52575a6cf5c0a7.tar.gz
gentoo-2-cb65bb7016c0361820004c26bd52575a6cf5c0a7.tar.bz2
gentoo-2-cb65bb7016c0361820004c26bd52575a6cf5c0a7.zip
Bump for 7.0 RC1.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/ChangeLog7
-rw-r--r--x11-apps/xdm/files/digest-xdm-0.99.21
-rw-r--r--x11-apps/xdm/xdm-0.99.2.ebuild35
3 files changed, 42 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index d17d8877d9d7..34ad37a5652e 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.17 2005/10/19 02:31:26 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.18 2005/10/20 00:45:22 spyderous Exp $
+
+*xdm-0.99.2 (20 Oct 2005)
+
+ 20 Oct 2005; Donnie Berkholz <spyderous@gentoo.org>; +xdm-0.99.2.ebuild:
+ Bump for 7.0 RC1.
19 Oct 2005; Stephen P. Becker <geoman@gentoo.org>
xdm-0.99.1_pre20051014.ebuild:
diff --git a/x11-apps/xdm/files/digest-xdm-0.99.2 b/x11-apps/xdm/files/digest-xdm-0.99.2
new file mode 100644
index 000000000000..7f5dfe39dbe0
--- /dev/null
+++ b/x11-apps/xdm/files/digest-xdm-0.99.2
@@ -0,0 +1 @@
+MD5 0e6403a60f50662b30f77322c0f54068 xdm-0.99.2.tar.bz2 210823
diff --git a/x11-apps/xdm/xdm-0.99.2.ebuild b/x11-apps/xdm/xdm-0.99.2.ebuild
new file mode 100644
index 000000000000..4abbea231fed
--- /dev/null
+++ b/x11-apps/xdm/xdm-0.99.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-0.99.2.ebuild,v 1.1 2005/10/20 00:45:22 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X.Org xdm application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="xprint ipv6 pam"
+RDEPEND="x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-0.99.1_pre20050905-r1"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --libdir=/etc"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ newpamd ${FILESDIR}/xdm.pamd xdm
+}