summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-07-14 05:02:48 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-07-14 05:02:48 +0000
commit8c8757338c2284d88ff8e89cbf8c4d669de3cb89 (patch)
treeeb9b0f47dc9840a935f41342ac4fec1a036e831a /x11-apps/xinit/xinit-1.0.4.ebuild
parentBump. Lots of changes for G80 series, including addition of RandR 1.2 support... (diff)
downloadgentoo-2-8c8757338c2284d88ff8e89cbf8c4d669de3cb89.tar.gz
gentoo-2-8c8757338c2284d88ff8e89cbf8c4d669de3cb89.tar.bz2
gentoo-2-8c8757338c2284d88ff8e89cbf8c4d669de3cb89.zip
Bump. Mostly removes cruft. Also sets the WINDOWPATH variable for anyone needing that.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'x11-apps/xinit/xinit-1.0.4.ebuild')
-rw-r--r--x11-apps/xinit/xinit-1.0.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-apps/xinit/xinit-1.0.4.ebuild b/x11-apps/xinit/xinit-1.0.4.ebuild
new file mode 100644
index 000000000000..c6cd52731cb2
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.4.ebuild,v 1.1 2007/07/14 05:02:48 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+# This is enabled due to modified Makefile.am from the patches
+SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="minimal"
+
+RDEPEND="x11-apps/xauth
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+PDEPEND="!minimal? ( x11-wm/twm
+ x11-apps/xclock
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-terms/xterm )"
+
+PATCHES="${FILESDIR}/nolisten-tcp-and-black-background.patch
+ ${FILESDIR}/gentoo-startx-customization-${PV}.patch"
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" ${S}/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe ${FILESDIR}/chooser.sh ${FILESDIR}/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/Xsession
+ exeinto /etc/X11/xinit
+ doexe ${FILESDIR}/xinitrc
+ newinitd ${FILESDIR}/xdm.initd-1 xdm
+ newconfd ${FILESDIR}/xdm.confd-1 xdm
+ newpamd ${FILESDIR}/xserver.pamd xserver
+}