summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2009-02-10 02:49:00 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2009-02-10 02:49:00 +0000
commitad3d5de2706e5e110a45592d2376ed42a89974e5 (patch)
tree5ac8c8447a8547016c276eacab432fd94b1b1762 /x11-apps
parent Get rid of invalid aRts dependency. Fix bug #255862. (diff)
downloadgentoo-2-ad3d5de2706e5e110a45592d2376ed42a89974e5.tar.gz
gentoo-2-ad3d5de2706e5e110a45592d2376ed42a89974e5.tar.bz2
gentoo-2-ad3d5de2706e5e110a45592d2376ed42a89974e5.zip
(#220797) Instead of letting settings in /etc/env.d/90xsession get overwritten on every update, don't install anything there and just tell people what to do.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog12
-rw-r--r--x11-apps/xinit/xinit-1.0.8-r4.ebuild74
2 files changed, 84 insertions, 2 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 73982e909310..a30d2dd49001 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-apps/xinit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.117 2008/05/12 08:34:27 dberkholz Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.118 2009/02/10 02:49:00 dberkholz Exp $
+
+*xinit-1.0.8-r4 (10 Feb 2009)
+
+ 10 Feb 2009; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xinit-1.0.8-r4.ebuild:
+ (#220797) Instead of letting settings in /etc/env.d/90xsession get
+ overwritten on every update, don't install anything there and just tell
+ people what to do.
12 May 2008; Donnie Berkholz <dberkholz@gentoo.org>;
xinit-1.0.8-r3.ebuild:
diff --git a/x11-apps/xinit/xinit-1.0.8-r4.ebuild b/x11-apps/xinit/xinit-1.0.8-r4.ebuild
new file mode 100644
index 000000000000..fe4c525bdf08
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.0.8-r4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.8-r4.ebuild,v 1.1 2009/02/10 02:49:00 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+# This is enabled due to modified Makefile.am from the patches
+SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="hal minimal pam"
+
+RDEPEND="x11-apps/xauth
+ x11-libs/libX11
+ hal? ( sys-auth/consolekit )"
+DEPEND="${RDEPEND}"
+PDEPEND="!minimal? ( x11-wm/twm
+ x11-apps/xclock
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-terms/xterm )"
+
+PATCHES="${FILESDIR}/nolisten-tcp-and-black-background.patch
+ ${FILESDIR}/gentoo-startx-customization-1.0.8.patch
+ ${FILESDIR}/xinit-1.0.4-console-kit.patch"
+
+CONFIGURE_OPTIONS="$(use_with hal consolekit)"
+
+pkg_setup() {
+ if use hal; then
+ if ! built_with_use sys-apps/dbus X ; then
+ eerror "You MUST build sys-apps/dbus with the X USE flag enabled."
+ die "You MUST build sys-apps/dbus with the X USE flag enabled."
+ fi
+ fi
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" "${S}/Makefile.am"
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession || die
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xinitrc || die
+ newinitd "${FILESDIR}"/xdm.initd-2 xdm
+ newconfd "${FILESDIR}"/xdm.confd-1 xdm
+ newpamd "${FILESDIR}"/xserver.pamd xserver
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}