summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-04-08 20:45:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-04-08 20:45:38 +0000
commitd3a36a6fffe0b6f18f05d8d072bf5a68cd2ce7c8 (patch)
treec532dd6c809c1e364459eff02831357f21d2c745 /x11-apps
parentreadd ~x86-fbsd (diff)
downloadgentoo-2-d3a36a6fffe0b6f18f05d8d072bf5a68cd2ce7c8.tar.gz
gentoo-2-d3a36a6fffe0b6f18f05d8d072bf5a68cd2ce7c8.tar.bz2
gentoo-2-d3a36a6fffe0b6f18f05d8d072bf5a68cd2ce7c8.zip
add /etc/env.d/90xsession file
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog8
-rw-r--r--x11-apps/xinit/files/xsession.env.d25
-rw-r--r--x11-apps/xinit/xinit-1.0.8-r1.ebuild63
3 files changed, 95 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 2511fa6b88d2..28ee6aa489c0 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.113 2008/03/10 01:58:15 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.114 2008/04/08 20:45:37 cardoe Exp $
+
+*xinit-1.0.8-r1 (08 Apr 2008)
+
+ 08 Apr 2008; Doug Goldstein <cardoe@gentoo.org> +files/xsession.env.d,
+ +xinit-1.0.8-r1.ebuild:
+ add /etc/env.d/90xsession file
*xinit-1.0.8 (10 Mar 2008)
diff --git a/x11-apps/xinit/files/xsession.env.d b/x11-apps/xinit/files/xsession.env.d
new file mode 100644
index 000000000000..c108d3d44e48
--- /dev/null
+++ b/x11-apps/xinit/files/xsession.env.d
@@ -0,0 +1,25 @@
+# /etc/env.d/90xsession
+
+# XSESSION is a new variable to control what window manager to start
+# default with X if run with xdm, startx or xinit. The default behavior
+# is to look in /etc/X11/Sessions/ and run the script in matching the
+# value that XSESSION is set to. The support scripts are smart enough to
+# look in all bin directories if it cant find a match in /etc/X11/Sessions/,
+# so setting it to "enlightenment" can also work. This is basically used
+# as a way for the system admin to configure a default system wide WM,
+# allthough it will work if the user export XSESSION in his .bash_profile, etc.
+#
+# NOTE: 1) this behaviour is overridden when a ~/.xinitrc exists, and startx
+# is called.
+# 2) even if ~/.xsession exists, if XSESSION can be resolved, it will
+# be executed rather than ~/.xsession, else KDM breaks ...
+#
+# Defaults depending on what you install currently include:
+#
+# Gnome - will start gnome-session
+# kde-<version> - will start startkde (look in /etc/X11/Sessions/)
+# Xfce4 - will start a XFCE4 session
+# Xsession - will start a terminal and a few other nice apps
+
+#XSESSION="Gnome"
+
diff --git a/x11-apps/xinit/xinit-1.0.8-r1.ebuild b/x11-apps/xinit/xinit-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..67dfff374a83
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.0.8-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.8-r1.ebuild,v 1.1 2008/04/08 20:45:37 cardoe Exp $
+
+# Must be before x-modular eclass is inherited
+# This is enabled due to modified Makefile.am from the patches
+SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="hal minimal pam"
+
+RDEPEND="x11-apps/xauth
+ x11-libs/libX11
+ hal? ( sys-auth/consolekit )"
+DEPEND="${RDEPEND}"
+PDEPEND="!minimal? ( x11-wm/twm
+ x11-apps/xclock
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-terms/xterm )"
+
+PATCHES="${FILESDIR}/nolisten-tcp-and-black-background.patch
+ ${FILESDIR}/gentoo-startx-customization-1.0.8.patch
+ ${FILESDIR}/xinit-1.0.4-console-kit.patch"
+
+CONFIGURE_OPTIONS="$(use_with hal consolekit)"
+
+pkg_setup() {
+ if use hal; then
+ if ! built_with_use sys-apps/dbus X ; then
+ eerror "You MUST build sys-apps/dbus with the X USE flag enabled."
+ die "You MUST build sys-apps/dbus with the X USE flag enabled."
+ fi
+ fi
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" "${S}/Makefile.am"
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession || die
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xinitrc || die
+ newinitd "${FILESDIR}"/xdm.initd-1 xdm
+ newconfd "${FILESDIR}"/xdm.confd-1 xdm
+ newpamd "${FILESDIR}"/xserver.pamd xserver
+ newenvd "${FILESIDR}"/xsession.env.d 90xsession
+}