summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-10-03 16:05:24 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-10-03 16:05:24 +0000
commit0e9e53438378911cf878da29315953b03398bcf3 (patch)
tree16d27328b04e2d7466aa5aada9dd0c631821e3ab /x11-base/xorg-server
parentDep cleanup. (diff)
downloadgentoo-2-0e9e53438378911cf878da29315953b03398bcf3.tar.gz
gentoo-2-0e9e53438378911cf878da29315953b03398bcf3.tar.bz2
gentoo-2-0e9e53438378911cf878da29315953b03398bcf3.zip
Version bump for xorg-server 1.7.
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'x11-base/xorg-server')
-rw-r--r--x11-base/xorg-server/ChangeLog9
-rw-r--r--x11-base/xorg-server/files/1.7.0-xkb-check-permissions-on-XKM_OUTPUT_DIR.patch41
-rw-r--r--x11-base/xorg-server/xorg-server-1.7.0.ebuild263
3 files changed, 312 insertions, 1 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
index f300e8934d20..2b6d6cc4c167 100644
--- a/x11-base/xorg-server/ChangeLog
+++ b/x11-base/xorg-server/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-base/xorg-server
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.449 2009/10/02 14:10:00 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.450 2009/10/03 16:05:24 scarabeus Exp $
+
+*xorg-server-1.7.0 (03 Oct 2009)
+
+ 03 Oct 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/1.7.0-xkb-check-permissions-on-XKM_OUTPUT_DIR.patch,
+ +xorg-server-1.7.0.ebuild:
+ Version bump for xorg-server 1.7.
02 Oct 2009; Rémi Cardona <remi@gentoo.org>
+files/1.6.4-re-fix-DGA-removal.patch, xorg-server-1.6.4.ebuild:
diff --git a/x11-base/xorg-server/files/1.7.0-xkb-check-permissions-on-XKM_OUTPUT_DIR.patch b/x11-base/xorg-server/files/1.7.0-xkb-check-permissions-on-XKM_OUTPUT_DIR.patch
new file mode 100644
index 000000000000..deff5e6fe950
--- /dev/null
+++ b/x11-base/xorg-server/files/1.7.0-xkb-check-permissions-on-XKM_OUTPUT_DIR.patch
@@ -0,0 +1,41 @@
+From 9bc7cbf9c02656982c2525836b5498993f708e02 Mon Sep 17 00:00:00 2001
+From: Nirbheek Chauhan <nirbheek@gentoo.org>
+Date: Tue, 29 Sep 2009 22:35:06 +0530
+Subject: [PATCH 01/10] xkb: check permissions on XKM_OUTPUT_DIR
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Checking just for root is insufficient since that does not guarantee write/read
+permissions in XKM_OUTPUT_DIR (for example with sandbox).
+
+Check if we can write a file, as well as read it later. Otherwise, invoke the
+fallback to /tmp
+
+Signed-off-by: Nirbheek Chauhan <nirbheek@gentoo.org>
+Signed-off-by: Rémi Cardona <remi@gentoo.org>
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+ xkb/ddxLoad.c | 5 ++---
+ 1 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/xkb/ddxLoad.c b/xkb/ddxLoad.c
+index 6954dd1..ba8d50b 100644
+--- a/xkb/ddxLoad.c
++++ b/xkb/ddxLoad.c
+@@ -158,10 +158,9 @@ OutputDirectory(
+ size_t size)
+ {
+ #ifndef WIN32
+- if (getuid() == 0 && (strlen(XKM_OUTPUT_DIR) < size))
++ /* Can we write an xkm and then open it too? */
++ if (access(XKM_OUTPUT_DIR, W_OK | X_OK) == 0 && (strlen(XKM_OUTPUT_DIR) < size))
+ {
+- /* if server running as root it *may* be able to write */
+- /* FIXME: check whether directory is writable at all */
+ (void) strcpy (outdir, XKM_OUTPUT_DIR);
+ } else
+ #else
+--
+1.6.5.rc1
+
diff --git a/x11-base/xorg-server/xorg-server-1.7.0.ebuild b/x11-base/xorg-server/xorg-server-1.7.0.ebuild
new file mode 100644
index 000000000000..8a6ca8eec69c
--- /dev/null
+++ b/x11-base/xorg-server/xorg-server-1.7.0.ebuild
@@ -0,0 +1,263 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.7.0.ebuild,v 1.1 2009/10/03 16:05:24 scarabeus Exp $
+
+EAPI="2"
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib versionator
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org X servers"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE_SERVERS="dmx kdrive xorg"
+IUSE="${IUSE_SERVERS} tslib hal ipv6 minimal nptl sdl"
+RDEPEND="hal? ( sys-apps/hal )
+ tslib? ( >=x11-libs/tslib-1.0 x11-proto/xcalibrateproto )
+ dev-libs/openssl
+ >=x11-libs/libXfont-1.3.3
+ >=x11-libs/xtrans-1.2.2
+ >=x11-libs/libXau-1.0.4
+ >=x11-libs/libxkbfile-1.0.4
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libpciaccess-0.10.3
+ >=x11-libs/pixman-0.15.20
+ media-libs/freetype
+ >=x11-misc/xbitmaps-1.0.1
+ >=x11-misc/xkeyboard-config-1.4
+ x11-apps/xkbcomp
+ >=x11-apps/iceauth-1.0.2
+ >=x11-apps/rgb-1.0.3
+ >=x11-apps/xauth-1.0.3
+ >=x11-apps/xinit-1.0.8-r3
+ >=app-admin/eselect-opengl-1.0.8
+ dmx? (
+ x11-libs/libXt
+ >=x11-libs/libdmx-1.0.2
+ >=x11-libs/libX11-1.1.5
+ >=x11-libs/libXaw-1.0.4
+ >=x11-libs/libXext-1.0.5
+ >=x11-libs/libXfixes-4.0.3
+ >=x11-libs/libXi-1.2.99.1
+ >=x11-libs/libXmu-1.0.3
+ >=x11-libs/libXtst-1.0.3
+ )
+ !minimal? (
+ >=x11-libs/libX11-1.1.5
+ >=x11-libs/libXext-1.0.5
+ >=x11-libs/libXres-1.0.3
+ >=media-libs/mesa-7.4[nptl=]
+ )
+ >=x11-libs/libxkbui-1.0.2
+ kdrive? (
+ >=x11-libs/libXext-1.0.5
+ sdl? ( media-libs/libsdl ) )"
+ # Xres is dmx-dependent
+ # Xaw is dmx-dependent
+ # Xpm is dmx-dependent, pulls in Xt
+ # xkbcomp is launched at startup but not checked by ./configure
+
+## Deps that don't have a version in configure.ac but do here:
+# x11-proto/resourceproto
+# x11-proto/fontsproto
+# x11-libs/libXau
+# x11-libs/libXfont
+# x11-libs/libXdmcp
+# x11-libs/libXext
+# x11-libs/libX11
+# x11-libs/libXrender
+# x11-libs/libXmu
+# x11-libs/libXfixes
+# x11-libs/libXtst
+# x11-proto/xineramaproto
+# x11-proto/dmxproto
+## Deps that are larger here than in configure.ac
+# x11-libs/libpciaccess-0.8.0
+#
+
+DEPEND="${RDEPEND}
+ !!net-dialup/dtrace
+ sys-devel/flex
+ >=x11-proto/randrproto-1.2.99.3
+ >=x11-proto/renderproto-0.11
+ >=x11-proto/fixesproto-4.1
+ >=x11-proto/damageproto-1.1
+ >=x11-proto/xextproto-7.0.99.3
+ >=x11-proto/xproto-7.0.13
+ >=x11-proto/xf86dgaproto-2.0.99.1
+ >=x11-proto/xf86rushproto-1.1.2
+ >=x11-proto/xf86vidmodeproto-2.2.99.1
+ >=x11-proto/compositeproto-0.4
+ >=x11-proto/recordproto-1.13.99.1
+ >=x11-proto/resourceproto-1.0.2
+ >=x11-proto/videoproto-2.2.2
+ >=x11-proto/scrnsaverproto-1.1
+ >=x11-proto/trapproto-3.4.3
+ >=x11-proto/xineramaproto-1.1.3
+ >=x11-proto/fontsproto-2.0.2
+ >=x11-proto/kbproto-1.0.3
+ >=x11-proto/inputproto-1.9.99.902
+ >=x11-proto/bigreqsproto-1.1.0
+ >=x11-proto/xcmiscproto-1.2.0
+ >=x11-proto/glproto-1.4.9
+ dmx? ( >=x11-proto/dmxproto-2.2.2 )
+ !minimal? (
+ >=x11-proto/xf86driproto-2.1.0
+ >=x11-proto/dri2proto-2.1
+ >=x11-libs/libdrm-2.3.0
+ )"
+
+PDEPEND="xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
+
+EPATCH_FORCE="yes"
+EPATCH_SUFFIX="patch"
+
+# These have been sent upstream
+UPSTREAMED_PATCHES=(
+ #"${WORKDIR}/patches/"
+ # Merged for 1.7.1
+ "${FILESDIR}/${PV}-xkb-check-permissions-on-XKM_OUTPUT_DIR.patch"
+ )
+
+PATCHES=(
+ "${UPSTREAMED_PATCHES[@]}"
+ )
+
+pkg_setup() {
+ use minimal || ensure_a_server_is_building
+
+ # SDL only available in kdrive build
+ if use kdrive && use sdl; then
+ conf_opts="${conf_opts} --enable-xsdl"
+ else
+ conf_opts="${conf_opts} --disable-xsdl"
+ fi
+
+ # localstatedir is used for the log location; we need to override the default
+ # from ebuild.sh
+ # sysconfdir is used for the xorg.conf location; same applies
+ # --enable-install-setuid needed because sparcs default off
+ CONFIGURE_OPTIONS="
+ $(use_enable ipv6)
+ $(use_enable dmx)
+ $(use_enable kdrive)
+ $(use_enable tslib)
+ $(use_enable tslib xcalibrate)
+ $(use_enable !minimal xvfb)
+ $(use_enable !minimal xnest)
+ $(use_enable !minimal record)
+ $(use_enable !minimal xfree86-utils)
+ $(use_enable !minimal install-libxf86config)
+ $(use_enable !minimal dri)
+ $(use_enable !minimal dri2)
+ $(use_enable !minimal glx)
+ $(use_enable xorg)
+ $(use_enable nptl glx-tls)
+ $(use_enable hal config-hal)
+ --sysconfdir=/etc/X11
+ --localstatedir=/var
+ --enable-install-setuid
+ --with-fontdir=/usr/share/fonts
+ --with-xkb-output=/var/lib/xkb
+ --without-dtrace
+ ${conf_opts}"
+
+ # (#121394) Causes window corruption
+ filter-flags -fweb
+
+ # Incompatible with GCC 3.x SSP on x86, bug #244352
+ if use x86 ; then
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ filter-flags -fstack-protector
+ fi
+ fi
+
+ OLD_IMPLEM="$(eselect opengl show)"
+ eselect opengl set --impl-headers ${OPENGL_DIR}
+}
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+
+ server_based_install
+
+ if ! use minimal && use xorg; then
+ # Install xorg.conf.example (see bugs #151421 and #151670)
+ insinto /etc/X11
+ doins hw/xfree86/xorg.conf.example \
+ || die "couldn't install xorg.conf.example"
+ fi
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+
+ echo
+ ewarn "You must rebuild all drivers if upgrading from xorg-server 1.6"
+ ewarn "or earlier, because the ABI changed. If you cannot start X because"
+ ewarn "of module version mismatch errors, this is your problem."
+
+ echo
+ ewarn "You can generate a list of all installed packages in the x11-drivers"
+ ewarn "category using this command:"
+ ewarn "emerge portage-utils; qlist -I -C x11-drivers/"
+
+ ebeep 5
+ epause 10
+}
+
+pkg_postrm() {
+ # Get rid of module dir to ensure opengl-update works properly
+ if ! has_version x11-base/xorg-server; then
+ if [[ -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
+ rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
+ fi
+ fi
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
+ local x=""
+ for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
+ fi
+ done
+ eend 0
+}
+
+server_based_install() {
+ if ! use xorg; then
+ rm "${D}"/usr/share/man/man1/Xserver.1x \
+ "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
+ "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
+ "${D}"/usr/share/man/man1/Xserver.1x
+ fi
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set ${OLD_IMPLEM}
+}
+
+ensure_a_server_is_building() {
+ for server in ${IUSE_SERVERS}; do
+ use ${server} && return;
+ done
+ eerror "You need to specify at least one server to build."
+ eerror "Valid servers are: ${IUSE_SERVERS}."
+ die "No servers were specified to build."
+}