summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-09-04 23:22:46 +0000
committerRémi Cardona <remi@gentoo.org>2009-09-04 23:22:46 +0000
commit3ff2e455b02298ac6254e43fc8b2962ac971908d (patch)
treedab699c4c1ccfa7839c59b1b18beca26ed59b9a2 /x11-base/xorg-server
parentCleaning out unused patches (diff)
downloadgentoo-2-3ff2e455b02298ac6254e43fc8b2962ac971908d.tar.gz
gentoo-2-3ff2e455b02298ac6254e43fc8b2962ac971908d.tar.bz2
gentoo-2-3ff2e455b02298ac6254e43fc8b2962ac971908d.zip
x11-base/xorg-server: add a patch to fix bug #278487, split drivers into x11-base/xorg-drivers
(Portage version: 2.2_rc40/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'x11-base/xorg-server')
-rw-r--r--x11-base/xorg-server/ChangeLog10
-rw-r--r--x11-base/xorg-server/files/1.6.3.901-0001-dix-append-built-ins-to-the-font-path-in-SetDefaultF.patch102
-rw-r--r--x11-base/xorg-server/xorg-server-1.6.3.901-r1.ebuild264
3 files changed, 375 insertions, 1 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
index f4a066cd691c..056d0fc5e738 100644
--- a/x11-base/xorg-server/ChangeLog
+++ b/x11-base/xorg-server/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-base/xorg-server
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.440 2009/08/26 13:55:25 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.441 2009/09/04 23:22:45 remi Exp $
+
+*xorg-server-1.6.3.901-r1 (04 Sep 2009)
+
+ 04 Sep 2009; Rémi Cardona <remi@gentoo.org>
+ +xorg-server-1.6.3.901-r1.ebuild,
+ +files/1.6.3.901-0001-dix-append-built-ins-to-the-font-path-in-SetDefaultF
+ .patch:
+ add a patch to fix bug #278487, split drivers into x11-base/xorg-drivers
26 Aug 2009; Rémi Cardona <remi@gentoo.org>
-xorg-server-1.6.2.901.ebuild:
diff --git a/x11-base/xorg-server/files/1.6.3.901-0001-dix-append-built-ins-to-the-font-path-in-SetDefaultF.patch b/x11-base/xorg-server/files/1.6.3.901-0001-dix-append-built-ins-to-the-font-path-in-SetDefaultF.patch
new file mode 100644
index 000000000000..eb3ec7d6b181
--- /dev/null
+++ b/x11-base/xorg-server/files/1.6.3.901-0001-dix-append-built-ins-to-the-font-path-in-SetDefaultF.patch
@@ -0,0 +1,102 @@
+From c6753b750d76564bee02b317d10a496d0ced4274 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Fri, 4 Sep 2009 23:05:29 +0200
+Subject: [PATCH] dix: append "built-ins" to the font path in SetDefaultFontPath
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+49b93df8a3002db7196aa3fc1fd8dca1c12a55d6 made the hard dependency on
+a "fixed" font go away but only Xorg could use the built-ins fonts by
+default.
+
+With this commit, all DDXs get "built-ins" appended to their FontPath, not
+just Xorg.
+
+Tested with Xorg, Xvfb and Xnest.
+
+Signed-off-by: Rémi Cardona <remi@gentoo.org>
+---
+ dix/dixfonts.c | 20 ++++++++++++++++++--
+ hw/xfree86/common/xf86Config.c | 16 ----------------
+ 2 files changed, 18 insertions(+), 18 deletions(-)
+
+diff --git a/dix/dixfonts.c b/dix/dixfonts.c
+index 719bca4..4d69025 100644
+--- a/dix/dixfonts.c
++++ b/dix/dixfonts.c
+@@ -1818,6 +1818,9 @@ SetDefaultFontPath(char *path)
+ unsigned char *cp,
+ *pp,
+ *nump,
++ *temp_path,
++ *start,
++ *end,
+ *newpath;
+ int num = 1,
+ len,
+@@ -1825,12 +1828,24 @@ SetDefaultFontPath(char *path)
+ size = 0,
+ bad;
+
++ /* ensure temp_path contains "built-ins" */
++ start = strstr(path, "built-ins");
++ end = start + strlen("built-ins");
++ if (start == NULL ||
++ !((start == path || start[-1] == ',') && (!*end || *end == ','))) {
++ temp_path = Xprintf("%s%sbuilt-ins", path, *path ? "," : "");
++ } else {
++ temp_path = Xstrdup(path);
++ }
++ if (!temp_path)
++ return BadAlloc;
++
+ /* get enough for string, plus values -- use up commas */
+- len = strlen(path) + 1;
++ len = strlen(temp_path) + 1;
+ nump = cp = newpath = (unsigned char *) xalloc(len);
+ if (!newpath)
+ return BadAlloc;
+- pp = (unsigned char *) path;
++ pp = (unsigned char *) temp_path;
+ cp++;
+ while (*pp) {
+ if (*pp == ',') {
+@@ -1849,6 +1864,7 @@ SetDefaultFontPath(char *path)
+ err = SetFontPathElements(num, newpath, &bad, TRUE);
+
+ xfree(newpath);
++ xfree(temp_path);
+
+ return err;
+ }
+diff --git a/hw/xfree86/common/xf86Config.c b/hw/xfree86/common/xf86Config.c
+index 9376119..ddf4745 100644
+--- a/hw/xfree86/common/xf86Config.c
++++ b/hw/xfree86/common/xf86Config.c
+@@ -612,22 +612,6 @@ configFiles(XF86ConfFilesPtr fileconf)
+ pathFrom = X_DEFAULT;
+ temp_path = defaultFontPath ? defaultFontPath : "";
+
+- /* ensure defaultFontPath contains "built-ins" */
+- start = strstr(temp_path, "built-ins");
+- end = start + strlen("built-ins");
+- if (start == NULL ||
+- !((start == temp_path || start[-1] == ',') && (!*end || *end == ','))) {
+- defaultFontPath = Xprintf("%s%sbuilt-ins",
+- temp_path, *temp_path ? "," : "");
+- if (must_copy == TRUE) {
+- if (defaultFontPath != NULL) {
+- must_copy = FALSE;
+- }
+- } else {
+- /* already made a copy of the font path */
+- xfree(temp_path);
+- }
+- }
+ /* xf86ValidateFontPath modifies its argument, but returns a copy of it. */
+ temp_path = must_copy ? XNFstrdup(defaultFontPath) : defaultFontPath;
+ defaultFontPath = xf86ValidateFontPath(temp_path);
+--
+1.6.4.2
+
diff --git a/x11-base/xorg-server/xorg-server-1.6.3.901-r1.ebuild b/x11-base/xorg-server/xorg-server-1.6.3.901-r1.ebuild
new file mode 100644
index 000000000000..e9f16be0211f
--- /dev/null
+++ b/x11-base/xorg-server/xorg-server-1.6.3.901-r1.ebuild
@@ -0,0 +1,264 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.6.3.901-r1.ebuild,v 1.1 2009/09/04 23:22:45 remi Exp $
+
+EAPI="2"
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular multilib versionator
+
+# keithp put this one in archive/ instead of releases/ for unknown reasons
+BASE_INDIVIDUAL_URI="http://xorg.freedesktop.org/archive/individual"
+SRC_URI="${SRC_URI}
+ ${BASE_INDIVIDUAL_URI}/${MODULE}/${P}.tar.bz2"
+# mirror://gentoo/${P}-gentoo-patches-01.tar.bz2
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org X servers"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE_SERVERS="dmx kdrive xorg"
+IUSE="${IUSE_SERVERS}
+ tslib hal ipv6 minimal nptl sdl"
+RDEPEND="hal? ( sys-apps/hal )
+ tslib? ( >=x11-libs/tslib-1.0 x11-proto/xcalibrateproto )
+ dev-libs/openssl
+ >=x11-libs/libXfont-1.4.0
+ >=x11-libs/xtrans-1.2.3
+ >=x11-libs/libXau-1.0.4
+ >=x11-libs/libXext-1.0.4
+ >=x11-libs/libX11-1.1.5
+ >=x11-libs/libxkbfile-1.0.4
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXmu-1.0.3
+ >=x11-libs/libXrender-0.9.4
+ >=x11-libs/libXi-1.2.1
+ >=x11-libs/pixman-0.14.0
+ media-libs/freetype
+ >=x11-misc/xbitmaps-1.0.1
+ >=x11-misc/xkeyboard-config-1.4
+ x11-apps/xkbcomp
+ >=x11-apps/iceauth-1.0.2
+ >=x11-apps/rgb-1.0.3
+ >=x11-apps/xauth-1.0.3
+ >=x11-apps/xinit-1.0.8-r3
+ >=app-admin/eselect-opengl-1.0.7
+ >=x11-libs/libXaw-1.0.5
+ >=x11-libs/libXpm-3.5.7
+ >=x11-libs/libpciaccess-0.10.3
+ dmx? (
+ >=x11-libs/libdmx-1.0.2
+ >=x11-libs/libXfixes-4.0.3
+ )
+ !minimal? (
+ >=x11-libs/libXtst-1.0.3
+ >=x11-libs/libXres-1.0.3
+ >=media-libs/mesa-7.3_rc1[nptl=]
+ )
+ >=x11-libs/libxkbui-1.0.2
+ kdrive? ( sdl? ( media-libs/libsdl ) )"
+ # Xres is dmx-dependent
+ # Xaw is dmx-dependent
+ # Xpm is dmx-dependent, pulls in Xt
+ # xkbcomp is launched at startup but not checked by ./configure
+DEPEND="${RDEPEND}
+ !net-dialup/dtrace
+ sys-devel/flex
+ >=x11-proto/randrproto-1.2.99.4
+ >=x11-proto/renderproto-0.9.3
+ >=x11-proto/fixesproto-4
+ >=x11-proto/damageproto-1.1
+ >=x11-proto/xextproto-7.0.4
+ >=x11-proto/xproto-7.0.14
+ >=x11-proto/xf86dgaproto-2.0.3
+ >=x11-proto/xf86rushproto-1.1.2
+ >=x11-proto/xf86vidmodeproto-2.2.2
+ >=x11-proto/compositeproto-0.4
+ >=x11-proto/recordproto-1.13.2
+ >=x11-proto/resourceproto-1.0.2
+ >=x11-proto/videoproto-2.2.2
+ >=x11-proto/scrnsaverproto-1.1.0
+ >=x11-proto/trapproto-3.4.3
+ >=x11-proto/xineramaproto-1.1.2
+ >=x11-proto/fontsproto-2.0.2
+ >=x11-proto/kbproto-1.0.3
+ >=x11-proto/inputproto-1.5.0
+ >=x11-proto/bigreqsproto-1.0.2
+ >=x11-proto/xcmiscproto-1.1.2
+ >=x11-proto/glproto-1.4.9
+ dmx? ( >=x11-proto/dmxproto-2.2.2 )
+ !minimal? (
+ >=x11-proto/xf86driproto-2.0.4
+ >=x11-proto/dri2proto-2.1
+ >=x11-libs/libdrm-2.3
+ )"
+
+PDEPEND="xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
+LICENSE="${LICENSE} MIT"
+
+EPATCH_FORCE="yes"
+EPATCH_SUFFIX="patch"
+
+# Local customizations, unsuitable for upstream
+GENTOO_PATCHES=(
+ "${FILESDIR}/1.4-fpic-libxf86config.patch"
+ "${FILESDIR}/${PV}-0001-dix-append-built-ins-to-the-font-path-in-SetDefaultF.patch"
+ )
+
+# These have been sent upstream
+#UPSTREAMED_PATCHES=(
+# "${WORKDIR}/patches/"
+# )
+
+PATCHES=(
+ "${GENTOO_PATCHES[@]}"
+ "${UPSTREAMED_PATCHES[@]}"
+ )
+
+pkg_setup() {
+ use minimal || ensure_a_server_is_building
+
+ # SDL only available in kdrive build
+ if use kdrive && use sdl; then
+ conf_opts="${conf_opts} --enable-xsdl"
+ else
+ conf_opts="${conf_opts} --disable-xsdl"
+ fi
+
+ # localstatedir is used for the log location; we need to override the default
+ # from ebuild.sh
+ # sysconfdir is used for the xorg.conf location; same applies
+ # --enable-install-setuid needed because sparcs default off
+ CONFIGURE_OPTIONS="
+ $(use_enable ipv6)
+ $(use_enable dmx)
+ $(use_enable kdrive)
+ $(use_enable tslib)
+ $(use_enable tslib xcalibrate)
+ $(use_enable !minimal xvfb)
+ $(use_enable !minimal xnest)
+ $(use_enable !minimal record)
+ $(use_enable !minimal xfree86-utils)
+ $(use_enable !minimal install-libxf86config)
+ $(use_enable !minimal dri)
+ $(use_enable !minimal dri2)
+ $(use_enable !minimal glx)
+ $(use_enable xorg)
+ $(use_enable nptl glx-tls)
+ $(use_enable hal config-hal)
+ --sysconfdir=/etc/X11
+ --localstatedir=/var
+ --enable-install-setuid
+ --with-fontdir=/usr/share/fonts
+ --with-xkb-output=/var/lib/xkb
+ --without-dtrace
+ ${conf_opts}"
+
+ # (#121394) Causes window corruption
+ filter-flags -fweb
+
+ # Incompatible with GCC 3.x SSP on x86, bug #244352
+ if use x86 ; then
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ filter-flags -fstack-protector
+ fi
+ fi
+
+ OLD_IMPLEM="$(eselect opengl show)"
+ eselect opengl set --impl-headers ${OPENGL_DIR}
+}
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+
+ server_based_install
+
+ # Install video mode files for system-config-display
+ insinto /usr/share/xorg
+ doins hw/xfree86/common/{extra,vesa}modes \
+ || die "couldn't install extra modes"
+
+ # Bug #151421 - this file is not built with USE="minimal"
+ # Bug #151670 - this file is also not build if USE="-xorg"
+ if ! use minimal && use xorg; then
+ # Install xorg.conf.example
+ insinto /etc/X11
+ doins hw/xfree86/xorg.conf.example \
+ || die "couldn't install xorg.conf.example"
+ fi
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+
+ # Bug #135544
+ ewarn "Users of reduced blanking now need:"
+ ewarn " Option \"ReducedBlanking\""
+ ewarn "In the relevant Monitor section(s)."
+ ewarn "Make sure your reduced blanking modelines are safe!"
+
+ echo
+ ewarn "You must rebuild all drivers if upgrading from xorg-server 1.5"
+ ewarn "or earlier, because the ABI changed. If you cannot start X because"
+ ewarn "of module version mismatch errors, this is your problem."
+
+ echo
+ ewarn "You can generate a list of all installed packages in the x11-drivers"
+ ewarn "category using this command:"
+ ewarn "emerge portage-utils; qlist -I -C x11-drivers/"
+
+ ebeep 5
+ epause 10
+}
+
+pkg_postrm() {
+ # Get rid of module dir to ensure opengl-update works properly
+ if ! has_version x11-base/xorg-server; then
+ if [[ -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
+ rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
+ fi
+ fi
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
+ local x=""
+ for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri}*; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
+ fi
+ done
+ eend 0
+}
+
+server_based_install() {
+ if ! use xorg; then
+ rm "${D}"/usr/share/man/man1/Xserver.1x \
+ "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
+ "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
+ "${D}"/usr/share/man/man1/Xserver.1x
+ fi
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set ${OLD_IMPLEM}
+}
+
+ensure_a_server_is_building() {
+ for server in ${IUSE_SERVERS}; do
+ use ${server} && return;
+ done
+ eerror "You need to specify at least one server to build."
+ eerror "Valid servers are: ${IUSE_SERVERS}."
+ die "No servers were specified to build."
+}