summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-01-28 21:46:20 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-01-28 21:46:20 +0000
commit4c61f0abebd6b47cacb4d1d18d0c6260272585ed (patch)
tree61f962e9dffddd6e089afa50c8d29efdfd936213 /x11-base
parent- version bump for new applets and options (diff)
downloadgentoo-2-4c61f0abebd6b47cacb4d1d18d0c6260272585ed.tar.gz
gentoo-2-4c61f0abebd6b47cacb4d1d18d0c6260272585ed.tar.bz2
gentoo-2-4c61f0abebd6b47cacb4d1d18d0c6260272585ed.zip
Change VIDEO_CARDS=matrox to mga for compatibility with xorg-x11. Also port everything to modular X.
(Portage version: 2.1_pre4)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/x11-drm/ChangeLog10
-rw-r--r--x11-base/x11-drm/x11-drm-20050502.ebuild11
-rw-r--r--x11-base/x11-drm/x11-drm-20050807.ebuild11
-rw-r--r--x11-base/x11-drm/x11-drm-20051028.ebuild8
-rw-r--r--x11-base/x11-drm/x11-drm-20051223.ebuild8
-rw-r--r--x11-base/x11-drm/x11-drm-4.3.0-r7.ebuild11
6 files changed, 31 insertions, 28 deletions
diff --git a/x11-base/x11-drm/ChangeLog b/x11-base/x11-drm/ChangeLog
index b780ec5cab38..b39633031d7c 100644
--- a/x11-base/x11-drm/ChangeLog
+++ b/x11-base/x11-drm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-base/x11-drm
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.24 2005/12/24 00:43:04 battousai Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.25 2006/01/28 21:46:20 spyderous Exp $
+
+ 28 Jan 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ x11-drm-4.3.0-r7.ebuild, x11-drm-20050502.ebuild, x11-drm-20050807.ebuild,
+ x11-drm-20051028.ebuild, x11-drm-20051223.ebuild:
+ Change VIDEO_CARDS=matrox to mga for compatibility with xorg-x11. Also port
+ everything to modular X.
*x11-drm-20051223 (24 Dec 2005)
diff --git a/x11-base/x11-drm/x11-drm-20050502.ebuild b/x11-base/x11-drm/x11-drm-20050502.ebuild
index e2cacb7fe58d..33231503ee80 100644
--- a/x11-base/x11-drm/x11-drm-20050502.ebuild
+++ b/x11-base/x11-drm/x11-drm-20050502.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20050502.ebuild,v 1.3 2005/08/09 01:56:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20050502.ebuild,v 1.4 2006/01/28 21:46:20 spyderous Exp $
inherit eutils x11 linux-mod
IUSE=""
-IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 matrox rage128 radeon savage sis via"
+IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 mga rage128 radeon savage sis via"
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
@@ -25,8 +25,7 @@ SLOT="${KV}"
LICENSE="X11"
KEYWORDS="x86 ~alpha ~ia64 ~ppc ~amd64"
-DEPEND="virtual/x11
- virtual/linux-sources
+DEPEND="virtual/linux-sources
>=sys-apps/portage-2.0.49-r13"
pkg_setup() {
@@ -164,7 +163,7 @@ set_vidcards() {
VIDCARDS=""
- use video_cards_matrox && \
+ use video_cards_mga && \
VIDCARDS="${VIDCARDS} mga.${KV_OBJ}"
use video_cards_3dfx && \
VIDCARDS="${VIDCARDS} tdfx.${KV_OBJ}"
diff --git a/x11-base/x11-drm/x11-drm-20050807.ebuild b/x11-base/x11-drm/x11-drm-20050807.ebuild
index 4fe63504558a..956ef1ecd324 100644
--- a/x11-base/x11-drm/x11-drm-20050807.ebuild
+++ b/x11-base/x11-drm/x11-drm-20050807.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20050807.ebuild,v 1.2 2005/10/29 03:18:25 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20050807.ebuild,v 1.3 2006/01/28 21:46:20 spyderous Exp $
inherit eutils x11 linux-mod
IUSE=""
-IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 matrox rage128 radeon savage sis via"
+IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 mga rage128 radeon savage sis via"
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
@@ -25,8 +25,7 @@ SLOT="0"
LICENSE="X11"
KEYWORDS="~x86 ~alpha ~ia64 ~ppc ~amd64"
-DEPEND="virtual/x11
- >=sys-devel/automake-1.7
+DEPEND=">=sys-devel/automake-1.7
>=sys-devel/autoconf-2.59
>=sys-devel/libtool-1.5.14
>=sys-devel/m4-1.4
@@ -172,7 +171,7 @@ set_vidcards() {
VIDCARDS=""
- use video_cards_matrox && \
+ use video_cards_mga && \
VIDCARDS="${VIDCARDS} mga.${KV_OBJ}"
use video_cards_3dfx && \
VIDCARDS="${VIDCARDS} tdfx.${KV_OBJ}"
diff --git a/x11-base/x11-drm/x11-drm-20051028.ebuild b/x11-base/x11-drm/x11-drm-20051028.ebuild
index c2d4f6a90298..e11801a1deb9 100644
--- a/x11-base/x11-drm/x11-drm-20051028.ebuild
+++ b/x11-base/x11-drm/x11-drm-20051028.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20051028.ebuild,v 1.2 2005/12/14 15:59:54 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20051028.ebuild,v 1.3 2006/01/28 21:46:20 spyderous Exp $
inherit eutils x11 linux-mod
IUSE=""
-IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 matrox nv rage128 radeon savage sis via"
+IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 mga nv rage128 radeon savage sis via"
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
@@ -171,7 +171,7 @@ set_vidcards() {
VIDCARDS=""
- use video_cards_matrox && \
+ use video_cards_mga && \
VIDCARDS="${VIDCARDS} mga.${KV_OBJ}"
use video_cards_3dfx && \
VIDCARDS="${VIDCARDS} tdfx.${KV_OBJ}"
diff --git a/x11-base/x11-drm/x11-drm-20051223.ebuild b/x11-base/x11-drm/x11-drm-20051223.ebuild
index 250ca2e04c06..6a0414665935 100644
--- a/x11-base/x11-drm/x11-drm-20051223.ebuild
+++ b/x11-base/x11-drm/x11-drm-20051223.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20051223.ebuild,v 1.1 2005/12/24 00:43:04 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20051223.ebuild,v 1.2 2006/01/28 21:46:20 spyderous Exp $
inherit eutils x11 linux-mod
IUSE=""
-IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 matrox nv rage128 radeon savage sis via"
+IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 mga nv rage128 radeon savage sis via"
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
@@ -171,7 +171,7 @@ set_vidcards() {
VIDCARDS=""
- use video_cards_matrox && \
+ use video_cards_mga && \
VIDCARDS="${VIDCARDS} mga.${KV_OBJ}"
use video_cards_3dfx && \
VIDCARDS="${VIDCARDS} tdfx.${KV_OBJ}"
diff --git a/x11-base/x11-drm/x11-drm-4.3.0-r7.ebuild b/x11-base/x11-drm/x11-drm-4.3.0-r7.ebuild
index 25404599a647..0331d9a1f1e6 100644
--- a/x11-base/x11-drm/x11-drm-4.3.0-r7.ebuild
+++ b/x11-base/x11-drm/x11-drm-4.3.0-r7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-4.3.0-r7.ebuild,v 1.6 2005/05/19 04:38:14 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-4.3.0-r7.ebuild,v 1.7 2006/01/28 21:46:20 spyderous Exp $
IUSE="gatos"
-IUSE_VIDEO_CARDS="3dfx gamma i810 i830 matrox rage128 radeon sis mach64"
+IUSE_VIDEO_CARDS="3dfx gamma i810 i830 mga rage128 radeon sis mach64"
inherit eutils x11
@@ -42,8 +42,7 @@ LICENSE="X11"
KEYWORDS="x86 alpha ia64 ppc"
# Need new portage for USE_EXPAND
-DEPEND="virtual/x11
- virtual/linux-sources
+DEPEND="virtual/linux-sources
>=sys-apps/portage-2.0.49-r13"
pkg_setup() {
@@ -197,7 +196,7 @@ check_exclusive() {
set_vidcards() {
VIDCARDS=""
- use video_cards_matrox && \
+ use video_cards_mga && \
VIDCARDS="${VIDCARDS} mga.o"
use video_cards_3dfx && \
VIDCARDS="${VIDCARDS} tdfx.o"