summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-05-20 17:41:02 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-05-20 17:41:02 +0000
commite5c8b5a69832312cfe0b6b9f2fc9b3f0c9df8a74 (patch)
treeadf920bc7a37d83e629e57fcf5770de65e8d4201 /x11-drivers/ati-drivers/ati-drivers-13.4.ebuild
parentRestore ~arm (diff)
downloadgentoo-2-e5c8b5a69832312cfe0b6b9f2fc9b3f0c9df8a74.tar.gz
gentoo-2-e5c8b5a69832312cfe0b6b9f2fc9b3f0c9df8a74.tar.bz2
gentoo-2-e5c8b5a69832312cfe0b6b9f2fc9b3f0c9df8a74.zip
Import latest ebuild from the x11 overlay, by Emil Karlson.
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/ati-drivers/ati-drivers-13.4.ebuild')
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-13.4.ebuild24
1 files changed, 21 insertions, 3 deletions
diff --git a/x11-drivers/ati-drivers/ati-drivers-13.4.ebuild b/x11-drivers/ati-drivers/ati-drivers-13.4.ebuild
index f93c0d487042..c6d861e19bdb 100644
--- a/x11-drivers/ati-drivers/ati-drivers-13.4.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-13.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-13.4.ebuild,v 1.1 2013/04/26 08:51:56 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-13.4.ebuild,v 1.2 2013/05/20 17:41:02 chithanh Exp $
EAPI=5
@@ -11,7 +11,11 @@ HOMEPAGE="http://www.amd.com"
MY_V=( $(get_version_components) )
#RUN="${WORKDIR}/amd-driver-installer-9.00-x86.x86_64.run"
SLOT="1"
-[[ "${MY_V[2]}" =~ beta.* ]] && BETADIR="beta/" || BETADIR="linux/"
+if [[ "${MY_V[2]}" =~ beta.* ]]; then
+ BETADIR="beta/"
+else
+ BETADIR="linux/"
+fi
if [[ legacy != ${SLOT} ]]; then
DRIVERS_URI="http://www2.ati.com/drivers/${BETADIR}amd-catalyst-${PV/_beta/-beta}-linux-x86.x86_64.zip"
else
@@ -155,7 +159,6 @@ QA_DT_HASH="
"
CONFIG_CHECK="~MTRR ~!DRM ACPI PCI_MSI !LOCKDEP !PAX_KERNEXEC_PLUGIN_METHOD_OR"
-use amd64 && CONFIG_CHECK="${CONFIG_CHECK} COMPAT"
ERROR_MTRR="CONFIG_MTRR required for direct rendering."
ERROR_DRM="CONFIG_DRM must be disabled or compiled as a module and not loaded for direct
rendering to work."
@@ -177,6 +180,10 @@ _check_kernel_config() {
kernel_is ge 2 6 37 && kernel_is le 2 6 38 && if ! linux_chkconfig_present BKL ; then
die "CONFIG_BKL must be enabled for kernels 2.6.37-2.6.38."
fi
+
+ if use amd64 && ! linux_chkconfig_present COMPAT; then
+ die "CONFIG_COMPAT must be enabled for amd64 kernels."
+ fi
}
pkg_pretend() {
@@ -193,6 +200,12 @@ pkg_pretend() {
die "USE pax_kernel enabled for a non-hardened kernel"
fi
fi
+
+ if ! has XT ${PAX_MARKINGS} && use pax_kernel; then
+ ewarn "You have disabled xattr pax markings for portage."
+ ewarn "This will likely cause programs using ati-drivers provided"
+ ewarn "libraries to be killed kernel."
+ fi
}
pkg_setup() {
@@ -299,6 +312,11 @@ src_prepare() {
# compile fix for AGP-less kernel, bug #435322
epatch "${FILESDIR}"/ati-drivers-12.9-KCL_AGP_FindCapsRegisters-stub.patch
+ # Compile fix for kernel typesafe uid types #469160
+ epatch "${FILESDIR}/linux-3.9-kuid.diff"
+
+ epatch "${FILESDIR}/linux-3.10-proc.diff"
+
# Compile fix, https://bugs.gentoo.org/show_bug.cgi?id=454870
use pax_kernel && epatch "${FILESDIR}/const-notifier-block.patch"