summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-17 13:59:18 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-17 13:59:18 +0000
commitab51c9e923dfc22fe7d9db58b8c3911d2a777e87 (patch)
treee02f1261b68857a88af9e7c3ea67bbeec5f2f963 /x11-drivers/nvidia-legacy-drivers
parentMark 2.1.1-r1 stable on alpha (diff)
downloadgentoo-2-ab51c9e923dfc22fe7d9db58b8c3911d2a777e87.tar.gz
gentoo-2-ab51c9e923dfc22fe7d9db58b8c3911d2a777e87.tar.bz2
gentoo-2-ab51c9e923dfc22fe7d9db58b8c3911d2a777e87.zip
Added patch for 2.6.19 kernel and closing bug #151317.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'x11-drivers/nvidia-legacy-drivers')
-rw-r--r--x11-drivers/nvidia-legacy-drivers/ChangeLog6
-rw-r--r--x11-drivers/nvidia-legacy-drivers/files/NVIDIA_kernel-2.6.19.patch47
-rw-r--r--x11-drivers/nvidia-legacy-drivers/nvidia-legacy-drivers-1.0.7184.ebuild5
3 files changed, 56 insertions, 2 deletions
diff --git a/x11-drivers/nvidia-legacy-drivers/ChangeLog b/x11-drivers/nvidia-legacy-drivers/ChangeLog
index 5df42f41acbd..6921e1b105af 100644
--- a/x11-drivers/nvidia-legacy-drivers/ChangeLog
+++ b/x11-drivers/nvidia-legacy-drivers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-drivers/nvidia-legacy-drivers
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-legacy-drivers/ChangeLog,v 1.10 2006/10/09 13:36:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-legacy-drivers/ChangeLog,v 1.11 2006/10/17 13:59:18 wolf31o2 Exp $
+
+ 17 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/NVIDIA_kernel-2.6.19.patch, nvidia-legacy-drivers-1.0.7184.ebuild:
+ Added patch for 2.6.19 kernel and closing bug #151317.
09 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
nvidia-legacy-drivers-1.0.7184.ebuild:
diff --git a/x11-drivers/nvidia-legacy-drivers/files/NVIDIA_kernel-2.6.19.patch b/x11-drivers/nvidia-legacy-drivers/files/NVIDIA_kernel-2.6.19.patch
new file mode 100644
index 000000000000..9d56d428e155
--- /dev/null
+++ b/x11-drivers/nvidia-legacy-drivers/files/NVIDIA_kernel-2.6.19.patch
@@ -0,0 +1,47 @@
+Index: NVIDIA-Linux-x86_64-1.0-9625-pkg2/usr/src/nv/nv-linux.h
+===================================================================
+--- NVIDIA-Linux-x86_64-1.0-9625-pkg2.orig/usr/src/nv/nv-linux.h
++++ NVIDIA-Linux-x86_64-1.0-9625-pkg2/usr/src/nv/nv-linux.h
+@@ -14,10 +14,11 @@
+
+ #include "nv.h"
+
+-#include <linux/config.h>
+ #include <linux/version.h>
+ #include <linux/utsname.h>
+-
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 15)
++#include <linux/config.h>
++#endif
+
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 4, 7)
+ # error This driver does not support 2.4 kernels older than 2.4.7!
+Index: NVIDIA-Linux-x86_64-1.0-9625-pkg2/usr/src/nv/nv.c
+===================================================================
+--- NVIDIA-Linux-x86_64-1.0-9625-pkg2.orig/usr/src/nv/nv.c
++++ NVIDIA-Linux-x86_64-1.0-9625-pkg2/usr/src/nv/nv.c
+@@ -288,7 +288,11 @@ int nv_kern_ioctl(struct inode
+ long nv_kern_unlocked_ioctl(struct file *, unsigned int, unsigned long);
+ long nv_kern_compat_ioctl(struct file *, unsigned int, unsigned long);
+ void nv_kern_isr_bh(unsigned long);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 19)
+ irqreturn_t nv_kern_isr(int, void *, struct pt_regs *);
++#else
++irqreturn_t nv_kern_isr(int, void *);
++#endif
+ void nv_kern_rc_timer(unsigned long);
+ #if defined(NV_PM_SUPPORT_OLD_STYLE_APM)
+ static int nv_kern_apm_event(struct pm_dev *, pm_request_t, void *);
+@@ -2595,8 +2599,10 @@ long nv_kern_compat_ioctl(
+ */
+ irqreturn_t nv_kern_isr(
+ int irq,
+- void *arg,
+- struct pt_regs *regs
++ void *arg
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 19)
++ , struct pt_regs *regs
++#endif
+ )
+ {
+ nv_linux_state_t *nvl = (void *) arg;
diff --git a/x11-drivers/nvidia-legacy-drivers/nvidia-legacy-drivers-1.0.7184.ebuild b/x11-drivers/nvidia-legacy-drivers/nvidia-legacy-drivers-1.0.7184.ebuild
index ba93a6bdccd1..1f6da45b1cb5 100644
--- a/x11-drivers/nvidia-legacy-drivers/nvidia-legacy-drivers-1.0.7184.ebuild
+++ b/x11-drivers/nvidia-legacy-drivers/nvidia-legacy-drivers-1.0.7184.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-legacy-drivers/nvidia-legacy-drivers-1.0.7184.ebuild,v 1.5 2006/10/09 13:36:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-legacy-drivers/nvidia-legacy-drivers-1.0.7184.ebuild,v 1.6 2006/10/17 13:59:18 wolf31o2 Exp $
inherit eutils multilib versionator linux-mod
@@ -139,6 +139,9 @@ src_unpack() {
# If greater than 2.6.5 use M= instead of SUBDIR=
cd ${S}; convert_to_m Makefile.kbuild
+
+ # Patch for kernel 2.6.19 from Daniel Drake <dsd@gentoo.org>
+ epatch ${FILESDIR}/NVIDIA_kernel-2.6.19.patch
}
src_compile() {