summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-09-27 21:01:41 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-09-27 21:01:41 +0000
commit4dfbff5a8022afb56f121dc22055c2b2080d8491 (patch)
tree8301d42de88f7a37da318fe5d01efe36c79eb7e1 /x11-drivers/xf86-input-synaptics
parentBump (diff)
downloadgentoo-2-4dfbff5a8022afb56f121dc22055c2b2080d8491.tar.gz
gentoo-2-4dfbff5a8022afb56f121dc22055c2b2080d8491.tar.bz2
gentoo-2-4dfbff5a8022afb56f121dc22055c2b2080d8491.zip
QA: Restore downgrade path from 1.3.0; this package is now privately maintained. Check with maintainers on e-mail / IRC.
(Portage version: 2.1.9.6/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog7
-rw-r--r--x11-drivers/xf86-input-synaptics/metadata.xml2
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r2.ebuild55
3 files changed, 62 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index 05ac782952ef..76f685f112c2 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.52 2010/09/10 13:27:03 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.53 2010/09/27 21:01:41 chainsaw Exp $
+
+ 27 Sep 2010; <chainsaw@gentoo.org> +xf86-input-synaptics-1.2.2-r2.ebuild,
+ metadata.xml:
+ QA: Restore downgrade path from 1.3.0; this package is now privately
+ maintained. Check with maintainers on e-mail / IRC.
10 Sep 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
xf86-input-synaptics-1.3.0.ebuild:
diff --git a/x11-drivers/xf86-input-synaptics/metadata.xml b/x11-drivers/xf86-input-synaptics/metadata.xml
index 55970b5c80a6..045145274ed5 100644
--- a/x11-drivers/xf86-input-synaptics/metadata.xml
+++ b/x11-drivers/xf86-input-synaptics/metadata.xml
@@ -14,5 +14,5 @@
<name>Christoph Brill</name>
<description>upstream co-maintainer</description>
</maintainer>
- <herd>x11</herd>
+ <herd>no-herd</herd>
</pkgmetadata>
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r2.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..5b478bc4464d
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r2.ebuild,v 1.3 2010/09/27 21:01:41 chainsaw Exp $
+
+inherit linux-info x-modular
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="hal"
+
+RDEPEND="
+ >=x11-base/xorg-server-1.8
+ >=x11-libs/libXi-1.2
+ x11-libs/libXtst
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ >=sys-apps/sed-4"
+
+src_install() {
+ DOCS="INSTALL TODO README"
+ x-modular_src_install
+
+ if use hal ; then
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ doins "${S}"/fdi/11-x11-synaptics.fdi
+ fi
+
+ insinto /etc/X11/xorg.conf.d
+ newins "${FILESDIR}/${PV}-xorg-inputclass" 20-synaptics.conf || die "Unable to install xorg inputclass policy file"
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+ if use hal ; then
+ elog "If you want to modify Synaptics settings, please create an fdi file in:"
+ elog "/etc/hal/fdi/policy/"
+ echo
+ ewarn "The current default are set by :"
+ ewarn "/usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi"
+ ewarn "You can use this file for inspiration, but DO NOT EDIT IT directly."
+ fi
+}