summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2010-01-07 03:49:01 +0000
committerNed Ludd <solar@gentoo.org>2010-01-07 03:49:01 +0000
commit4433fcf41fba5cdcea8c3361c915739f4c5a893c (patch)
tree5c8dc4d471794c78da493cde936ccf387c2b1e9e /x11-drivers/xf86-input-tslib
parentVersion bump and removed useless .la files (bug #298887) (diff)
downloadgentoo-2-4433fcf41fba5cdcea8c3361c915739f4c5a893c.tar.gz
gentoo-2-4433fcf41fba5cdcea8c3361c915739f4c5a893c.tar.bz2
gentoo-2-4433fcf41fba5cdcea8c3361c915739f4c5a893c.zip
- version bump. Pull updated debian patchset. http://packages.qa.debian.org/x/xf86-input-tslib.html
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'x11-drivers/xf86-input-tslib')
-rw-r--r--x11-drivers/xf86-input-tslib/ChangeLog10
-rw-r--r--x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-tslib/ChangeLog b/x11-drivers/xf86-input-tslib/ChangeLog
index 3fa45725f232..fd1f18f77cd2 100644
--- a/x11-drivers/xf86-input-tslib/ChangeLog
+++ b/x11-drivers/xf86-input-tslib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-tslib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/ChangeLog,v 1.16 2009/09/22 10:17:26 remi Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/ChangeLog,v 1.17 2010/01/07 03:49:01 solar Exp $
+
+*xf86-input-tslib-0.0.6 (07 Jan 2010)
+
+ 07 Jan 2010; <solar@gentoo.org> +xf86-input-tslib-0.0.6.ebuild:
+ - version bump. Pull updated debian patchset.
+ http://packages.qa.debian.org/x/xf86-input-tslib.html
22 Sep 2009; Rémi Cardona <remi@gentoo.org>
-xf86-input-tslib-0.0.5.ebuild:
diff --git a/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6.ebuild b/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6.ebuild
new file mode 100644
index 000000000000..c3401d3cca25
--- /dev/null
+++ b/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6.ebuild,v 1.1 2010/01/07 03:49:01 solar Exp $
+
+# Based on xf86-input-synaptics ebuild
+
+inherit toolchain-funcs eutils linux-info x-modular
+
+PATCHLEVEL=1
+PATCHFILE="${PN}_${PV}-${PATCHLEVEL}.diff"
+
+DESCRIPTION="xorg input driver for use of tslib based touchscreen devices"
+HOMEPAGE="http://www.pengutronix.de/software/${PN}/index_en.html"
+SRC_URI="http://www.pengutronix.de/software/${PN}/download/${P}.tar.bz2
+ ftp://cdn.debian.net/debian/pool/main/x/${PN}/${PATCHFILE}.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE=""
+RDEPEND="x11-base/xorg-server x11-libs/tslib"
+DEPEND="x11-proto/inputproto"
+
+# Remove stupid evdev checks.
+# Never die simply cuz kernel sources do not exist.
+
+src_unpack() {
+ x-modular_unpack_source
+ cd "${WORKDIR}"
+ epatch "${WORKDIR}/${PATCHFILE}"
+ EPATCH_OPTS="-p0" EPATCH_SOURCE="${S}/debian/patches" EPATCH_SUFFIX="diff" EPATCH_FORCE="yes" epatch
+}
+
+src_install() {
+ DOCS="COPYING ChangeLog"
+ x-modular_src_install
+ insinto /usr/share/hal/fdi/policy/20thirdparty/
+ doins "${S}/debian/10-x11-input-tslib.fdi"
+}