summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2012-04-22 13:32:58 +0000
committerMike Auty <ikelos@gentoo.org>2012-04-22 13:32:58 +0000
commit882d46cf07cce5b1bfafe49e914c05333933f2b9 (patch)
tree01709442c927e9aefd3d7c3f75f2868db4ccd9a2 /x11-drivers/xf86-input-wacom
parentVersion bump (diff)
downloadgentoo-2-882d46cf07cce5b1bfafe49e914c05333933f2b9.tar.gz
gentoo-2-882d46cf07cce5b1bfafe49e914c05333933f2b9.tar.bz2
gentoo-2-882d46cf07cce5b1bfafe49e914c05333933f2b9.zip
Bump to version 0.14.0.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog7
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.14.0.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 6a3c84a10b6f..af44283599f6 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.51 2012/03/03 16:28:53 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.52 2012/04/22 13:32:58 ikelos Exp $
+
+*xf86-input-wacom-0.14.0 (22 Apr 2012)
+
+ 22 Apr 2012; Mike Auty <ikelos@gentoo.org> +xf86-input-wacom-0.14.0.ebuild:
+ Bump to version 0.14.0.
03 Mar 2012; Brent Baude <ranger@gentoo.org> xf86-input-wacom-0.11.1.ebuild:
Marking xf86-input-wacom-0.11.1 ppc64 stable for bug 394393
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.14.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.14.0.ebuild
new file mode 100644
index 000000000000..c93a1ac9e86b
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.14.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.14.0.ebuild,v 1.1 2012/04/22 13:32:58 ikelos Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}