summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-18 20:01:51 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-18 20:01:51 +0000
commit04673755569db01e8fe46341d4d0cc38680b07b9 (patch)
treed5969fd43163817bcc8cb547eeabb401e63afa84 /x11-drivers
parentAdded some country specific locales (diff)
downloadgentoo-2-04673755569db01e8fe46341d4d0cc38680b07b9.tar.gz
gentoo-2-04673755569db01e8fe46341d4d0cc38680b07b9.tar.bz2
gentoo-2-04673755569db01e8fe46341d4d0cc38680b07b9.zip
Add patch to fix horizontal scrolling.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-evdev/ChangeLog7
-rw-r--r--x11-drivers/xf86-input-evdev/files/xf86-input-evdev-2.7.0-horizontal-scrolling.patch27
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.7.0.ebuild6
3 files changed, 38 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-evdev/ChangeLog b/x11-drivers/xf86-input-evdev/ChangeLog
index c7822390dddb..35e06c17139f 100644
--- a/x11-drivers/xf86-input-evdev/ChangeLog
+++ b/x11-drivers/xf86-input-evdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-input-evdev
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.172 2012/03/18 17:09:04 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.173 2012/03/18 20:01:50 chithanh Exp $
+
+ 18 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-input-evdev-2.7.0-horizontal-scrolling.patch,
+ xf86-input-evdev-2.7.0.ebuild:
+ Add patch to fix horizontal scrolling.
*xf86-input-evdev-2.7.0 (18 Mar 2012)
diff --git a/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-2.7.0-horizontal-scrolling.patch b/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-2.7.0-horizontal-scrolling.patch
new file mode 100644
index 000000000000..93c54d300619
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-2.7.0-horizontal-scrolling.patch
@@ -0,0 +1,27 @@
+From 99340147b9092a5aaec997eca407282a51e1f063 Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Thu, 15 Mar 2012 05:46:32 +0000
+Subject: Fix inverted horizontal scroll (#46205)
+
+REL_HWHEEL has a positive increment, not a negative one like REL_WHEEL.
+
+X.Org Bug 46205 <http://bugs.freedesktop.org/show_bug.cgi?id=46205>
+
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+Reviewed-by: Chase Douglas <chase.douglas@canonical.com>
+---
+diff --git a/src/evdev.c b/src/evdev.c
+index d540b87..8cf630c 100644
+--- a/src/evdev.c
++++ b/src/evdev.c
+@@ -1600,7 +1600,7 @@ EvdevAddRelValuatorClass(DeviceIntPtr device)
+ else if (axis == REL_DIAL)
+ SetScrollValuator(device, axnum, SCROLL_TYPE_VERTICAL, -1.0, SCROLL_FLAG_NONE);
+ else if (axis == REL_HWHEEL)
+- SetScrollValuator(device, axnum, SCROLL_TYPE_HORIZONTAL, -1.0, SCROLL_FLAG_NONE);
++ SetScrollValuator(device, axnum, SCROLL_TYPE_HORIZONTAL, 1.0, SCROLL_FLAG_NONE);
+ #endif
+ }
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.7.0.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.7.0.ebuild
index d4bae2574b20..a26a0cbf5ed7 100644
--- a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.7.0.ebuild
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.7.0.ebuild,v 1.1 2012/03/18 17:09:04 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.7.0.ebuild,v 1.2 2012/03/18 20:01:50 chithanh Exp $
EAPI=4
inherit xorg-2
@@ -14,3 +14,7 @@ DEPEND="${RDEPEND}
>=x11-proto/inputproto-2.1.99.3
>=sys-kernel/linux-headers-2.6
sys-libs/mtdev"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.0-horizontal-scrolling.patch
+)