summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-01 18:54:51 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-01 18:54:51 +0000
commit5e90b93cee34bf1417bfad7dc7b5f7eb866f3dde (patch)
tree5db0d1d41da98bf1bd12db2bcb877d5b0f89ee73 /x11-drivers
parentAdd fix from upstream for brown bag bug in patch005. (diff)
downloadgentoo-2-5e90b93cee34bf1417bfad7dc7b5f7eb866f3dde.tar.gz
gentoo-2-5e90b93cee34bf1417bfad7dc7b5f7eb866f3dde.tar.bz2
gentoo-2-5e90b93cee34bf1417bfad7dc7b5f7eb866f3dde.zip
Version bump.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.11.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index e07861402c18..d9abe89fa885 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.32 2011/02/20 10:54:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.33 2011/03/01 18:54:51 scarabeus Exp $
+
+*xf86-input-wacom-0.10.11 (01 Mar 2011)
+
+ 01 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +xf86-input-wacom-0.10.11.ebuild:
+ Version bump.
20 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
xf86-input-wacom-0.10.8-r1.ebuild:
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.11.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.11.ebuild
new file mode 100644
index 000000000000..dbf1f5211d08
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.11.ebuild,v 1.1 2011/03/01 18:54:51 scarabeus Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND="!x11-drivers/linuxwacom
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${D}"/usr/share/hal
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}