summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-10-05 01:11:47 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-10-05 01:11:47 +0000
commit78ec0b2a73a41754c0294dd7db3152972873e741 (patch)
tree7639e8dd131596ef4bda310658ad29c929c520b1 /x11-libs/cairo/cairo-1.0.2.ebuild
parentDont RDEPEND on audiofile if USE=noaudio #108091 by Brice Arnould. (diff)
downloadgentoo-2-78ec0b2a73a41754c0294dd7db3152972873e741.tar.gz
gentoo-2-78ec0b2a73a41754c0294dd7db3152972873e741.tar.bz2
gentoo-2-78ec0b2a73a41754c0294dd7db3152972873e741.zip
New release: 1.0.2
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'x11-libs/cairo/cairo-1.0.2.ebuild')
-rw-r--r--x11-libs/cairo/cairo-1.0.2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/x11-libs/cairo/cairo-1.0.2.ebuild b/x11-libs/cairo/cairo-1.0.2.ebuild
new file mode 100644
index 000000000000..282e09d07c09
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.0.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.0.2.ebuild,v 1.1 2005/10/05 01:11:47 leonardop Exp $
+
+inherit eutils
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc glitz png X"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1
+ sys-libs/zlib
+ X? (
+ ||( (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXt )
+ virtual/x11 )
+ virtual/xft )
+ glitz? ( >=media-libs/glitz-0.4.4 )
+ png? ( media-libs/libpng )
+ !<x11-libs/cairo-0.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? (
+ >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2 )"
+
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Call PKG_PROG_PKG_CONFIG to fix other standard pkg-config calls
+ epatch ${FILESDIR}/${P}-pkg_macro.patch
+
+ cp aclocal.m4 old_macros.m4
+ aclocal -I . || die "aclocal failed"
+ autoconf || die "autoconf failed"
+}
+
+
+src_compile() {
+ local myconf="$(use_with X x) \
+ $(use_enable X xlib) \
+ $(use_enable png) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable glitz)"
+
+ econf $myconf || die "./configure failed"
+ emake || die "Compilation failed"
+}
+
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}