summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-04-15 15:32:13 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-04-15 15:32:13 +0000
commit608ad6631da2d2021835e3f78efac591f41662ff (patch)
tree860fe107a133430d2cdc116d07683f7920d73920 /x11-libs/cairo
parentDo not use GMPCV variable. (diff)
downloadgentoo-2-608ad6631da2d2021835e3f78efac591f41662ff.tar.gz
gentoo-2-608ad6631da2d2021835e3f78efac591f41662ff.tar.bz2
gentoo-2-608ad6631da2d2021835e3f78efac591f41662ff.zip
revbump from upstream. reduces malloc calls. cleans up cases when malloc fails. cleans up other assorted bugs.
(Portage version: 2.1.2.3)
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/ChangeLog8
-rw-r--r--x11-libs/cairo/cairo-1.4.4.ebuild67
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.4.43
3 files changed, 77 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 428a9b7da064..f022a6854f56 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.111 2007/03/21 15:21:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.112 2007/04/15 15:32:13 cardoe Exp $
+
+*cairo-1.4.4 (15 Apr 2007)
+
+ 15 Apr 2007; Doug Goldstein <cardoe@gentoo.org> +cairo-1.4.4.ebuild:
+ revbump from upstream. reduces malloc calls. cleans up cases when malloc
+ fails. cleans up other assorted bugs.
21 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> cairo-1.2.6.ebuild:
Stable on alpha/ia64 wrt bug #167573.
diff --git a/x11-libs/cairo/cairo-1.4.4.ebuild b/x11-libs/cairo/cairo-1.4.4.ebuild
new file mode 100644
index 000000000000..41496023e98f
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.4.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.4.4.ebuild,v 1.1 2007/04/15 15:32:13 cardoe Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug directfb doc glitz svg X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.4
+ media-libs/libpng
+ X? (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft
+ xcb? ( x11-libs/libxcb
+ x11-libs/xcb-util )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ X? ( x11-proto/renderproto
+ xcb? ( x11-proto/xcb-proto ) )
+ doc? (
+ >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ elibtoolize
+}
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
+ $(use_enable svg) $(use_enable glitz) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps $(use_enable xcb) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/x11-libs/cairo/files/digest-cairo-1.4.4 b/x11-libs/cairo/files/digest-cairo-1.4.4
new file mode 100644
index 000000000000..b6fb5c2f95f6
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.4.4
@@ -0,0 +1,3 @@
+MD5 a609118644e1d958d977821c6fd765a9 cairo-1.4.4.tar.gz 3129412
+RMD160 69b71c4dc43a4f843772b6653ec158bea7680fe4 cairo-1.4.4.tar.gz 3129412
+SHA256 6469711192ebd359cd77cf299cfbea285dbba3cc857ff9268c74345bddf2b473 cairo-1.4.4.tar.gz 3129412