summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-08-21 18:28:23 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-08-21 18:28:23 +0000
commite427f6f7e699ebe0cc097443895de2f26183ebb3 (patch)
tree473fe2fecde0b2adf1bbe9021441646f422e5f57 /x11-libs/fltk/fltk-1.1.7.ebuild
parentVersion bump as per bug 189595. Temporarily package.mask'ed for further testing. (diff)
downloadgentoo-2-e427f6f7e699ebe0cc097443895de2f26183ebb3.tar.gz
gentoo-2-e427f6f7e699ebe0cc097443895de2f26183ebb3.tar.bz2
gentoo-2-e427f6f7e699ebe0cc097443895de2f26183ebb3.zip
HTML docs installation fixed. bug #189729 thanks to Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.1.2.11)
Diffstat (limited to 'x11-libs/fltk/fltk-1.1.7.ebuild')
-rw-r--r--x11-libs/fltk/fltk-1.1.7.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/x11-libs/fltk/fltk-1.1.7.ebuild b/x11-libs/fltk/fltk-1.1.7.ebuild
index dc05a49a9c3b..5353a80a61d8 100644
--- a/x11-libs/fltk/fltk-1.1.7.ebuild
+++ b/x11-libs/fltk/fltk-1.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.7.ebuild,v 1.15 2007/08/02 13:25:05 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.7.ebuild,v 1.16 2007/08/21 18:28:23 coldwind Exp $
inherit eutils toolchain-funcs multilib
@@ -76,10 +76,10 @@ src_compile() {
src_install() {
einstall \
- includedir=${D}${INCDIR} \
- libdir=${D}${LIBDIR} || die "Installation Failed"
+ includedir="${D}${INCDIR}" \
+ libdir="${D}${LIBDIR}" || die "Installation Failed"
- ranlib ${D}${LIBDIR}/*.a
+ ranlib "${D}${LIBDIR}"/*.a
dodoc CHANGES README
@@ -88,10 +88,9 @@ src_install() {
doenvd 99fltk-${SLOT}
- dodir /usr/share/doc/${P}/html
- mv ${D}/usr/share/doc/fltk/* ${D}/usr/share/doc/${PF}/html
- rmdir ${D}/usr/share/doc/fltk
- rm -rf ${D}/usr/share/man/cat{1,3}
+ dohtml -A xbm,xpm,h,cxx,fl -r "${D}"/usr/share/doc/fltk/*
+ rm -rf "${D}"/usr/share/doc/fltk
+ rm -rf "${D}"/usr/share/man/cat{1,3}
}
pkg_postinst() {