summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-02-07 01:36:55 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-02-07 01:36:55 +0000
commita9bf04d7f579d9b7ca3df8ecf896511704930f01 (patch)
treefaa6c92a5594635da0c31784fbab2fa4642c0aa2 /x11-libs/fox/fox-1.0.49.ebuild
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-a9bf04d7f579d9b7ca3df8ecf896511704930f01.tar.gz
gentoo-2-a9bf04d7f579d9b7ca3df8ecf896511704930f01.tar.bz2
gentoo-2-a9bf04d7f579d9b7ca3df8ecf896511704930f01.zip
Version bump, removed older ebuilds and fixed a DESC typo.
Diffstat (limited to 'x11-libs/fox/fox-1.0.49.ebuild')
-rw-r--r--x11-libs/fox/fox-1.0.49.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-libs/fox/fox-1.0.49.ebuild b/x11-libs/fox/fox-1.0.49.ebuild
new file mode 100644
index 000000000000..9f28f46e5e59
--- /dev/null
+++ b/x11-libs/fox/fox-1.0.49.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.0.49.ebuild,v 1.1 2004/02/07 01:36:55 pyrania Exp $
+
+IUSE="cups opengl"
+S=${WORKDIR}/${P}
+DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily and effectively"
+SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.fox-toolkit.org"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc "
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+
+ local myconf
+
+ use opengl || myconf="$myconf --with-opengl=no" #default enabled
+ use cups && myconf="$myconf --enable-cups" #default disabled
+
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
+ rmdir ${D}/usr/fox/html
+ rmdir ${D}/usr/fox
+}