summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-17 03:15:34 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-17 03:15:34 +0000
commit1c14ab3e26a63da3fd9e7a355c3a948a8556fb1a (patch)
tree4673b5710ec2af52303a09c5a08c65ac0f65d9e7 /x11-libs/gtk+
parentVersion bump for stable channel release. (diff)
downloadgentoo-2-1c14ab3e26a63da3fd9e7a355c3a948a8556fb1a.tar.gz
gentoo-2-1c14ab3e26a63da3fd9e7a355c3a948a8556fb1a.tar.bz2
gentoo-2-1c14ab3e26a63da3fd9e7a355c3a948a8556fb1a.zip
Add upstream patch to prevent segfault in gtk_icon_view_layout_single_row, drop broken version. Thanks to Rafał Mużyło (galtgendo) for reporting.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/gtk+-2.24.8-iconview-layout.patch30
-rw-r--r--x11-libs/gtk+/gtk+-2.24.8-r1.ebuild (renamed from x11-libs/gtk+/gtk+-2.24.8.ebuild)5
3 files changed, 42 insertions, 2 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index c780de1f0992..a58d363f2ebf 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.551 2011/11/16 23:44:46 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.552 2011/11/17 03:15:34 tetromino Exp $
+
+*gtk+-2.24.8-r1 (17 Nov 2011)
+
+ 17 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org> -gtk+-2.24.8.ebuild,
+ +gtk+-2.24.8-r1.ebuild, +files/gtk+-2.24.8-iconview-layout.patch:
+ Add upstream patch to prevent segfault in gtk_icon_view_layout_single_row,
+ drop broken version. Thanks to Rafał Mużyło (galtgendo) for reporting.
*gtk+-3.2.2-r1 (16 Nov 2011)
diff --git a/x11-libs/gtk+/files/gtk+-2.24.8-iconview-layout.patch b/x11-libs/gtk+/files/gtk+-2.24.8-iconview-layout.patch
new file mode 100644
index 000000000000..e16fc38e3cfb
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-2.24.8-iconview-layout.patch
@@ -0,0 +1,30 @@
+From 5c3bb1839cac52828756f9ddb98f49d586853991 Mon Sep 17 00:00:00 2001
+From: Cosimo Cecchi <cosimoc@gnome.org>
+Date: Wed, 16 Nov 2011 22:38:45 +0000
+Subject: Revert "iconview: layout items immediately when setting a GtkTreeModel"
+
+It makes GtkIconView segfault on GTK 2.24.
+
+gtk_icon_view_expose() calls gtk_icon_view_layout() first thing if
+there's a layout queued anyway, so we wouldn't end up in the same
+situation causing the crash the original patch is supposed to fix.
+
+This reverts commit 5a03f4a6a50237d86959f596dda143dfc2f040d1.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=663138
+---
+diff --git a/gtk/gtkiconview.c b/gtk/gtkiconview.c
+index 62877fa..54b3f3b 100644
+--- a/gtk/gtkiconview.c
++++ b/gtk/gtkiconview.c
+@@ -5423,7 +5423,7 @@ gtk_icon_view_set_model (GtkIconView *icon_view,
+
+ gtk_icon_view_build_items (icon_view);
+
+- gtk_icon_view_layout (icon_view);
++ gtk_icon_view_queue_layout (icon_view);
+ }
+
+ g_object_notify (G_OBJECT (icon_view), "model");
+--
+cgit v0.9.0.2
diff --git a/x11-libs/gtk+/gtk+-2.24.8.ebuild b/x11-libs/gtk+/gtk+-2.24.8-r1.ebuild
index 2b39a3984663..1a36fc9dfbc7 100644
--- a/x11-libs/gtk+/gtk+-2.24.8.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.8.ebuild,v 1.1 2011/11/16 21:54:12 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.8-r1.ebuild,v 1.1 2011/11/17 03:15:34 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="2:2.4"
@@ -94,6 +94,9 @@ src_prepare() {
# fix building with gir #372953, upstream bug #642085
epatch "${FILESDIR}"/${PN}-2.24.7-darwin-quartz-introspection.patch
+ # Upstream patch to fix iconview crash, will be in next release
+ epatch "${FILESDIR}/${P}-iconview-layout.patch"
+
# Stop trying to build unmaintained docs, bug #349754
strip_builddir SUBDIRS tutorial docs/Makefile.am docs/Makefile.in
strip_builddir SUBDIRS faq docs/Makefile.am docs/Makefile.in