summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-11-06 10:53:13 +0000
committerSimon Stelling <blubb@gentoo.org>2005-11-06 10:53:13 +0000
commitb3474957d18554d12296e7b5648395ba531c3ce8 (patch)
tree65e8240d17de244e38d57182e66b86357267785d /x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
parentRemove old ebuilds (diff)
downloadgentoo-2-b3474957d18554d12296e7b5648395ba531c3ce8.tar.gz
gentoo-2-b3474957d18554d12296e7b5648395ba531c3ce8.tar.bz2
gentoo-2-b3474957d18554d12296e7b5648395ba531c3ce8.zip
fix bug 95603 and a multilib-strict issue
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild')
-rw-r--r--x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild b/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
index 32c667b527ec..bc93737af0e9 100644
--- a/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
+++ b/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild,v 1.7 2004/10/19 09:07:43 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/gtkscintilla2-0.1.0.ebuild,v 1.8 2005/11/06 10:53:13 blubb Exp $
+
+inherit multilib
MY_P="GtkScintilla2-${PV}"
DESCRIPTION="Gtk-2 wrappers for the Scintilla source editing components."
@@ -27,7 +29,7 @@ src_unpack() {
# some quick touches to the Makefile, bump the version
# and make use of our CFLAGS
- GTHREAD_LDFLAGS="$(pkg-config gthread-2.0 --libs)"
+ GTHREAD_LDFLAGS=$(echo "$(pkg-config gthread-2.0 --libs)" | sed 's|/|\\/|g')
sed -e "/CFLAGS/s/-g/${CFLAGS} -fPIC/" \
-e "s/^LDFLAGS_PRE =/LDFLAGS_PRE = ${GTHREAD_LDFLAGS}/" \
-i Makefile
@@ -44,7 +46,7 @@ src_compile() {
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} LIB_DIR=/usr/$(get_libdir) install || die
dodoc COPYING README
}