summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-24 17:16:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-24 17:16:51 +0000
commit2f719a4601e35d31d7721b53f2c897249d346efe (patch)
treea041f8fb2c968a68e76d4d34a2b3e7b51858e909 /x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild
parentDelete older ebuilds. (diff)
downloadgentoo-2-2f719a4601e35d31d7721b53f2c897249d346efe.tar.gz
gentoo-2-2f719a4601e35d31d7721b53f2c897249d346efe.tar.bz2
gentoo-2-2f719a4601e35d31d7721b53f2c897249d346efe.zip
Call Python-specific functions only when "python" USE flag is enabled.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild')
-rw-r--r--x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild b/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild
index a991fa7a5b98..2a8f82e1c584 100644
--- a/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild
+++ b/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild,v 1.5 2010/05/23 21:13:45 elvanor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/hippo-canvas/hippo-canvas-0.3.0-r1.ebuild,v 1.6 2010/05/24 17:16:51 arfrever Exp $
EAPI="2"
@@ -32,7 +32,9 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS README TODO"
pkg_setup() {
- python_set_active_version 2
+ if use python; then
+ python_set_active_version 2
+ fi
G2CONF="$(use_enable python)"
}
@@ -47,6 +49,8 @@ src_configure() {
src_install() {
gnome2_src_install
- rm "${D}$(python_get_sitedir)/hippo.la"
+ if use python; then
+ python_clean_installation_image
+ fi
rm "${D}/usr/$(get_libdir)/libhippocanvas-1.la"
}