summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-23 17:42:22 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-23 17:42:22 +0000
commit59596fb55723dfa4c55744b4af6e307e64420583 (patch)
tree35ef166671c93dff39024d57c196c3147df813a3 /x11-libs/libX11
parentDon't use cp -a. (diff)
downloadgentoo-2-59596fb55723dfa4c55744b4af6e307e64420583.tar.gz
gentoo-2-59596fb55723dfa4c55744b4af6e307e64420583.tar.bz2
gentoo-2-59596fb55723dfa4c55744b4af6e307e64420583.zip
(fd.o #4050) Fix VT switches. Woohoo!
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-libs/libX11')
-rw-r--r--x11-libs/libX11/ChangeLog8
-rw-r--r--x11-libs/libX11/files/digest-libX11-0.99.0-r11
-rw-r--r--x11-libs/libX11/files/fix-xkeysymdb-location.patch17
-rw-r--r--x11-libs/libX11/libX11-0.99.0-r1.ebuild30
4 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/libX11/ChangeLog b/x11-libs/libX11/ChangeLog
index f00d457cc33e..bc9b3fd0aefb 100644
--- a/x11-libs/libX11/ChangeLog
+++ b/x11-libs/libX11/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libX11
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.4 2005/08/20 22:24:06 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.5 2005/08/23 17:42:22 spyderous Exp $
+
+*libX11-0.99.0-r1 (23 Aug 2005)
+
+ 23 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/fix-xkeysymdb-location.patch, +libX11-0.99.0-r1.ebuild:
+ (fd.o #4050) Fix VT switches. Woohoo!
20 Aug 2005; Luca Barbato <lu_zero@gentoo.org> libX11-0.99.0.ebuild:
Marked ~ppc
diff --git a/x11-libs/libX11/files/digest-libX11-0.99.0-r1 b/x11-libs/libX11/files/digest-libX11-0.99.0-r1
new file mode 100644
index 000000000000..56d3b5933c1f
--- /dev/null
+++ b/x11-libs/libX11/files/digest-libX11-0.99.0-r1
@@ -0,0 +1 @@
+MD5 0bb745ed34f8bf09d0c0d89ff91c56b4 libX11-0.99.0.tar.bz2 1317247
diff --git a/x11-libs/libX11/files/fix-xkeysymdb-location.patch b/x11-libs/libX11/files/fix-xkeysymdb-location.patch
new file mode 100644
index 000000000000..13ef986853e8
--- /dev/null
+++ b/x11-libs/libX11/files/fix-xkeysymdb-location.patch
@@ -0,0 +1,17 @@
+https://bugs.freedesktop.org/show_bug.cgi?id=4050
+
+diff -Nur libX11-0.99.0.orig/src/StrKeysym.c libX11-0.99.0/src/StrKeysym.c
+--- libX11-0.99.0.orig/src/StrKeysym.c 2005-08-01 22:15:43.000000000 +0200
++++ libX11-0.99.0/src/StrKeysym.c 2005-08-23 14:39:49.000000000 +0200
+@@ -39,7 +39,11 @@
+ #include "Key.h"
+
+ #ifndef KEYSYMDB
++#ifndef XKEYSYMDB
+ #define KEYSYMDB "/usr/lib/X11/XKeysymDB"
++#else
++#define KEYSYMDB XKEYSYMDB
++#endif
+ #endif
+
+ static Bool initialized;
diff --git a/x11-libs/libX11/libX11-0.99.0-r1.ebuild b/x11-libs/libX11/libX11-0.99.0-r1.ebuild
new file mode 100644
index 000000000000..f06b96da2694
--- /dev/null
+++ b/x11-libs/libX11/libX11-0.99.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-0.99.0-r1.ebuild,v 1.1 2005/08/23 17:42:22 spyderous Exp $
+
+# FIXME: Add USE flags
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+PATCHES="${FILESDIR}/fix-xkeysymdb-location.patch"
+
+DESCRIPTION="X.Org X11 library"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE="ipv6"
+RDEPEND="x11-libs/xtrans
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/bigreqsproto
+ x11-proto/xextproto
+ x11-proto/xcmiscproto
+ x11-proto/kbproto
+ x11-proto/inputproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)"
+# xorg really doesn't like xlocale disabled.
+# $(use_enable nls xlocale)