summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-12 20:17:20 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-12 20:17:20 +0000
commit26f42c9c07a5e0b49ccc51cbb80acb22e9b5a325 (patch)
treeeb78f2026aac4b1da331ed80a45f0e17b52ace87 /x11-libs/libXfont/libXfont-1.2.2.ebuild
parentold (diff)
downloadgentoo-2-26f42c9c07a5e0b49ccc51cbb80acb22e9b5a325.tar.gz
gentoo-2-26f42c9c07a5e0b49ccc51cbb80acb22e9b5a325.tar.bz2
gentoo-2-26f42c9c07a5e0b49ccc51cbb80acb22e9b5a325.zip
(#145513) Security bump. Local root vulnerability in parsing CID fonts. Straight to stable on alpha/amd64/hppa/ppc/ppc64/sparc/x86 because they pre-tested on the bug.
(Portage version: 2.1.1_rc1-r7)
Diffstat (limited to 'x11-libs/libXfont/libXfont-1.2.2.ebuild')
-rw-r--r--x11-libs/libXfont/libXfont-1.2.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-libs/libXfont/libXfont-1.2.2.ebuild b/x11-libs/libXfont/libXfont-1.2.2.ebuild
new file mode 100644
index 000000000000..56316da6472a
--- /dev/null
+++ b/x11-libs/libXfont/libXfont-1.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.2.2.ebuild,v 1.1 2006/09/12 20:17:20 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular flag-o-matic
+
+DESCRIPTION="X.Org Xfont library"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="ipv6"
+RDEPEND="x11-libs/xtrans
+ x11-libs/libfontenc
+ x11-proto/xproto
+ x11-proto/fontsproto
+ >=media-libs/freetype-2"
+DEPEND="${RDEPEND}
+ x11-proto/fontcacheproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+ --with-encodingsdir=/usr/share/fonts/encodings"
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+}