summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-10-29 08:56:28 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-10-29 08:56:28 +0000
commit244028d3aab9075cc3ddb0df6c40b162d5101662 (patch)
tree9307fdc3114a819ef5cd7fd931a81316ea758572 /x11-libs/libXfont/libXfont-1.4.3.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-244028d3aab9075cc3ddb0df6c40b162d5101662.tar.gz
gentoo-2-244028d3aab9075cc3ddb0df6c40b162d5101662.tar.bz2
gentoo-2-244028d3aab9075cc3ddb0df6c40b162d5101662.zip
Version bump
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libXfont/libXfont-1.4.3.ebuild')
-rw-r--r--x11-libs/libXfont/libXfont-1.4.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-libs/libXfont/libXfont-1.4.3.ebuild b/x11-libs/libXfont/libXfont-1.4.3.ebuild
new file mode 100644
index 000000000000..700cd5e402fb
--- /dev/null
+++ b/x11-libs/libXfont/libXfont-1.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXfont/libXfont-1.4.3.ebuild,v 1.1 2010/10/29 08:56:28 scarabeus Exp $
+
+EAPI=3
+inherit xorg-2
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc ipv6"
+
+RDEPEND="x11-libs/xtrans
+ x11-libs/libfontenc
+ >=media-libs/freetype-2
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/fontsproto
+ doc? ( app-text/xmlto )"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_enable doc devel-docs)
+ $(use_with doc xmlto)
+ --with-bzip2
+ --without-fop"
+}