summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-01-01 14:27:08 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-01-01 14:27:08 +0000
commit979e0b20fa01538d80ef253e787b17ff43b70beb (patch)
tree9824f0ed2e3c0eb789fb2010b7cdf037972cdf2b /x11-libs/libXi
parentVersion bump. (diff)
downloadgentoo-2-979e0b20fa01538d80ef253e787b17ff43b70beb.tar.gz
gentoo-2-979e0b20fa01538d80ef253e787b17ff43b70beb.tar.bz2
gentoo-2-979e0b20fa01538d80ef253e787b17ff43b70beb.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libXi')
-rw-r--r--x11-libs/libXi/ChangeLog11
-rw-r--r--x11-libs/libXi/libXi-1.5.0.ebuild36
-rw-r--r--x11-libs/libXi/libXi-1.5.99.2.ebuild36
3 files changed, 81 insertions, 2 deletions
diff --git a/x11-libs/libXi/ChangeLog b/x11-libs/libXi/ChangeLog
index fc64f4776aa4..8f98e8b5b5c7 100644
--- a/x11-libs/libXi/ChangeLog
+++ b/x11-libs/libXi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libXi
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.131 2011/12/27 21:09:21 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.132 2012/01/01 14:27:08 chithanh Exp $
+
+*libXi-1.5.99.2 (01 Jan 2012)
+*libXi-1.5.0 (01 Jan 2012)
+
+ 01 Jan 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libXi-1.5.0.ebuild, +libXi-1.5.99.2.ebuild:
+ Version bump.
27 Dec 2011; Markus Meier <maekke@gentoo.org> libXi-1.4.3-r1.ebuild:
x86 stable, bug #394393
diff --git a/x11-libs/libXi/libXi-1.5.0.ebuild b/x11-libs/libXi/libXi-1.5.0.ebuild
new file mode 100644
index 000000000000..2339fbfdb9f3
--- /dev/null
+++ b/x11-libs/libXi/libXi-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/libXi-1.5.0.ebuild,v 1.1 2012/01/01 14:27:08 chithanh Exp $
+
+EAPI=4
+
+XORG_DOC=doc
+inherit xorg-2
+
+DESCRIPTION="X.Org Xi library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.3
+ >=x11-libs/libXext-1.1
+ >=x11-proto/inputproto-2.0.99.1
+ >=x11-proto/xproto-7.0.13
+ >=x11-proto/xextproto-7.0.3"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ $(use_with doc asciidoc)
+ --without-fop
+ )
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ ewarn "Some special keys and keyboard layouts may stop working."
+ ewarn "To fix them, recompile xorg-server."
+}
diff --git a/x11-libs/libXi/libXi-1.5.99.2.ebuild b/x11-libs/libXi/libXi-1.5.99.2.ebuild
new file mode 100644
index 000000000000..dc874b1f165c
--- /dev/null
+++ b/x11-libs/libXi/libXi-1.5.99.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/libXi-1.5.99.2.ebuild,v 1.1 2012/01/01 14:27:08 chithanh Exp $
+
+EAPI=4
+
+XORG_DOC=doc
+inherit xorg-2
+
+DESCRIPTION="X.Org Xi library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.3
+ >=x11-libs/libXext-1.1
+ >=x11-proto/inputproto-2.1.99.3
+ >=x11-proto/xproto-7.0.13
+ >=x11-proto/xextproto-7.0.3"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ $(use_with doc asciidoc)
+ --without-fop
+ )
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ ewarn "Some special keys and keyboard layouts may stop working."
+ ewarn "To fix them, recompile xorg-server."
+}